aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-08-18 05:18:18 +0800
committerultima <ultima@FreeBSD.org>2017-08-18 05:18:18 +0800
commit878f1c935ae06e3fc5efc91f9827e0b7fe93b674 (patch)
treee66ab1f4fb8b3d649c92b506984fd7df9e67a908
parent600e54687103dd398ae84b0e51b0358cc768f4d2 (diff)
downloadfreebsd-ports-878f1c935ae06e3fc5efc91f9827e0b7fe93b674.tar.gz
freebsd-ports-878f1c935ae06e3fc5efc91f9827e0b7fe93b674.tar.zst
freebsd-ports-878f1c935ae06e3fc5efc91f9827e0b7fe93b674.zip
MFH: r447919
* Bump Revision to fix ioctl sign-extension warning * Cleanup Makefile PR: 221241 Submitted by: <peo@bsdlabs.com> Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D11993 Approved by: ports-secteam (feld)
-rw-r--r--multimedia/motion/Makefile6
-rw-r--r--multimedia/motion/files/patch-video2.c11
2 files changed, 14 insertions, 3 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index cd7ee6bbf86a..4985e4b30322 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -3,8 +3,8 @@
PORTNAME= motion
PORTVERSION= 4.0.1
-PORTREVISION= 3
DISTVERSIONPREFIX= release-
+PORTREVISION= 4
CATEGORIES= multimedia
MAINTAINER= ports@FreeBSD.org
@@ -13,10 +13,11 @@ COMMENT= Motion detection application
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= autoreconf gmake jpeg localbase pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= Motion-Project
+USE_RC_SUBR= ${PORTNAME}
-USES= autoreconf gmake jpeg localbase pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-linuxthreads \
--without-jpeg-mmx
@@ -26,7 +27,6 @@ KMODDIR?= /boot/modules
KMODDIR= /boot/modules
.endif
-USE_RC_SUBR= ${PORTNAME}
SUB_FILES= pkg-message
PLIST_FILES= bin/motion \
diff --git a/multimedia/motion/files/patch-video2.c b/multimedia/motion/files/patch-video2.c
new file mode 100644
index 000000000000..a0e17aa92445
--- /dev/null
+++ b/multimedia/motion/files/patch-video2.c
@@ -0,0 +1,11 @@
+--- video2.c.orig 2017-08-11 20:05:27 UTC
++++ video2.c
+@@ -184,7 +184,7 @@ typedef struct {
+ /**
+ * xioctl
+ */
+-#ifdef __OpenBSD__
++#if defined (__OpenBSD__) || defined (__FreeBSD__)
+ static int xioctl(src_v4l2_t *vid_source, unsigned long request, void *arg)
+ #else
+ static int xioctl(src_v4l2_t *vid_source, int request, void *arg)