aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2017-09-01 03:29:19 +0800
committerfeld <feld@FreeBSD.org>2017-09-01 03:29:19 +0800
commita38da232c85322290c00104203108cf482046cdd (patch)
tree001b63edbaf0f095bae88cc15b43bb396391f05c
parente6695de237711abe0ca71b73dbee10fe6f7f9eb2 (diff)
downloadfreebsd-ports-a38da232c85322290c00104203108cf482046cdd.tar.gz
freebsd-ports-a38da232c85322290c00104203108cf482046cdd.tar.zst
freebsd-ports-a38da232c85322290c00104203108cf482046cdd.zip
MFH: r448998 r449000 r449020
Add base/port options for libpcap PR: 221923 Approved by: ehaupt (maintainer) Correctly define the _DESC values Reported by: ehaupt,mat Fix OPTIONS_SINGLE logic. The two options (LIBPCAP_BASE and LIBPCAP_PORTS) need to be mutually exclusive. If LIBPCAP_BASE is selected, make sure the binary is linked against the libpcap from base, even if net/libpcap is present. Bump PORTREVISION to make sure the OPTIONS change is tracked. Reported by: jbeich Approved by: ports-secteam (with hat)
-rw-r--r--net-mgmt/tcpreplay/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/net-mgmt/tcpreplay/Makefile b/net-mgmt/tcpreplay/Makefile
index f0d1cbe3fc95..43c436cae3af 100644
--- a/net-mgmt/tcpreplay/Makefile
+++ b/net-mgmt/tcpreplay/Makefile
@@ -4,6 +4,7 @@
PORTNAME= tcpreplay
PORTVERSION= 4.2.6
DISTVERSIONPREFIX= v
+PORTREVISION= 3
CATEGORIES= net-mgmt
MAINTAINER= ehaupt@FreeBSD.org
@@ -27,6 +28,17 @@ CONFIGURE_ARGS= --program-transform-name='s|.*\(tcp.*\)|\1|' \
# required when using autogen
CONFIGURE_ARGS+= --disable-local-libopts --disable-libopts-install
+LIBPCAP_BASE_DESC= Build with libpcap from the base OS
+LIBPCAP_PORTS_DESC= Build with net/libpcap
+
+OPTIONS_SINGLE= LIBPCAP
+OPTIONS_SINGLE_LIBPCAP= LIBPCAP_BASE LIBPCAP_PORTS
+
+OPTIONS_DEFAULT= LIBPCAP_BASE
+
+LIBPCAP_BASE_CONFIGURE_ON= --with-libpcap=/usr/lib
+LIBPCAP_PORTS_LIB_DEPENDS= libpcap.so:net/libpcap
+
post-patch:
@${REINPLACE_CMD} -e 's|-Wall -O3||' ${WRKSRC}/${CONFIGURE_SCRIPT}.ac