aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2019-03-31 06:05:26 +0800
committersunpoet <sunpoet@FreeBSD.org>2019-03-31 06:05:26 +0800
commit01042f6ba88d54cd3b422b0752855c92bdf3d676 (patch)
tree38145e15e8bc43a91b52feb99413fe96bb169d79
parent1e88f8c3a1882fb732bb1ca8287c9fd7a4f0badb (diff)
downloadfreebsd-ports-01042f6ba88d54cd3b422b0752855c92bdf3d676.tar.gz
freebsd-ports-01042f6ba88d54cd3b422b0752855c92bdf3d676.tar.zst
freebsd-ports-01042f6ba88d54cd3b422b0752855c92bdf3d676.zip
MFH: r497122
Fix CVE-2018-5727 - Bump PORTREVISION for possible package change Obtained from: https://github.com/uclouvain/openjpeg/commit/d6b8aed5612e6be6d3a4053867fbd2ae0cb7c8af Security: 5efd7a93-2dfb-11e9-9549-e980e869c2e9 Approved by: ports-secteam (joneum)
-rw-r--r--graphics/openjpeg/Makefile5
-rw-r--r--graphics/openjpeg/files/patch-src-lib-openjp2-t1.c24
2 files changed, 27 insertions, 2 deletions
diff --git a/graphics/openjpeg/Makefile b/graphics/openjpeg/Makefile
index b81c8069281c..3cba946ea485 100644
--- a/graphics/openjpeg/Makefile
+++ b/graphics/openjpeg/Makefile
@@ -3,8 +3,8 @@
PORTNAME= openjpeg
PORTVERSION= 2.3.0
-PORTREVISION= 3
DISTVERSIONPREFIX= v
+PORTREVISION= 4
CATEGORIES= graphics
MAINTAINER= sunpoet@FreeBSD.org
@@ -18,9 +18,10 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
libpng.so:graphics/png \
libtiff.so:graphics/tiff
-USE_LDCONFIG= yes
USES= cmake cpe pkgconfig
+USE_LDCONFIG= yes
+
PLIST_SUB= PORTVERSION=${PORTVERSION} VER=${PORTVERSION:R}
GH_ACCOUNT= uclouvain
diff --git a/graphics/openjpeg/files/patch-src-lib-openjp2-t1.c b/graphics/openjpeg/files/patch-src-lib-openjp2-t1.c
new file mode 100644
index 000000000000..77d16c031d6a
--- /dev/null
+++ b/graphics/openjpeg/files/patch-src-lib-openjp2-t1.c
@@ -0,0 +1,24 @@
+Obtained from: https://github.com/uclouvain/openjpeg/commit/d6b8aed5612e6be6d3a4053867fbd2ae0cb7c8af
+
+--- src/lib/openjp2/t1.c.orig 2017-10-04 22:23:14 UTC
++++ src/lib/openjp2/t1.c
+@@ -2168,9 +2168,18 @@ OPJ_BOOL opj_t1_encode_cblks(opj_t1_t *t
+ t1->data = tiledp;
+ t1->data_stride = tile_w;
+ if (tccp->qmfbid == 1) {
++ /* Do multiplication on unsigned type, even if the
++ * underlying type is signed, to avoid potential
++ * int overflow on large value (the output will be
++ * incorrect in such situation, but whatever...)
++ * This assumes complement-to-2 signed integer
++ * representation
++ * Fixes https://github.com/uclouvain/openjpeg/issues/1053
++ */
++ OPJ_UINT32* OPJ_RESTRICT tiledp_u = (OPJ_UINT32*) tiledp;
+ for (j = 0; j < cblk_h; ++j) {
+ for (i = 0; i < cblk_w; ++i) {
+- tiledp[tileIndex] *= (1 << T1_NMSEDEC_FRACBITS);
++ tiledp_u[tileIndex] <<= T1_NMSEDEC_FRACBITS;
+ tileIndex++;
+ }
+ tileIndex += tileLineAdvance;
ch2018-03-191-1/+4 * Mark unbroken on actual hardware for e.g. armvX. It is known to runawayMark Linimon2018-03-191-0/+4 * mail/courier: Unbreak by fixing shebangYuri Victorovich2018-03-191-0/+6 * mail/dkimproxy: Change url of detail webpageDanilo G. Baio2018-03-182-7/+8 * mail/postgrey: Add reload command in rcfileDanilo G. Baio2018-03-182-0/+2 * Mark as broken on armvX.Mark Linimon2018-03-181-4/+5 * Mark as broken on armvX. This is probably a holdover from ancient code.Mark Linimon2018-03-181-2/+4 * mail/milter-greylist: Add configtest command in rcfileDanilo G. Baio2018-03-183-3/+4 * devel/oniguruma: Update to 6.8.0Yuri Victorovich2018-03-181-0/+1 * Fix order of variablesDanilo G. Baio2018-03-173-6/+7 * - Unbreak patchVsevolod Stakhov2018-03-171-49/+1 * Update rspamd port to 1.7.0Vsevolod Stakhov2018-03-175-179/+516 * Update to 1.10.2Sunpoet Po-Chuan Hsieh2018-03-162-4/+4 * Update to 1.10.2Sunpoet Po-Chuan Hsieh2018-03-162-4/+4 * Update to 1.03Sunpoet Po-Chuan Hsieh2018-03-162-4/+4 * - update to 1.1.Alpha9.0Dirk Meyer2018-03-152-6/+6 * Move security/qtkeychain-qt[45] to security/qtkeychain and create flavorsTobias C. Berner2018-03-131-2/+2 * UnbreakAntoine Brodin2018-03-121-1/+1 * Migrate USE_APACHE to USES= apacheBernard Spil2018-03-122-2/+2 * Bump PORTREVISIONs of all users of math/mpc that we just updated toGerald Pfeifer2018-03-116-5/+6 * Un-break with SSL OPTION (default)Thomas Zander2018-03-102-3/+27 * Update to 0.7.1Tilman Keskinoz2018-03-102-4/+4 * Introduce PHP flavors.Mathieu Arnold2018-03-0920-34/+33 * - fix "exited on signal 11" when dhparams file is missing.Dirk Meyer2018-03-082-41/+24 * mail/mutt: Fix for NNTP=onYuri Victorovich2018-03-081-0/+1 * Update to 3.009Sunpoet Po-Chuan Hsieh2018-03-073-6/+5 * Update to 1.909Sunpoet Po-Chuan Hsieh2018-03-072-3/+8 * www/claws-mail: Take MaintainershipJochen Neumeister2018-03-071-1/+1 * Fix build on 10.X. mail/mu4e requires no C++ compiler.Hiroki Sato2018-03-061-4/+7 * mail/rspamd: Backport upstream patch for reject-message with FreeBSD libmilterMahdi Mokhtari2018-03-062-0/+114 * Fix build on 10.X. mail/mu requires C++14 compiler.Hiroki Sato2018-03-051-1/+2 * - fix build with openssl 1.1 and libresslDirk Meyer2018-03-053-1/+185 * mail/py-authres: Update to 1.1.0Kubilay Kocak2018-03-042-4/+4 * mail/mutt: Update to 1.9.4Yuri Victorovich2018-03-04