aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2019-03-14 08:54:38 +0800
committerjbeich <jbeich@FreeBSD.org>2019-03-14 08:54:38 +0800
commit16d8c85abc5966b92b0f94e18b6870d035c4373d (patch)
tree511d3293b0d2e8a24b56e19795406b858e7330e5
parente3f56287a640ac7af37f9fc177ce9d6723d81172 (diff)
downloadfreebsd-ports-16d8c85abc5966b92b0f94e18b6870d035c4373d.tar.gz
freebsd-ports-16d8c85abc5966b92b0f94e18b6870d035c4373d.tar.zst
freebsd-ports-16d8c85abc5966b92b0f94e18b6870d035c4373d.zip
MFH: r494760 r495669
games/openbor: unbreak with GCC 4.2 cc1: error: unrecognized command line option "-Wno-unused-result" source/gamelib/loadimg.o:(.text+0x1ce8): undefined reference to `__builtin_unreachable' source/gamelib/loadimg.o:(.text+0x2164): undefined reference to `__builtin_unreachable' Reported by: pkg-fallout Approved by: ports-secteam blanket
-rw-r--r--games/openbor/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index e5b818aadfb2..acd59f1226fb 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -81,6 +81,7 @@ post-patch:
@${REINPLACE_CMD} -e 's/ -O[0-9]//; s/ -g//; s/ -Werror//' \
-e 's/ -fomit-frame-pointer//' \
-e 's/ -freorder-blocks//' \
+ -e 's/ -Wno-unused-result//' \
-e 's/ -Wl,-rpath,$$(LIBRARIES)//' \
-e '/echo/!s/ @/ /' \
-e 's/@echo/@$$(ECHO)/' \
@@ -88,6 +89,8 @@ post-patch:
${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's/\.openbor/.${PKGBASE}/' \
${WRKSRC}/sdl/sdlport.c
+ @${REINPLACE_CMD} -e 's/__builtin_unreachable/__unreachable/' \
+ ${WRKSRC}/source/gamelib/loadimg.c
@${GREP} -Flr 'malloc.h' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
's,malloc\.h,stdlib.h,'
@${REINPLACE_CMD} -e 's/^function \(.*\) {/\1() {/' \