aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordim <dim@FreeBSD.org>2019-02-28 05:50:17 +0800
committerdim <dim@FreeBSD.org>2019-02-28 05:50:17 +0800
commitb4f9ea65b277629525b64d78c4ca009c42091799 (patch)
tree365143c3047cf2f3f1aff9007aa3c271b5d3444b
parent10ab956baa1cbd357091dbd77559d1f9e6b65387 (diff)
downloadfreebsd-ports-b4f9ea65b277629525b64d78c4ca009c42091799.tar.gz
freebsd-ports-b4f9ea65b277629525b64d78c4ca009c42091799.tar.zst
freebsd-ports-b4f9ea65b277629525b64d78c4ca009c42091799.zip
MFH: r493979
With libc++ 8.0, which is in the projects/clang800-import branch, and which will soon be merged to head, compilation of devel/jsoncpp fails due to a conflict between the new C++ <version> header, and a local file "version" which is produced by jsoncpp during its configure phase. This is due to the initial test runner being compiled with "-I.", even though it does not need any file from the port's working directory root. Therefore, it seems to be easiest to comment out the line from the SConstruct script that adds the "-I." option. Approved by: portmgr (joneum) PR: 236061
-rw-r--r--devel/jsoncpp/Makefile2
-rw-r--r--devel/jsoncpp/files/patch-SConstruct7
2 files changed, 7 insertions, 2 deletions
diff --git a/devel/jsoncpp/Makefile b/devel/jsoncpp/Makefile
index 3fd277f3a0fd..a6834e22d617 100644
--- a/devel/jsoncpp/Makefile
+++ b/devel/jsoncpp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= jsoncpp
PORTVERSION= 1.8.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
diff --git a/devel/jsoncpp/files/patch-SConstruct b/devel/jsoncpp/files/patch-SConstruct
index 38dc7960fcb7..02cb53edee00 100644
--- a/devel/jsoncpp/files/patch-SConstruct
+++ b/devel/jsoncpp/files/patch-SConstruct
@@ -38,7 +38,7 @@
if 'TarGz' in env['BUILDERS']:
class SrcDistAdder:
def __init__( self, env ):
-@@ -164,7 +170,7 @@ env['SRCDIST_ADD'] = SrcDistAdder( env )
+@@ -164,11 +170,11 @@ env['SRCDIST_ADD'] = SrcDistAdder( env )
env['SRCDIST_TARGET'] = os.path.join( DIST_DIR, 'jsoncpp-src-%s.tar.gz' % env['JSONCPP_VERSION'] )
env_testing = env.Clone( )
@@ -47,6 +47,11 @@
def buildJSONExample( env, target_sources, target_name ):
env = env.Clone()
+- env.Append( CPPPATH = ['#'] )
++ #env.Append( CPPPATH = ['#'] )
+ exe = env.Program( target=target_name,
+ source=target_sources )
+ env['SRCDIST_ADD']( source=[target_sources] )
@@ -187,14 +193,14 @@ def buildUnitTests( env, target_sources,
env.AlwaysBuild( check_alias_target )