aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-05-24 18:14:57 +0800
committerKubilay Kocak <koobs@FreeBSD.org>2019-05-24 18:14:57 +0800
commite66addbe22fef8429e959af12c4336aa2dae5bbd (patch)
tree704bf0da092283f783f05cedea657347677b6b35
parent658e110b8b2004b5ba98ae82f9d2c5235f0bf336 (diff)
downloadfreebsd-ports-e66addbe22fef8429e959af12c4336aa2dae5bbd.tar.gz
freebsd-ports-e66addbe22fef8429e959af12c4336aa2dae5bbd.tar.zst
freebsd-ports-e66addbe22fef8429e959af12c4336aa2dae5bbd.zip
MFH: devel/py-buildbot{-*}: Update to 2.2.0 (r500101 r500102 r500578)
buildbot: - Now python 3 only (3.5+) - Add missing tests_requires to setup.py buildbot-worker: - Retains Python 2/3 compatibility - Remove setup.py patch (upstreamed) Changelog: https://docs.buildbot.net/current/relnotes/index.html#buildbot-2-2-0-2019-04-07 Security: 5536ea5f-6814-11e9-a8f7-0050562a4d7b Unbreak devel/py-buildbot-*: Limit to Python 3.5+ These packages only support Python 3.x [1], currently failing to build: File "/usr/local/lib/python2.7/site-packages/buildbot_pkg.py", line 254, in run super().run() TypeError: super() takes at least 1 argument (0 given) antoine@ fixed fallout in py-buildbot-www in ports r500102 [1] https://github.com/buildbot/buildbot/commit/403722c20e7f96707be3d15db54b25f472b8a525 Reported by: pkg-fallout Approved by: ports-secteam (joneum (r500101), blanket: build fix)
Notes
Notes: svn path=/branches/2019Q2/; revision=502446
-rw-r--r--devel/py-buildbot-console-view/Makefile4
-rw-r--r--devel/py-buildbot-console-view/distinfo6
-rw-r--r--devel/py-buildbot-grid-view/Makefile4
-rw-r--r--devel/py-buildbot-grid-view/distinfo6
-rw-r--r--devel/py-buildbot-pkg/Makefile4
-rw-r--r--devel/py-buildbot-pkg/distinfo6
-rw-r--r--devel/py-buildbot-waterfall-view/Makefile4
-rw-r--r--devel/py-buildbot-waterfall-view/distinfo6
-rw-r--r--devel/py-buildbot-worker/Makefile15
-rw-r--r--devel/py-buildbot-worker/distinfo6
-rw-r--r--devel/py-buildbot-worker/files/patch-setup.py46
-rw-r--r--devel/py-buildbot-www/Makefile6
-rw-r--r--devel/py-buildbot-www/distinfo6
-rw-r--r--devel/py-buildbot/Makefile26
-rw-r--r--devel/py-buildbot/distinfo6
-rw-r--r--devel/py-buildbot/files/patch-setup.py11
16 files changed, 58 insertions, 104 deletions
diff --git a/devel/py-buildbot-console-view/Makefile b/devel/py-buildbot-console-view/Makefile
index c11908adcd5b..df6c47483d50 100644
--- a/devel/py-buildbot-console-view/Makefile
+++ b/devel/py-buildbot-console-view/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= buildbot-console-view
-PORTVERSION= 1.5.0
+PORTVERSION= 2.2.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +16,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}buildbot-pkg>=${PORTVERSION}:devel/py-buildbot-pkg@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}buildbot-pkg>=${PORTVERSION}:devel/py-buildbot-pkg@${PY_FLAVOR}
-USES= python
+USES= python:3.5+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/devel/py-buildbot-console-view/distinfo b/devel/py-buildbot-console-view/distinfo
index 3bd2c369f6c2..67b16875b5cb 100644
--- a/devel/py-buildbot-console-view/distinfo
+++ b/devel/py-buildbot-console-view/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541214151
-SHA256 (buildbot-console-view-1.5.0.tar.gz) = 698e1d2966ca29220e1ab7a246f6f5c492b82bea640a96c22fe541b2d135e7ad
-SIZE (buildbot-console-view-1.5.0.tar.gz) = 641186
+TIMESTAMP = 1556272383
+SHA256 (buildbot-console-view-2.2.0.tar.gz) = 544b04aa7835150e2c16231fe709ed2c2a4f2fa9da365a6cc97164645d020542
+SIZE (buildbot-console-view-2.2.0.tar.gz) = 641078
diff --git a/devel/py-buildbot-grid-view/Makefile b/devel/py-buildbot-grid-view/Makefile
index 800c918b5088..1831ae8f8d94 100644
--- a/devel/py-buildbot-grid-view/Makefile
+++ b/devel/py-buildbot-grid-view/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= buildbot-grid-view
-PORTVERSION= 1.5.0
+PORTVERSION= 2.2.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +15,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}buildbot-pkg>=${PORTVERSION}:devel/py-buildbot-pkg@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}buildbot-pkg>=${PORTVERSION}:devel/py-buildbot-pkg@${PY_FLAVOR}
-USES= python
+USES= python:3.5+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/devel/py-buildbot-grid-view/distinfo b/devel/py-buildbot-grid-view/distinfo
index 9087de46b075..9388347a17ee 100644
--- a/devel/py-buildbot-grid-view/distinfo
+++ b/devel/py-buildbot-grid-view/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541214745
-SHA256 (buildbot-grid-view-1.5.0.tar.gz) = abc1504e8ecacf92d0f72854dd670618d7926ad168eff5621594bffaec01e757
-SIZE (buildbot-grid-view-1.5.0.tar.gz) = 639274
+TIMESTAMP = 1556272539
+SHA256 (buildbot-grid-view-2.2.0.tar.gz) = 4eab84f6ef8e9b95bdf3aca2762bca658f1cc1309b3fa638c05ff983283e0b44
+SIZE (buildbot-grid-view-2.2.0.tar.gz) = 639371
diff --git a/devel/py-buildbot-pkg/Makefile b/devel/py-buildbot-pkg/Makefile
index 357eeb1019e5..57fbc1d94325 100644
--- a/devel/py-buildbot-pkg/Makefile
+++ b/devel/py-buildbot-pkg/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= buildbot-pkg
-PORTVERSION= 1.5.0
+PORTVERSION= 2.2.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,7 @@ COMMENT= Buildbot packaging tools
LICENSE= GPLv2
#LICENSE_FILE= Not packaged in sdist
-USES= python
+USES= python:3.5+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/devel/py-buildbot-pkg/distinfo b/devel/py-buildbot-pkg/distinfo
index 0ff358521db8..16e64be621ea 100644
--- a/devel/py-buildbot-pkg/distinfo
+++ b/devel/py-buildbot-pkg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541214448
-SHA256 (buildbot-pkg-1.5.0.tar.gz) = 4646dfbcedaf81d258609a1186708de0f1902d176aed64d3c86c3020288cd4de
-SIZE (buildbot-pkg-1.5.0.tar.gz) = 4856
+TIMESTAMP = 1556272576
+SHA256 (buildbot-pkg-2.2.0.tar.gz) = 5ce994a72d8f893678a5d12764c43ac1c4e4618235f40b0041a874fc424dcf8e
+SIZE (buildbot-pkg-2.2.0.tar.gz) = 4895
diff --git a/devel/py-buildbot-waterfall-view/Makefile b/devel/py-buildbot-waterfall-view/Makefile
index 6abe316e6d48..b82ea2590ea9 100644
--- a/devel/py-buildbot-waterfall-view/Makefile
+++ b/devel/py-buildbot-waterfall-view/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= buildbot-waterfall-view
-PORTVERSION= 1.5.0
+PORTVERSION= 2.2.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +16,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}buildbot-pkg>=${PORTVERSION}:devel/py-buildbot-pkg@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}buildbot-pkg>=${PORTVERSION}:devel/py-buildbot-pkg@${PY_FLAVOR}
-USES= python
+USES= python:3.5+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/devel/py-buildbot-waterfall-view/distinfo b/devel/py-buildbot-waterfall-view/distinfo
index f65e59095c56..6f2501c201e0 100644
--- a/devel/py-buildbot-waterfall-view/distinfo
+++ b/devel/py-buildbot-waterfall-view/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541214915
-SHA256 (buildbot-waterfall-view-1.5.0.tar.gz) = d1ab3bd9027d8ca387ef508f657f9a0dec4ffd9d00708cdb3df6a113fbc4d37c
-SIZE (buildbot-waterfall-view-1.5.0.tar.gz) = 714352
+TIMESTAMP = 1556272622
+SHA256 (buildbot-waterfall-view-2.2.0.tar.gz) = aabad8ee508b76dececcf1feb0e5aa8e9bb2db700e9140e2721bf68fd209351f
+SIZE (buildbot-waterfall-view-2.2.0.tar.gz) = 714129
diff --git a/devel/py-buildbot-worker/Makefile b/devel/py-buildbot-worker/Makefile
index c665686237bd..601778c3b5f8 100644
--- a/devel/py-buildbot-worker/Makefile
+++ b/devel/py-buildbot-worker/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= buildbot-worker
-PORTVERSION= 1.5.0
+PORTVERSION= 2.2.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,8 @@ COMMENT= Buildbot Worker Daemon
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=17.9.0:devel/py-twisted@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
USES= python
@@ -26,14 +27,6 @@ NO_ARCH= yes
PLIST_FILES= man/man1/buildbot-worker.1.gz
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_VER} >= 3.0
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}twisted>=17.9.0:devel/py-twisted@${PY_FLAVOR}
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}twisted>=16.1.0:devel/py-twisted@${PY_FLAVOR}
-.endif
-
post-install:
${INSTALL_MAN} ${WRKSRC}/docs/buildbot-worker.1 ${STAGEDIR}${MANPREFIX}/man/man1
@@ -41,4 +34,4 @@ do-test:
${MKDIR} ${WRKDIR}/tmp
cd ${WRKDIR}/tmp && PYTHONPATH=${WRKSRC} ${PYTHON_CMD} -m twisted.trial buildbot_worker.test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-buildbot-worker/distinfo b/devel/py-buildbot-worker/distinfo
index 0636b5ed7a89..565816ef2a8d 100644
--- a/devel/py-buildbot-worker/distinfo
+++ b/devel/py-buildbot-worker/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541212854
-SHA256 (buildbot-worker-1.5.0.tar.gz) = 533e4fd3cacddcfa8e4b5c33c3d021b7bda3a437ba4d9c23c1a1a0df0e5233bc
-SIZE (buildbot-worker-1.5.0.tar.gz) = 105814
+TIMESTAMP = 1556271718
+SHA256 (buildbot-worker-2.2.0.tar.gz) = dd2353a207fce1e1c6df656333051ff1b979bd80d12f7559c17136a23ae438dc
+SIZE (buildbot-worker-2.2.0.tar.gz) = 110244
diff --git a/devel/py-buildbot-worker/files/patch-setup.py b/devel/py-buildbot-worker/files/patch-setup.py
deleted file mode 100644
index 1d087a0b9245..000000000000
--- a/devel/py-buildbot-worker/files/patch-setup.py
+++ /dev/null
@@ -1,46 +0,0 @@
-# modernize buildbot_worker setup.py with package_data
-# https://github.com/buildbot/buildbot/pull/4394
-
---- setup.py.orig 2018-10-09 18:37:18 UTC
-+++ setup.py
-@@ -31,23 +31,6 @@ from distutils.core import setup
- from buildbot_worker import version
-
-
--class our_install_data(install_data):
--
-- def finalize_options(self):
-- self.set_undefined_options('install',
-- ('install_lib', 'install_dir'),
-- )
-- install_data.finalize_options(self)
--
-- def run(self):
-- install_data.run(self)
-- # ensure there's a buildbot_worker/VERSION file
-- fn = os.path.join(self.install_dir, 'buildbot_worker', 'VERSION')
-- with open(fn, 'w') as f:
-- f.write(version)
-- self.outfiles.append(fn)
--
--
- class our_sdist(sdist):
-
- def make_release_tree(self, base_dir, files):
-@@ -105,11 +88,12 @@ setup_args = {
- "buildbot_worker.test.unit",
- "buildbot_worker.test.util",
- ],
-- # mention data_files, even if empty, so install_data is called and
-- # VERSION gets copied
-- 'data_files': [("buildbot_worker", [])],
-+ 'package_data': {
-+ '': [
-+ 'VERSION',
-+ ]
-+ },
- 'cmdclass': {
-- 'install_data': our_install_data,
- 'sdist': our_sdist
- },
- 'entry_points': {
diff --git a/devel/py-buildbot-www/Makefile b/devel/py-buildbot-www/Makefile
index 3ad4ef8b7932..d3adf5d441dd 100644
--- a/devel/py-buildbot-www/Makefile
+++ b/devel/py-buildbot-www/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= buildbot-www
-PORTVERSION= 1.5.0
+PORTVERSION= 2.2.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,13 +15,13 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}buildbot>=${PORTVERSION}:devel/py-buildbot@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}buildbot-pkg>=${PORTVERSION}:devel/py-buildbot-pkg@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mock>0.8.0:devel/py-mock@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}buildbot-console-view>=${PORTVERSION}:devel/py-buildbot-console-view@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}buildbot-grid-view>=${PORTVERSION}:devel/py-buildbot-grid-view@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}buildbot-waterfall-view>=${PORTVERSION}:devel/py-buildbot-waterfall-view@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}service_identity>=16.0.0:security/py-service_identity@${PY_FLAVOR}
-USES= python
+USES= python:3.5+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/devel/py-buildbot-www/distinfo b/devel/py-buildbot-www/distinfo
index d38acc2266de..6e2fe1138930 100644
--- a/devel/py-buildbot-www/distinfo
+++ b/devel/py-buildbot-www/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541214992
-SHA256 (buildbot-www-1.5.0.tar.gz) = 4204477dc67ed42443d1f03cd9189a0e57d9d3d7c4662df306e8e29c9d3d5a46
-SIZE (buildbot-www-1.5.0.tar.gz) = 718533
+TIMESTAMP = 1556272660
+SHA256 (buildbot-www-2.2.0.tar.gz) = 23d25ab7af29d7bcb598ba25c2a97e0cb53533b6d652510b7e611897fcc41075
+SIZE (buildbot-www-2.2.0.tar.gz) = 719814
diff --git a/devel/py-buildbot/Makefile b/devel/py-buildbot/Makefile
index 718268697e20..3afa10e89598 100644
--- a/devel/py-buildbot/Makefile
+++ b/devel/py-buildbot/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= buildbot
-PORTVERSION= 1.5.0
-PORTREVISION= 2
+PORTVERSION= 2.2.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,9 +15,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>=2.1:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}autobahn>=0.16.0:www/py-autobahn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}twisted>=17.9.0:devel/py-twisted@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zope.interface>=4.1.1:devel/py-zope.interface@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}future>=0.15.2:devel/py-future@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy12>=0.8.0:databases/py-sqlalchemy12@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy12>=1.1.0:databases/py-sqlalchemy12@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlalchemy-migrate>=0.9:databases/py-sqlalchemy-migrate@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>=1.5:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}txaio>=2.2.2:devel/py-txaio@${PY_FLAVOR} \
@@ -33,8 +33,9 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}treq>0:www/py-treq@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}buildbot-pkg>0:devel/py-buildbot-pkg@${PY_FLAVOR}
# to be ported ${PYTHON_PKGNAMEPREFIX}pyjade>0:www/py-pyjade@${PY_FLAVOR}
# to be ported ${PYTHON_PKGNAMEPREFIX}moto>0:www/py-moto@${PY_FLAVOR}
+# to be ported ${PYTHON_PKGNAMEPREFIX}parameterized>0:devel/py-parametrized@${PY_FLAVOR}
-USES= python
+USES= python:3.5+
USE_RC_SUBR= buildbot
USE_PYTHON= autoplist concurrent distutils
@@ -42,16 +43,11 @@ SUB_LIST= PYTHON_CMD=${PYTHON_CMD} PYTHON_VER=${PYTHON_VER}
NO_ARCH= yes
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_VER} >= 3.0
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}twisted>=17.9.0:devel/py-twisted@${PY_FLAVOR}
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}twisted>=16.1.0:devel/py-twisted@${PY_FLAVOR}
-.endif
-
do-test:
- ${MKDIR} ${WRKDIR}/tmp
- cd ${WRKDIR}/tmp && PYTHONPATH=${WRKSRC} ${PYTHON_CMD} -m twisted.trial buildbot.test
+ @cd ${WRKSRC} && TZ=UTC ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+# Old invocation that we will probably need later
+# ${MKDIR} ${WRKDIR}/tmp
+# cd ${WRKDIR}/tmp && TZ=UTC LANG=C PYTHONPATH=${WRKSRC} ${PYTHON_CMD} -m twisted.trial buildbot.test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-buildbot/distinfo b/devel/py-buildbot/distinfo
index 6db0f41e5bbf..db912fcf6b3a 100644
--- a/devel/py-buildbot/distinfo
+++ b/devel/py-buildbot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541129797
-SHA256 (buildbot-1.5.0.tar.gz) = d02a717222bcdc98205624c7d6b0b2ae24653170f2971946f26bf8cadea4fd52
-SIZE (buildbot-1.5.0.tar.gz) = 3191364
+TIMESTAMP = 1556250817
+SHA256 (buildbot-2.2.0.tar.gz) = c16d7360316af4e433f28ff60574b2b6cf4e52ad1f2b17e83c94a108edf92650
+SIZE (buildbot-2.2.0.tar.gz) = 3129058
diff --git a/devel/py-buildbot/files/patch-setup.py b/devel/py-buildbot/files/patch-setup.py
new file mode 100644
index 000000000000..cc264adce6e0
--- /dev/null
+++ b/devel/py-buildbot/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2019-04-07 13:12:23 UTC
++++ setup.py
+@@ -486,6 +486,8 @@ test_deps = [
+ 'boto3',
+ 'moto',
+ 'mock>=2.0.0',
++ 'parameterized',
++ 'buildbot-worker',
+ ]
+ if sys.platform != 'win32':
+ test_deps += [