aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-22 07:52:37 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-22 07:52:37 +0800
commitd92159e623f6d6aa22976afecb662f299f46dc25 (patch)
tree43e3e96b51c1b5ffe0081b680c450409ce4bb954 /biology
parent173ef5b72bc329eaf5be116b2994334e00137d30 (diff)
downloadfreebsd-ports-d92159e623f6d6aa22976afecb662f299f46dc25.tar.gz
freebsd-ports-d92159e623f6d6aa22976afecb662f299f46dc25.tar.zst
freebsd-ports-d92159e623f6d6aa22976afecb662f299f46dc25.zip
Mark as broken on aarch64, and, where appropriate, armvX.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'biology')
-rw-r--r--biology/canu/Makefile4
-rw-r--r--biology/freebayes/Makefile4
-rw-r--r--biology/pear-merger/Makefile4
-rw-r--r--biology/trimadap/Makefile4
4 files changed, 16 insertions, 0 deletions
diff --git a/biology/canu/Makefile b/biology/canu/Makefile
index 19ab1b85b2fb..c6c0f25ea3d7 100644
--- a/biology/canu/Makefile
+++ b/biology/canu/Makefile
@@ -11,6 +11,10 @@ COMMENT= Single molecule sequence assembler
LICENSE= GPLv2
LICENSE_FILE= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/README.license.GPL
+BROKEN_aarch64= fails to link: undefined reference to omp_set_num_threads
+BROKEN_armv6= fails to install: mv: rename site_perl to /wrkdirs/usr/ports/biology/canu/work/canu-1.7/src/usr/local/FreeBSD-armv6/lib/perl5/site_perl: No such file or directory
+BROKEN_armv7= fails to install: mv: rename site_perl to /wrkdirs/usr/ports/biology/canu/work/canu-1.7/src/usr/local/FreeBSD-armv7/lib/perl5/site_perl: No such file or directory
+
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
RUN_DEPENDS= gnuplot:math/gnuplot
diff --git a/biology/freebayes/Makefile b/biology/freebayes/Makefile
index 3d1fa422be62..9efc560da37e 100644
--- a/biology/freebayes/Makefile
+++ b/biology/freebayes/Makefile
@@ -10,6 +10,10 @@ COMMENT= Bayesian haplotype-based polymorphism discovery and genotyping
LICENSE= MIT
+BROKEN_aarch64= fails to compile: invalid conversion between vector type and integer type
+BROKEN_armv6= fails to compile: invalid conversion between vector type and integer type
+BROKEN_armv7= fails to compile: invalid conversion between vector type and integer type
+
# Submodules use older versions than the ports, so we cannot safely unbundle
# No shared libs are built by the submodules so there will be no conflicts
USES= gmake tar:xz
diff --git a/biology/pear-merger/Makefile b/biology/pear-merger/Makefile
index dee206c9dd84..d9a9a3985bcc 100644
--- a/biology/pear-merger/Makefile
+++ b/biology/pear-merger/Makefile
@@ -14,6 +14,10 @@ COMMENT= Memory-efficient and highly accurate paired-end read merger
LICENSE= CC-BY-NC-SA-3.0
+BROKEN_aarch64= fails to compile: invokes x86 assembler
+BROKEN_armv6= fails to compile: invokes x86 assembler
+BROKEN_armv7= fails to compile: invokes x86 assembler
+
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
diff --git a/biology/trimadap/Makefile b/biology/trimadap/Makefile
index 21e8a9b4e149..565e42f7c40e 100644
--- a/biology/trimadap/Makefile
+++ b/biology/trimadap/Makefile
@@ -10,6 +10,10 @@ COMMENT= Trim adapter sequences from Illumina data using heuristic rules
LICENSE= GPLv2
+BROKEN_aarch64= fails to compile: invalid conversion between vector type and integer type
+BROKEN_armv6= fails to compile: invalid conversion between vector type and integer type
+BROKEN_armv7= fails to compile: invalid conversion between vector type and integer type
+
USE_GITHUB= yes
GH_ACCOUNT= lh3