aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-05-27 13:26:56 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-05-27 13:26:56 +0800
commitda8894bebc36c9681d531713fb4dc7591cb4d330 (patch)
treee6d612ef0646a1cd47ebc2990b12e09c1ce0b291 /devel
parentb8405859bd365881405c2969cbfea36a035f9255 (diff)
downloadfreebsd-ports-da8894bebc36c9681d531713fb4dc7591cb4d330.tar.gz
freebsd-ports-da8894bebc36c9681d531713fb4dc7591cb4d330.tar.zst
freebsd-ports-da8894bebc36c9681d531713fb4dc7591cb4d330.zip
Respect CFLAGS: particularly, do not pass `-march=native' which some
compilers do not like, which in turn might break the build.
Notes
Notes: svn path=/head/; revision=441826
Diffstat (limited to 'devel')
-rw-r--r--devel/rapidjson/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/devel/rapidjson/Makefile b/devel/rapidjson/Makefile
index f85c81f6a8b8..21e443f93cda 100644
--- a/devel/rapidjson/Makefile
+++ b/devel/rapidjson/Makefile
@@ -20,8 +20,6 @@ BROKEN_armv6= does not build: c++: error: the clang compiler does not support -
BROKEN_sparc64= does not build: c++: error: the clang compiler does not support -march=native
BROKEN_powerpc64= does not build: c++: error: the clang compiler does not support -march=native
-DOXYGEN_BUILD_DEPENDS+= doxygen:devel/doxygen
-
USE_GITHUB= yes
GH_ACCOUNT= miloyip
@@ -31,6 +29,7 @@ OPTIONS_DEFINE= DOXYGEN EXAMPLES
OPTIONS_DEFAULT=${OPTIONS_DEFINE}
OPTIONS_SUB= yes
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_CMAKE_ON= -DRAPIDJSON_BUILD_DOC:BOOL=ON
DOXYGEN_CMAKE_OFF= -DRAPIDJSON_BUILD_DOC:BOOL=OFF
EXAMPLES_CMAKE_ON= -DRAPIDJSON_BUILD_EXAMPLES:BOOL=ON
@@ -44,7 +43,7 @@ DATADIR= ${PREFIX}/share/doc/RapidJSON
PORTDATA= *
post-patch:
- @${REINPLACE_CMD} -e 's|DOC_INSTALL_DIR}/examples"|CMAKE_INSTALL_PREFIX}/share/examples/${PORTNAME}"|' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|DOC_INSTALL_DIR}/examples"|CMAKE_INSTALL_PREFIX}/share/examples/${PORTNAME}"| ; s| -march=native||' ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e 's|-Werror||' ${WRKSRC}/example/CMakeLists.txt ${WRKSRC}/test/unittest/CMakeLists.txt
@${REINPLACE_CMD} -e 's|.*travis.*||' ${WRKSRC}/CMakeLists.txt # travis_doc breaks cmake, see https://github.com/miloyip/rapidjson/issues/715
@${REINPLACE_CMD} -e 's|add_subdirectory.*googletest.*|link_directories(${LOCALBASE}/lib)|' ${WRKSRC}/test/CMakeLists.txt