aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-06-02 07:51:32 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-06-02 07:51:32 +0800
commitf0682af452603fe4b9e90122befdc8c0e150f6ca (patch)
tree41c70a7a030610d125c19e2d9530231896306bfc /devel
parent15449a05f79d210e1fcec0a38917928c6d7cd813 (diff)
downloadfreebsd-ports-f0682af452603fe4b9e90122befdc8c0e150f6ca.tar.gz
freebsd-ports-f0682af452603fe4b9e90122befdc8c0e150f6ca.tar.zst
freebsd-ports-f0682af452603fe4b9e90122befdc8c0e150f6ca.zip
Add LICENSE
- Add NO_ARCH - Remove outdated PERL_LEVEL check - Sort PLIST
Notes
Notes: svn path=/head/; revision=442347
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-JSON-RPC-Common/Makefile13
-rw-r--r--devel/p5-JSON-RPC-Common/pkg-plist34
2 files changed, 23 insertions, 24 deletions
diff --git a/devel/p5-JSON-RPC-Common/Makefile b/devel/p5-JSON-RPC-Common/Makefile
index 71a090024ae8..56c392d90a50 100644
--- a/devel/p5-JSON-RPC-Common/Makefile
+++ b/devel/p5-JSON-RPC-Common/Makefile
@@ -11,6 +11,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Transport agnostic JSON RPC helper objects
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
BUILD_DEPENDS= p5-libwww>=5:www/p5-libwww \
p5-Moose>=0.81:devel/p5-Moose \
p5-JSON>=2.11:converters/p5-JSON \
@@ -21,13 +25,8 @@ BUILD_DEPENDS= p5-libwww>=5:www/p5-libwww \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:devel/p5-Test-Exception
+NO_ARCH= yes
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 502200
-TEST_DEPENDS+= p5-Test-Simple>=1.001014:devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-JSON-RPC-Common/pkg-plist b/devel/p5-JSON-RPC-Common/pkg-plist
index b6e952dca427..5515c8293c0d 100644
--- a/devel/p5-JSON-RPC-Common/pkg-plist
+++ b/devel/p5-JSON-RPC-Common/pkg-plist
@@ -1,20 +1,3 @@
-%%PERL5_MAN3%%/JSON::RPC::Common.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Marshal::HTTP.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Marshal::Text.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Message.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Call.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Call::Version_1_0.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Call::Version_1_1.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Call::Version_2_0.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Error.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Version_1_0.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Version_1_0::Error.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Version_1_1.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Version_1_1::Error.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Version_2_0.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Version_2_0::Error.3.gz
-%%PERL5_MAN3%%/JSON::RPC::Common::TypeConstraints.3.gz
%%SITE_PERL%%/JSON/RPC/Common.pm
%%SITE_PERL%%/JSON/RPC/Common/Marshal/HTTP.pm
%%SITE_PERL%%/JSON/RPC/Common/Marshal/Text.pm
@@ -32,3 +15,20 @@
%%SITE_PERL%%/JSON/RPC/Common/Procedure/Return/Version_2_0.pm
%%SITE_PERL%%/JSON/RPC/Common/Procedure/Return/Version_2_0/Error.pm
%%SITE_PERL%%/JSON/RPC/Common/TypeConstraints.pm
+%%PERL5_MAN3%%/JSON::RPC::Common.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Marshal::HTTP.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Marshal::Text.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Message.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Call.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Call::Version_1_0.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Call::Version_1_1.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Call::Version_2_0.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Error.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Version_1_0.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Version_1_0::Error.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Version_1_1.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Version_1_1::Error.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Version_2_0.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::Procedure::Return::Version_2_0::Error.3.gz
+%%PERL5_MAN3%%/JSON::RPC::Common::TypeConstraints.3.gz