aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1998-11-14 12:16:10 +0800
committerDavid E. O'Brien <obrien@FreeBSD.org>1998-11-14 12:16:10 +0800
commit6cd943f47964cc8462f5d5921e7bcb13b73faafc (patch)
tree3c3087cb9a7e4fb90ef8bcdf71f710ab910e02d2 /devel
parent3f09baf663c541c575ba3c08873697b88c736fb3 (diff)
downloadfreebsd-ports-6cd943f47964cc8462f5d5921e7bcb13b73faafc.tar.gz
freebsd-ports-6cd943f47964cc8462f5d5921e7bcb13b73faafc.tar.zst
freebsd-ports-6cd943f47964cc8462f5d5921e7bcb13b73faafc.zip
Upgrade to version 3.33.
Notes
Notes: svn path=/head/; revision=14510
Diffstat (limited to 'devel')
-rw-r--r--devel/ups-debug/Makefile18
-rw-r--r--devel/ups-debug/distinfo4
-rw-r--r--devel/ups-debug/files/patch-0456
3 files changed, 35 insertions, 43 deletions
diff --git a/devel/ups-debug/Makefile b/devel/ups-debug/Makefile
index 81d1f99dc09b..90f87ecf3a41 100644
--- a/devel/ups-debug/Makefile
+++ b/devel/ups-debug/Makefile
@@ -4,29 +4,25 @@
# Date created: Mon Feb 03, 1997
# Whom: David O'Brien (obrien@FreeBSD.org)
#
-# $Id: Makefile,v 1.5 1998/09/16 20:48:34 obrien Exp $
+# $Id: Makefile,v 1.6 1998/11/11 05:37:17 asami Exp $
#
-DISTNAME= ups-3.32
+DISTNAME= ups-3.33
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_XCONTRIB} \
ftp://unix.hensa.ac.uk/pub/misc/unix/ups/ \
http://www.concerto.demon.co.uk/UPS/
MASTER_SITE_SUBDIR= utilities
-PATCHFILES= rga-332-patch-17jul98.txt
-PATCH_SITES= http://www.concerto.demon.co.uk/UPS/
+PATCHFILES= ide-333-patch-06oct98.txt.mod
+PATCH_SITES= http://www.concerto.demon.co.uk/UPS/ \
+ http://www.freebsd.org/~obrien/
MAINTAINER= obrien@FreeBSD.org
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 300000
-BROKEN= "During build: Libvar_addrs[0] is not constant"
-.endif
-
+BROKEN_ELF= yes
USE_GMAKE= yes
ALL_TARGET= ups
MAN1= ups.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ups-debug/distinfo b/devel/ups-debug/distinfo
index be7d73d5ef24..5bdc55b9ef58 100644
--- a/devel/ups-debug/distinfo
+++ b/devel/ups-debug/distinfo
@@ -1,2 +1,2 @@
-MD5 (ups-3.32.tar.gz) = 3618729f6e3ae88632c071f0f8d13866
-MD5 (rga-332-patch-17jul98.txt) = 9a65d5bd53f1fd730fb5677ab4d4b683
+MD5 (ups-3.33.tar.gz) = c8d14a771b8043d86ccebf477b9d5a25
+MD5 (ide-333-patch-06oct98.txt.mod) = 503d27f4348c8296d78ed42bd92d48ff
diff --git a/devel/ups-debug/files/patch-04 b/devel/ups-debug/files/patch-04
index d983cb44cb42..01fc130159aa 100644
--- a/devel/ups-debug/files/patch-04
+++ b/devel/ups-debug/files/patch-04
@@ -1,41 +1,37 @@
---- ups/xc_builtins.c.orig Wed Sep 16 05:26:07 1998
-+++ ups/xc_builtins.c Wed Sep 16 12:41:52 1998
-@@ -122,7 +122,7 @@
- extern int pipe PROTO((int *fds));
+--- ups/xc_builtins.c.orig Thu Oct 1 12:30:57 1998
++++ ups/xc_builtins.c Fri Nov 13 20:08:21 1998
+@@ -33,7 +33,11 @@
+ #include <ctype.h>
+ #include <errno.h>
+
+-#if defined (OS_SUNOS_5) && defined (__CLCC__)
++#if defined(OS_BSD44)
++#include <sys/ioctl.h>
++#endif
++
++#if defined (OS_SUNOS_5) && defined (__CLCC__) || defined(OS_BSD44)
+ #include <unistd.h>
+ #endif
+
+@@ -77,7 +81,7 @@
+ static int builtin_read PROTO((int fd, void *buf, size_t nbytes));
+ static int builtin_write PROTO((int fd, const void *buf, size_t nbytes));
static int builtin_pipe PROTO((int *fds));
- extern off_t lseek PROTO((int fd, off_t offset, int whence));
-static int builtin_lseek PROTO((int fd, off_t offset, int whence));
+static off_t builtin_lseek PROTO((int fd, off_t offset, int whence));
- /*extern int fcntl PROTO((int fd, int cmd, char *arg));*/
static int builtin_fcntl PROTO((int fd, int cmd, char *arg));
- extern int dup2 PROTO((int fd, int newfd));
-@@ -140,7 +140,7 @@
+ static int builtin_dup2 PROTO((int fd, int newfd));
+ static int builtin_dup PROTO((int fd));
+@@ -87,7 +91,7 @@
+ #ifdef BUILTIN_FLOCK
static int builtin_flock PROTO((int fd, int op));
#endif
- extern int ftruncate PROTO((int fd, off_t length));
-static int builtin_ftruncate PROTO((int fd, long length));
+static int builtin_ftruncate PROTO((int fd, off_t length));
- extern int ioctl PROTO((int fd, unsigned cmd, caddr_t arg));
static int builtin_ioctl PROTO((int fd, unsigned cmd, caddr_t arg));
- extern int fstat PROTO((int fd, struct stat *stbuf));
-@@ -173,7 +173,7 @@
-
- static bool fd_ok PROTO((int fd));
-
--#ifndef __FreeBSD__
-+#ifndef OS_BSD44
- #ifdef OS_LINUX
- extern const char *const sys_errlist[];
- extern int sys_nerr;
-@@ -320,6 +320,7 @@
- int getuid(), geteuid(), getgid(), getegid(), setreuid(), setregid();
- int setgroups(), getgroups();
- int rename(), read(), write(), pipe(), fcntl(), close(), dup(), dup2();
-+off_t lseek();
- int getdtablesize(), fchown(), flock(), fsync(), ftruncate();
- int ioctl(), select(), open(), creat(), link(), unlink(), chown(), chmod();
- int mkdir(), symlink(), readlink(), rmdir(), access(), chdir(), chroot();
-@@ -508,7 +509,7 @@
+ static int builtin_fstat PROTO((int fd, struct stat *stbuf));
+ static Display *builtin_XOpenDisplay PROTO((const char *display_name));
+@@ -298,7 +302,7 @@
static int
builtin_ftruncate(fd, length)
int fd;
@@ -44,7 +40,7 @@
{
return fd_ok(fd) ? ftruncate(fd, (off_t)length) : -1;
}
-@@ -531,7 +532,7 @@
+@@ -321,7 +325,7 @@
return res;
}