aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-11-09 05:42:52 +0800
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-11-09 05:42:52 +0800
commit9d66975bdb197e6342a3544dbc9a8c17b265aebc (patch)
tree26d628ea9b71d4fcccccedadf7d143b4e3f7e626 /finance
parent54c4d61777137f7d0f768b4f7713dc7243175ba9 (diff)
downloadfreebsd-ports-9d66975bdb197e6342a3544dbc9a8c17b265aebc.tar.gz
freebsd-ports-9d66975bdb197e6342a3544dbc9a8c17b265aebc.tar.zst
freebsd-ports-9d66975bdb197e6342a3544dbc9a8c17b265aebc.zip
Update to 3.0.1, the main highlights of this release are Segregated Witness
(segwit) support and has switched from qt4 to qt5. Cold storage wallet support still need some work. Therefore disable the trezor and ledger support for now until things have been fixed. Users depending on trezor and ledger are advised to use finance/electrum2 for the time being. Changelog: https://github.com/spesmilo/electrum/blob/master/RELEASE-NOTES
Notes
Notes: svn path=/head/; revision=453766
Diffstat (limited to 'finance')
-rw-r--r--finance/electrum/Makefile54
-rw-r--r--finance/electrum/distinfo6
-rw-r--r--finance/electrum/files/ledger_wallet.conf.sample13
-rw-r--r--finance/electrum/files/pkg-message-hwwallet.in14
-rw-r--r--finance/electrum/files/trezor_wallet.conf.sample13
5 files changed, 19 insertions, 81 deletions
diff --git a/finance/electrum/Makefile b/finance/electrum/Makefile
index 06a91d505a6a..8600d1b63d78 100644
--- a/finance/electrum/Makefile
+++ b/finance/electrum/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= electrum
-PORTVERSION= 2.9.3
-PORTREVISION= 2
+PORTVERSION= 3.0.1
CATEGORIES= finance python
MASTER_SITES= https://download.electrum.org/${PORTVERSION}/ \
http://download.electrum.org/${PORTVERSION}/
@@ -15,47 +14,26 @@ COMMENT= Easy to use Bitcoin client
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENCE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>0:dns/py-dnspython \
- ${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa \
- ${PYTHON_PKGNAMEPREFIX}jsonrpclib>0:devel/py-jsonrpclib \
- ${PYTHON_PKGNAMEPREFIX}pbkdf2>=1.3:security/py-pbkdf2 \
- ${PYTHON_PKGNAMEPREFIX}protobuf>=2.6.0:devel/py-protobuf \
- ${PYTHON_PKGNAMEPREFIX}pyaes>0:security/py-pyaes \
- ${PYTHON_PKGNAMEPREFIX}pysocks>=0:net/py-pysocks \
- ${PYTHON_PKGNAMEPREFIX}requests>=2.4.3:www/py-requests \
- ${PYTHON_PKGNAMEPREFIX}qrcode>=5.1:textproc/py-qrcode
-
-USES= desktop-file-utils pyqt:4 python:-2.7
-USE_PYQT= gui_run
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>0:dns/py3-dnspython \
+ ${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py3-ecdsa \
+ ${PYTHON_PKGNAMEPREFIX}httplib2>=0:www/py3-httplib2 \
+ ${PYTHON_PKGNAMEPREFIX}jsonrpclib-pelix>0:devel/py-jsonrpclib-pelix \
+ ${PYTHON_PKGNAMEPREFIX}pbkdf2>=1.3:security/py3-pbkdf2 \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=2.6.0:devel/py3-protobuf \
+ ${PYTHON_PKGNAMEPREFIX}pyaes>0:security/py3-pyaes \
+ ${PYTHON_PKGNAMEPREFIX}pysocks>=0:net/py3-pysocks \
+ ${PYTHON_PKGNAMEPREFIX}qrcode>=5.1:textproc/py3-qrcode \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.4.3:www/py3-requests
+
+CONFLICTS_INSTALL= electrum2-*
+
+USES= desktop-file-utils pyqt:5 python:3
+USE_PYQT= gui_run sip widgets
USE_PYTHON= autoplist distutils
PYDISTUTILS_PKGNAME= Electrum
NO_ARCH= yes
-OPTIONS_SUB= yes
-
-OPTIONS_DEFINE= LEDGER TREZOR
-OPTIONS_DEFAULT=LEDGER TREZOR
-
-LEDGER_DESC= Enable LEDGER Bitcoin hardware wallet support
-TREZOR_DESC= Enable TREZOR Bitcoin hardware wallet support
-
-LEDGER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}btchip-python>0:security/py-btchip-python
-TREZOR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}trezor>0:security/py-trezor
-
-LEDGER_PLIST_FILES= "@sample etc/devd/ledger_wallet.conf.sample"
-TREZOR_PLIST_FILES= "@sample etc/devd/trezor_wallet.conf.sample"
-
-LEDGER_SUB_FILES= pkg-message-hwwallet
-TREZOR_SUB_FILES= pkg-message-hwwallet
post-patch:
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/setup.py
-post-install-LEDGER-on:
- ${INSTALL_DATA} ${FILESDIR}/ledger_wallet.conf.sample \
- ${STAGEDIR}${PREFIX}/etc/devd
-
-post-install-TREZOR-on:
- ${INSTALL_DATA} ${FILESDIR}/trezor_wallet.conf.sample \
- ${STAGEDIR}${PREFIX}/etc/devd
-
.include <bsd.port.mk>
diff --git a/finance/electrum/distinfo b/finance/electrum/distinfo
index 14110efa686d..79e46d3df761 100644
--- a/finance/electrum/distinfo
+++ b/finance/electrum/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1505652872
-SHA256 (Electrum-2.9.3.tar.gz) = c2192d4df6490fdc6e6f9f85b05db0e3915683a016a43ed444ebbc51ccfa0e34
-SIZE (Electrum-2.9.3.tar.gz) = 2389367
+TIMESTAMP = 1510066925
+SHA256 (Electrum-3.0.1.tar.gz) = 1aaabb1a89da659419c41ed68e55b0fe45c2afd69477117fd7833484751c0243
+SIZE (Electrum-3.0.1.tar.gz) = 2788127
diff --git a/finance/electrum/files/ledger_wallet.conf.sample b/finance/electrum/files/ledger_wallet.conf.sample
deleted file mode 100644
index a4ab25e0a074..000000000000
--- a/finance/electrum/files/ledger_wallet.conf.sample
+++ /dev/null
@@ -1,13 +0,0 @@
-# $FreeBSD$
-#
-# Allow members of group operator to access hardware wallet devices
-
-## Ledger Nano S
-#notify 301 {
-# match "system" "USB";
-# match "subsystem" "DEVICE";
-# match "vendor" "0x2c97";
-# match "product" "0x0001";
-# match "type" "ATTACH";
-# action "/bin/chmod g=rw /dev/$cdev";
-#};
diff --git a/finance/electrum/files/pkg-message-hwwallet.in b/finance/electrum/files/pkg-message-hwwallet.in
deleted file mode 100644
index f4f8236f23eb..000000000000
--- a/finance/electrum/files/pkg-message-hwwallet.in
+++ /dev/null
@@ -1,14 +0,0 @@
-For hardware wallet devices to work you need to be in the operator group
-and need r/w permissions to the appropriate /dev/usb/* device.
-
-Add a user to operator group:
-
-% pw groupmod operator -m satoshi
-
-Edit your configuration:
-
-%%PREFIX%%/etc/devd/*_wallet.conf
-
-Then restart devd to load the new rules:
-
-% /etc/rc.d/devd restart
diff --git a/finance/electrum/files/trezor_wallet.conf.sample b/finance/electrum/files/trezor_wallet.conf.sample
deleted file mode 100644
index e75d3649ec0c..000000000000
--- a/finance/electrum/files/trezor_wallet.conf.sample
+++ /dev/null
@@ -1,13 +0,0 @@
-# $FreeBSD$
-#
-# Allow members of group operator to access hardware wallet devices
-
-## SatoshiLabs TREZOR
-#notify 301 {
-# match "system" "USB";
-# match "subsystem" "DEVICE";
-# match "vendor" "0x534c";
-# match "product" "0x0001";
-# match "type" "ATTACH";
-# action "/bin/chmod g=rw /dev/$cdev";
-#};