aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-03-18 22:40:44 +0800
committerMark Linimon <linimon@FreeBSD.org>2018-03-18 22:40:44 +0800
commit213715333d547287b053e7800c7bf8559d8d7992 (patch)
treee9229e9cc7b55b362501c13b4df08f5032472f3e /games
parentdd7aca9d8be0c5efa992b3da102161895e772736 (diff)
downloadfreebsd-ports-213715333d547287b053e7800c7bf8559d8d7992.tar.gz
freebsd-ports-213715333d547287b053e7800c7bf8559d8d7992.tar.zst
freebsd-ports-213715333d547287b053e7800c7bf8559d8d7992.zip
Mark as broken on armvX.
Apparently the attempt to defeat the x86 assembler is insufficient. While here, conform to newer style by unquoting and sorting ARCHs. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=464917
Diffstat (limited to 'games')
-rw-r--r--games/crafty/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/crafty/Makefile b/games/crafty/Makefile
index 6d2dd812aca0..cb6f0288cafa 100644
--- a/games/crafty/Makefile
+++ b/games/crafty/Makefile
@@ -16,6 +16,9 @@ EXTRACT_ONLY= crafty-${PORTVERSION}.zip
MAINTAINER= johans@FreeBSD.org
COMMENT= Chess program for playing and analyzing games
+BROKEN_armv6= fails to compile: invokes x86 assembler
+BROKEN_armv7= fails to compile: invokes x86 assembler
+
WRKSRC= ${WRKDIR}
USES= gmake zip
@@ -36,7 +39,7 @@ OPT= -DHASHSTATS -DTRACE -DBOOKDIR=\\\"${WITH_BOOKDIR}\\\" \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+.if ${ARCH} == amd64 || ${ARCH} == i386
OPT+= -DCPUS=4
.else
OPT+= -DCPUS=1 # disables x86 assembler