aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2021-03-08 06:09:42 +0800
committersunpoet <sunpoet@FreeBSD.org>2021-03-08 06:09:42 +0800
commit86b0990fd78bc08e32289669d80482b77cac16fa (patch)
tree3d65819ed040cbd30c30eeea9f7e70c2a455f408 /graphics
parentcac346fce356507e0ecf9ef0c0bd5e1569d1f6e4 (diff)
downloadfreebsd-ports-86b0990fd78bc08e32289669d80482b77cac16fa.tar.gz
freebsd-ports-86b0990fd78bc08e32289669d80482b77cac16fa.tar.zst
freebsd-ports-86b0990fd78bc08e32289669d80482b77cac16fa.zip
Add py-pandana 0.6
Pandana is a Python library for network analysis that uses contraction hierarchies to calculate super-fast travel accessibility metrics and shortest paths. The numerical code is in C++. WWW: https://udst.github.io/pandana/ WWW: https://github.com/UDST/pandana
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-pandana/Makefile32
-rw-r--r--graphics/py-pandana/distinfo3
-rw-r--r--graphics/py-pandana/pkg-descr6
4 files changed, 42 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 1f54810ccaa0..c1b5fe7db621 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -851,6 +851,7 @@
SUBDIR += py-openimageio
SUBDIR += py-openshadinglanguage
SUBDIR += py-osmnet
+ SUBDIR += py-pandana
SUBDIR += py-photocollage
SUBDIR += py-piexif
SUBDIR += py-pillow
diff --git a/graphics/py-pandana/Makefile b/graphics/py-pandana/Makefile
new file mode 100644
index 000000000000..ea3f29091819
--- /dev/null
+++ b/graphics/py-pandana/Makefile
@@ -0,0 +1,32 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pandana
+PORTVERSION= 0.6
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python library for network analysis
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.25.2:lang/cython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.8,1:math/py-numpy@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.8,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.17,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.18:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tables>=3.1<3.7:devel/py-tables@${PY_FLAVOR}
+
+USES= compiler:c++11-lang python:3.7+
+USE_PYTHON= autoplist concurrent cython distutils
+
+CFLAGS+= -DNO_TR1_MEMORY
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/pandana/cyaccess.so
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pandana/distinfo b/graphics/py-pandana/distinfo
new file mode 100644
index 000000000000..d4346601a0cd
--- /dev/null
+++ b/graphics/py-pandana/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614794178
+SHA256 (pandana-0.6.tar.gz) = 2166974da455d5217a7a248af1f34a94a4b895fc6cc85c2b0002431eccef532a
+SIZE (pandana-0.6.tar.gz) = 410810
diff --git a/graphics/py-pandana/pkg-descr b/graphics/py-pandana/pkg-descr
new file mode 100644
index 000000000000..521f3f1443d5
--- /dev/null
+++ b/graphics/py-pandana/pkg-descr
@@ -0,0 +1,6 @@
+Pandana is a Python library for network analysis that uses contraction
+hierarchies to calculate super-fast travel accessibility metrics and shortest
+paths. The numerical code is in C++.
+
+WWW: https://udst.github.io/pandana/
+WWW: https://github.com/UDST/pandana