aboutsummaryrefslogtreecommitdiffstats
path: root/irc
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-02-01 13:28:52 +0800
committerJan Beich <jbeich@FreeBSD.org>2017-02-01 13:28:52 +0800
commit3537aef17a68b92e0954c11cc6fcf7dc636ebc13 (patch)
treec1cafd0513589f4519687fe2ca62ff0ee2271f2a /irc
parentb8a1188a89729063cb9f338a3cbe3a1ccbd860a7 (diff)
downloadfreebsd-ports-3537aef17a68b92e0954c11cc6fcf7dc636ebc13.tar.gz
freebsd-ports-3537aef17a68b92e0954c11cc6fcf7dc636ebc13.tar.zst
freebsd-ports-3537aef17a68b92e0954c11cc6fcf7dc636ebc13.zip
irc/kvirc: unbreak with clang 4.0
src/modules/rijndael/libkvirijndael.cpp:331:11: error: ordered comparison between pointer and zero ('int *' and 'int') if(len > 0) ~~~ ^ ~ src/modules/rijndael/libkvirijndael.cpp:357:11: error: ordered comparison between pointer and zero ('int *' and 'int') if(len > 0) ~~~ ^ ~ Reported by: antoine (via exp-run)
Notes
Notes: svn path=/head/; revision=432985
Diffstat (limited to 'irc')
-rw-r--r--irc/kvirc/Makefile2
-rw-r--r--irc/kvirc/files/patch-src_modules_rijndael_libkvirijndael.cpp20
2 files changed, 21 insertions, 1 deletions
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index bf9717de8f32..7651d8bb4d2c 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kvirc
PORTVERSION= 4.2.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= irc kde
MASTER_SITES= ftp://ftp.kvirc.de/pub/kvirc/%SUBDIR%/ \
http://kvirc.gmake.de/pub/kvirc/%SUBDIR%/ \
diff --git a/irc/kvirc/files/patch-src_modules_rijndael_libkvirijndael.cpp b/irc/kvirc/files/patch-src_modules_rijndael_libkvirijndael.cpp
new file mode 100644
index 000000000000..4fd7ce6a12e0
--- /dev/null
+++ b/irc/kvirc/files/patch-src_modules_rijndael_libkvirijndael.cpp
@@ -0,0 +1,20 @@
+--- src/modules/rijndael/libkvirijndael.cpp.orig 2011-07-23 15:15:56 UTC
++++ src/modules/rijndael/libkvirijndael.cpp
+@@ -328,7 +328,7 @@
+ setLastError(__tr2qs("The message is not a hexadecimal string: this is not my stuff"));
+ return false;
+ } else {
+- if(len > 0)
++ if(*len > 0)
+ {
+ *outBuffer = (char *)KviMemory::allocate(*len);
+ KviMemory::move(*outBuffer,tmpBuf,*len);
+@@ -354,7 +354,7 @@
+ setLastError(__tr2qs("The message is not a base64 string: this is not my stuff"));
+ return false;
+ } else {
+- if(len > 0)
++ if(*len > 0)
+ {
+ *outBuffer = (char *)KviMemory::allocate(*len);
+ KviMemory::move(*outBuffer,tmpBuf,*len);