aboutsummaryrefslogtreecommitdiffstats
path: root/lang/vala/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /lang/vala/Makefile
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadfreebsd-ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
freebsd-ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.zst
freebsd-ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'lang/vala/Makefile')
-rw-r--r--lang/vala/Makefile44
1 files changed, 20 insertions, 24 deletions
diff --git a/lang/vala/Makefile b/lang/vala/Makefile
index d9f819fb55bf..d85c5f683980 100644
--- a/lang/vala/Makefile
+++ b/lang/vala/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: vala
-# Date created: 2007-07-09
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/lang/vala/Makefile,v 1.55 2011/06/02 12:10:13 kwm Exp $
-#
+# $MCom: ports/lang/vala/Makefile,v 1.65 2012/12/17 19:46:24 kwm Exp $
PORTNAME= vala
-PORTVERSION= 0.12.1
+PORTVERSION= 0.18.1
CATEGORIES= lang gnome
MASTER_SITES= GNOME
@@ -15,27 +11,28 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Programming language and compiler that converts Vala code into C code
LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_XZ= yes
USE_GNOME= gnomehack glib20 gnomeprefix libxslt
+USE_GMAKE= yes
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
USE_GETTEXT= yes
-CPPFLAGS+= -I${LOCALBASE}
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_BISON= build
USE_LDCONFIG= yes
-MAN1?= valac.1 valac-0.12.1
-
-PLIST_SUB= VERSION=0.12
+MAN1?= valac.1 valac-${VALA_VER}.1
+VALA_VER= 0.18
-.include <bsd.port.pre.mk>
+PLIST_SUB= VERSION=${VALA_VER}
.if defined(VALA_SLAVE)
-LIB_DEPENDS+= vala-0.12.0:${PORTSDIR}/lang/vala
+LIB_DEPENDS+= vala-${VALA_VER}.0:${PORTSDIR}/lang/vala
CONFIGURE_ARGS+=--enable-vapigen
-BUILD_DEPENDS+= p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
-RUN_DEPENDS+= p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML
MAN1= vala-gen-introspect.1 vapigen.1
.else
CONFIGURE_ARGS+=--disable-vapigen
@@ -43,13 +40,13 @@ CONFIGURE_ARGS+=--disable-vapigen
post-patch:
# We cheat here, because vala records vapigen related stuff in its .pc file
-# This makes the vapigen work again, although it might get weird when
+# This makes vapigen work again, although it might get weird when
# vala-vapigen isn't installed.
- @${REINPLACE_CMD} -e 's|@vapigen_decl@|vapigen=$${bindir}/vapigen-0.12|g' \
- -e 's|@gen_introspect_decl@|gen_introspect=$${libdir}/vala-0.12/gen-introspect-0.12|g' \
- -e 's|@vala_gen_introspect_decl@|vala_gen_introspect=$${bindir}/vala-gen-introspect-0.12|g' \
+ @${REINPLACE_CMD} -e 's|@vapigen_decl@|vapigen=$${bindir}/vapigen-${VALA_VER}|g' \
+ -e 's|@gen_introspect_decl@|gen_introspect=$${libdir}/vala-${VALA_VER}/gen-introspect-${VALA_VER}|g' \
+ -e 's|@vala_gen_introspect_decl@|vala_gen_introspect=$${bindir}/vala-gen-introspect-${VALA_VER}|g' \
${WRKSRC}/libvala.pc.in
- @${REINPLACE_CMD} -e 's|cp $$< $$@|cp libvala.pc libvala-0.12.pc|g' \
+ @${REINPLACE_CMD} -e 's|cp $$< $$@|cp libvala.pc libvala-${VALA_VER}.pc|g' \
${WRKSRC}/Makefile.in
.if defined(VALA_SLAVE)
@@ -63,10 +60,9 @@ post-install:
@${INSTALL_MAN} ${WRKSRC}/doc/vapigen.1 ${WRKSRC}/doc/vala-gen-introspect.1 \
${PREFIX}/man/man1/
.else
-# want to see what will fail.
post-install:
- ${LN} -fs ${PREFIX}/libdata/pkgconfig/libvala-0.12.pc \
+ ${LN} -fs ${PREFIX}/libdata/pkgconfig/libvala-${VALA_VER}.pc \
${PREFIX}/libdata/pkgconfig/vala-1.0.pc
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>