aboutsummaryrefslogtreecommitdiffstats
path: root/lang/vala/Makefile
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2018-04-25 03:00:22 +0800
committerDon Lewis <truckman@FreeBSD.org>2018-04-25 03:00:22 +0800
commit9de16bbec2b30d90b46ed22e376f4ca6632a5035 (patch)
tree3d6e549dcaaa6c8d87da444e762bd0edd6f810f4 /lang/vala/Makefile
parent65264647b15be68e516187e49f7ce808e57691ca (diff)
downloadfreebsd-ports-9de16bbec2b30d90b46ed22e376f4ca6632a5035.tar.gz
freebsd-ports-9de16bbec2b30d90b46ed22e376f4ca6632a5035.tar.zst
freebsd-ports-9de16bbec2b30d90b46ed22e376f4ca6632a5035.zip
Upgrade lang/vala to version 0.36.13:
- gstreamer: Cherry-pick some fixes from 0.40 - vala: Fix return-type of BasicBlock.get_successors() https://bugzilla.gnome.org/show_bug.cgi?id=794979 - gdbus: Fix missing declaration of _fd_list for async methods https://bugzilla.gnome.org/show_bug.cgi?id=794566 - gtk+-4.0: Hide dedicated constructors of compact classes bound as structs https://bugzilla.gnome.org/show_bug.cgi?id=794733 - tests: Add GLib.ParamSpec tests to increase coverage - glib-2.0: Use g_value_*et_schar instead of depecated g_value_*et_char g_value_get_char is broken on platforms where the char type is unsigned, such as ARM and PowerPC. - gobject-2.0: Add ParamSpecGType - gtk+-*.0: Fix iter parameter of TextView.backward*/forward*/move_visually() Those methods are changing the passed iter structure and therefore it needs be marked as ref for vala taking this into account. https://bugzilla.gnome.org/show_bug.cgi?id=794345 - gdk-3.0,gtk+-3.0: Update to 3.22.29 - posix: Include sys/sysmacros.h for major(), minor() and makedev() Relying on sys/types.h is fatal since glibc 2.27 and was deprecated since glibc 2.25. https://bugzilla.gnome.org/show_bug.cgi?id=794651 - gobject-2.0: Cherry-pick some changes from 0.38 - webkit2gtk-4.0: Update to 2.20.0 - clutter-1.0: Avoid duplications of implemented interfaces - codegen: Don't add target fields for captured delegates without target - codegen: Don't add length fields for captured fixed-length array variables - gstreamer-1.0: Cherry-pick some fixes from 0.38 - gtk+-4.0: Fix TreeView.is_blank_at_pos() - gtk+-3.0: Fix TreeView.is_blank_at_pos() - posix: Fix sig*set and sigprocmask parameters to be out/ref https://bugzilla.gnome.org/show_bug.cgi?id=727425 - purple: Update to 2.12.0 - vapi: Fix wrong attributes - libgnome-menu-3.0: Add deps file - gitignore: ignore macOS metadata files - vala: The rank of an array-initializer should match the target's rank https://bugzilla.gnome.org/show_bug.cgi?id=744923 - Fix recursive declaration in generic base type https://bugzilla.gnome.org/show_bug.cgi?id=688732 - vala: Properly handle array-initializers inside struct-initializers https://bugzilla.gnome.org/show_bug.cgi?id=622178 - codegen: Don't append fixed-length of array fields in initializers - valac: Always use the given "pkg-config" and respect PKG_CONFIG envar
Notes
Notes: svn path=/head/; revision=468231
Diffstat (limited to 'lang/vala/Makefile')
-rw-r--r--lang/vala/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/vala/Makefile b/lang/vala/Makefile
index 6d350708ece9..92796ab04316 100644
--- a/lang/vala/Makefile
+++ b/lang/vala/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= vala
-PORTVERSION= 0.36.12
+PORTVERSION= 0.36.13
PORTEPOCH= 1
CATEGORIES= lang gnome
MASTER_SITES= GNOME