aboutsummaryrefslogtreecommitdiffstats
path: root/lang/vala/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-02-15 02:57:53 +0800
committerKoop Mast <kwm@FreeBSD.org>2016-02-15 02:57:53 +0800
commitb93a80c99281466281db26011356c75bd54ea36c (patch)
treecb5a8a1108829deee66dbb334ff2a733162448c6 /lang/vala/Makefile
parentb78527376a1d11bef820d5e9fe86d3c524ea6acf (diff)
downloadfreebsd-ports-b93a80c99281466281db26011356c75bd54ea36c.tar.gz
freebsd-ports-b93a80c99281466281db26011356c75bd54ea36c.tar.zst
freebsd-ports-b93a80c99281466281db26011356c75bd54ea36c.zip
The FreeBSD GNOME team proudly presents GNOME 3.18 for FreeBSD.
The offical GNOME 3.18 release notes can be found at https://help.gnome.org/misc/release-notes/3.18/ This update doesn't contain the glib/gtk c++ bindings which will be done in a another update due to the requirement on c++11 and the amount of fallout this probably will give. GDM is still at version 3.16 due to some issues. Bump mate-themes to use the gtk 3.18 version of the themes. Thanks to Antoine Brodin for running the exp-runs. This release was made possible by the following people: Gustau Perez Ting-Wei_Lan PR: 207006
Notes
Notes: svn path=/head/; revision=408881
Diffstat (limited to 'lang/vala/Makefile')
-rw-r--r--lang/vala/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/lang/vala/Makefile b/lang/vala/Makefile
index 9756df894873..cca063d2b042 100644
--- a/lang/vala/Makefile
+++ b/lang/vala/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= vala
-PORTVERSION= 0.28.1
+PORTVERSION= 0.30.1
CATEGORIES= lang gnome
MASTER_SITES= GNOME
@@ -13,7 +13,8 @@ LICENSE= LGPL21
PORTSCOUT= limitw:1,even
-USES= bison gettext gmake libtool pathfix pkgconfig tar:xz
+USES= bison gettext-runtime gmake gnome libtool \
+ pathfix pkgconfig tar:xz
USE_GNOME= glib20 gnomeprefix libxslt
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -22,6 +23,10 @@ USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
VALA_VER= ${PORTVERSION:R}
-PLIST_SUB= VERSION=${VALA_VER}
+
+# Version got bumped to 0.30, replace VERSION with that instead
+# of using VALA_VER. Replace 0.30 with VALA_VER when vala gets to 0.30.0
+#PLIST_SUB= VERSION=${VALA_VER}
+PLIST_SUB= VERSION=0.30
.include <bsd.port.mk>