aboutsummaryrefslogtreecommitdiffstats
path: root/lang/vala/Makefile
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2018-01-25 05:45:29 +0800
committerDon Lewis <truckman@FreeBSD.org>2018-01-25 05:45:29 +0800
commitd98eb75012562b87087d75ff480dc76bcfabdba9 (patch)
treead6028f55d9f3d10c92665761ffe84ac3a22d6b2 /lang/vala/Makefile
parent6a54eb7d1f78de2faa3542ca75728f4f738ce2a9 (diff)
downloadfreebsd-ports-d98eb75012562b87087d75ff480dc76bcfabdba9.tar.gz
freebsd-ports-d98eb75012562b87087d75ff480dc76bcfabdba9.tar.zst
freebsd-ports-d98eb75012562b87087d75ff480dc76bcfabdba9.zip
Update lang/vala to 0.36.9.
Vala 0.36.5 =========== * Various bug fixes: - codegen: + Initialize temp-variable for fixed-size arrays to zero first [#787152] + Actually write declaration for GNodeTraverseFunc wrapper [#786845] + Don't transfer ownership of variable if target-type is unknown [#736774] + Adjust format-index for printf/scanf-methods which throw errors [#781061] + Include glib-object.h for Enums/Structs with type_id - vapigen: Mark given source-files as such and force girparser to handle them - tests: Fix some syntax issues [#786652] - Add .editorconfig file [#786620] Vala 0.36.6 =========== * Various bug fixes: - codegen: Support renamed signals [#731547] - Optimize (de)serialization of arrays with type-signature "ay" [#772426] - codegen: Try to use a more unique internal define for properties [#787436] - vala: Update list of used attributes - method: Include ownership transfer classifier for return-type mismatch Vala 0.36.7 =========== * Various bug fixes: - codegen: Prioritize "array_length=true" over "array_null_terminated=true" [#788775] - codegen: Avoid possible conflicts with internal property/signal defines [#788964] Vala 0.36.8 =========== * Various bug fixes: - Enforce name-length >= 3 for structs using GType [#764041] - Report error for missing type-parameter on enclosing type [#587905] - Discover invalid member access to instance field [#790903] - Improve error output of mismatching overriding methods - vala: Don't transform an explicit "null" into valid format-string [#791215] - codegen: Don't create null-safe destroy-wrapper for GenericType [#791283] - Improve error message for missing type-parameter on enclosing type [#587905] * GIR parser: - Allow change of parameter names - Handle metadata for fields inside a transparent union - Accept setters with boolean return-type as valid property-accessor - Don't mark simple-type out-parameters with '?' as nullable Vala 0.36.9 =========== * Various improvements and bug fixes: - codegen: Add destroy param when invoking delegate returned by delegate [#792077] - gidlparser: Update type qualifiers - vala: Fix parameter type inference of overridden async methods [#792660] - codewriter: Don't use string.replace() to apply header_to_override [#731322]
Notes
Notes: svn path=/head/; revision=459892
Diffstat (limited to 'lang/vala/Makefile')
-rw-r--r--lang/vala/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/vala/Makefile b/lang/vala/Makefile
index 0de597e5556c..7210574a7565 100644
--- a/lang/vala/Makefile
+++ b/lang/vala/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= vala
-PORTVERSION= 0.36.4
+PORTVERSION= 0.36.9
CATEGORIES= lang gnome
MASTER_SITES= GNOME