aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-02-11 23:49:22 +0800
committerMark Linimon <linimon@FreeBSD.org>2018-02-11 23:49:22 +0800
commit8335f67c5cf984fb7815489d2a403d9812dd7a6d (patch)
tree39fb8970bbcc70a170b16467dcef9137a7cd7287 /math
parent1278042b855739879576e31a5a1bfa1b87698a7c (diff)
downloadfreebsd-ports-8335f67c5cf984fb7815489d2a403d9812dd7a6d.tar.gz
freebsd-ports-8335f67c5cf984fb7815489d2a403d9812dd7a6d.tar.zst
freebsd-ports-8335f67c5cf984fb7815489d2a403d9812dd7a6d.zip
Use ONLY_FOR due to specific dependence on x86 instructions.
While here, pet portlint.
Notes
Notes: svn path=/head/; revision=461509
Diffstat (limited to 'math')
-rw-r--r--math/sfft/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/math/sfft/Makefile b/math/sfft/Makefile
index b31b6f7c852a..6acc80879ccf 100644
--- a/math/sfft/Makefile
+++ b/math/sfft/Makefile
@@ -14,6 +14,9 @@ COMMENT= Optimized Sparse Fast Fourier Transform
LICENSE= GPLv2
+ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS_REASON= requires SSE instructions, which are x86-specific
+
LIB_DEPENDS= libfftw3.so:math/fftw3
USES= uidfix zip
@@ -109,6 +112,6 @@ post-install:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${_DISTDIR}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>