aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2000-04-23 05:19:39 +0800
committerVanilla I. Shu <vanilla@FreeBSD.org>2000-04-23 05:19:39 +0800
commit19caf44942b71d7e3f6e5c3acb71b395cef5b13b (patch)
tree0fb38afc0822077e4a14e4199bfa13d5e0558337 /net
parent201929fc559eed268c4898e29d03988359317bd4 (diff)
downloadfreebsd-ports-19caf44942b71d7e3f6e5c3acb71b395cef5b13b.tar.gz
freebsd-ports-19caf44942b71d7e3f6e5c3acb71b395cef5b13b.tar.zst
freebsd-ports-19caf44942b71d7e3f6e5c3acb71b395cef5b13b.zip
Add a patch for I18N, and correct pkg/PLIST.
Notes
Notes: svn path=/head/; revision=27894
Diffstat (limited to 'net')
-rw-r--r--net/ethereal/files/patch-aa25
-rw-r--r--net/ethereal/files/patch-ab13
-rw-r--r--net/ethereal/pkg-plist8
-rw-r--r--net/wireshark/files/patch-aa25
-rw-r--r--net/wireshark/files/patch-ab13
-rw-r--r--net/wireshark/pkg-plist8
6 files changed, 84 insertions, 8 deletions
diff --git a/net/ethereal/files/patch-aa b/net/ethereal/files/patch-aa
new file mode 100644
index 000000000000..9fc3924a3c78
--- /dev/null
+++ b/net/ethereal/files/patch-aa
@@ -0,0 +1,25 @@
+--- gtk/main.c.orig Wed Apr 5 10:17:53 2000
++++ gtk/main.c Sat Apr 22 20:33:00 2000
+@@ -1161,6 +1161,7 @@
+
+ /* Let GTK get its args */
+ gtk_init (&argc, &argv);
++ gtk_set_locale ();
+
+ prefs = read_prefs(&pf_path);
+ if (pf_path != NULL) {
+@@ -1440,12 +1441,12 @@
+ sprintf(rc_file, "%s/%s", get_home_dir(), RC_FILE);
+ gtk_rc_parse(rc_file);
+
+- if ((m_r_font = gdk_font_load(medium_font)) == NULL) {
++ if ((m_r_font = gdk_fontset_load(medium_font)) == NULL) {
+ fprintf(stderr, "ethereal: Error font %s not found (use -m option)\n", medium_font);
+ exit(1);
+ }
+
+- if ((m_b_font = gdk_font_load(bold_font)) == NULL) {
++ if ((m_b_font = gdk_fontset_load(bold_font)) == NULL) {
+ fprintf(stderr, "ethereal: Error font %s not found (use -b option)\n", bold_font);
+ exit(1);
+ }
diff --git a/net/ethereal/files/patch-ab b/net/ethereal/files/patch-ab
new file mode 100644
index 000000000000..a92c130ac9cf
--- /dev/null
+++ b/net/ethereal/files/patch-ab
@@ -0,0 +1,13 @@
+--- gtk/main.h.orig Sat Apr 22 20:17:29 2000
++++ gtk/main.h Sat Apr 22 20:17:42 2000
+@@ -38,8 +38,8 @@
+ #define MONO_MEDIUM_FONT "-*-lucida console-medium-*-*-*-*-100-*-*-*-*-*-*"
+ #define MONO_BOLD_FONT "-*-lucida console-bold-*-*-*-*-100-*-*-*-*-*-*"
+ #else
+-#define MONO_MEDIUM_FONT "-*-lucidatypewriter-medium-r-normal-*-*-120-*-*-*-*-iso8859-1"
+-#define MONO_BOLD_FONT "-*-lucidatypewriter-bold-r-normal-*-*-120-*-*-*-*-iso8859-1"
++#define MONO_MEDIUM_FONT "-*-lucidatypewriter-medium-r-normal-*-*-120-*-*-*-*-iso8859-1,*"
++#define MONO_BOLD_FONT "-*-lucidatypewriter-bold-r-normal-*-*-120-*-*-*-*-iso8859-1,*"
+ #endif
+ #define RC_FILE PF_DIR "/gtkrc"
+ #define DEF_WIDTH 750
diff --git a/net/ethereal/pkg-plist b/net/ethereal/pkg-plist
index e2ae4336b465..adaa4bc48c0f 100644
--- a/net/ethereal/pkg-plist
+++ b/net/ethereal/pkg-plist
@@ -2,9 +2,9 @@ bin/editcap
bin/ethereal
bin/tethereal
etc/manuf
-lib/ethereal/plugins/0.8.5/gryphon.la
-lib/ethereal/plugins/0.8.5/gryphon.a
-lib/ethereal/plugins/0.8.5/gryphon.so
-@dirrm lib/ethereal/plugins/0.8.5
+lib/ethereal/plugins/0.8.7/gryphon.la
+lib/ethereal/plugins/0.8.7/gryphon.a
+lib/ethereal/plugins/0.8.7/gryphon.so
+@dirrm lib/ethereal/plugins/0.8.7
@dirrm lib/ethereal/plugins
@dirrm lib/ethereal
diff --git a/net/wireshark/files/patch-aa b/net/wireshark/files/patch-aa
new file mode 100644
index 000000000000..9fc3924a3c78
--- /dev/null
+++ b/net/wireshark/files/patch-aa
@@ -0,0 +1,25 @@
+--- gtk/main.c.orig Wed Apr 5 10:17:53 2000
++++ gtk/main.c Sat Apr 22 20:33:00 2000
+@@ -1161,6 +1161,7 @@
+
+ /* Let GTK get its args */
+ gtk_init (&argc, &argv);
++ gtk_set_locale ();
+
+ prefs = read_prefs(&pf_path);
+ if (pf_path != NULL) {
+@@ -1440,12 +1441,12 @@
+ sprintf(rc_file, "%s/%s", get_home_dir(), RC_FILE);
+ gtk_rc_parse(rc_file);
+
+- if ((m_r_font = gdk_font_load(medium_font)) == NULL) {
++ if ((m_r_font = gdk_fontset_load(medium_font)) == NULL) {
+ fprintf(stderr, "ethereal: Error font %s not found (use -m option)\n", medium_font);
+ exit(1);
+ }
+
+- if ((m_b_font = gdk_font_load(bold_font)) == NULL) {
++ if ((m_b_font = gdk_fontset_load(bold_font)) == NULL) {
+ fprintf(stderr, "ethereal: Error font %s not found (use -b option)\n", bold_font);
+ exit(1);
+ }
diff --git a/net/wireshark/files/patch-ab b/net/wireshark/files/patch-ab
new file mode 100644
index 000000000000..a92c130ac9cf
--- /dev/null
+++ b/net/wireshark/files/patch-ab
@@ -0,0 +1,13 @@
+--- gtk/main.h.orig Sat Apr 22 20:17:29 2000
++++ gtk/main.h Sat Apr 22 20:17:42 2000
+@@ -38,8 +38,8 @@
+ #define MONO_MEDIUM_FONT "-*-lucida console-medium-*-*-*-*-100-*-*-*-*-*-*"
+ #define MONO_BOLD_FONT "-*-lucida console-bold-*-*-*-*-100-*-*-*-*-*-*"
+ #else
+-#define MONO_MEDIUM_FONT "-*-lucidatypewriter-medium-r-normal-*-*-120-*-*-*-*-iso8859-1"
+-#define MONO_BOLD_FONT "-*-lucidatypewriter-bold-r-normal-*-*-120-*-*-*-*-iso8859-1"
++#define MONO_MEDIUM_FONT "-*-lucidatypewriter-medium-r-normal-*-*-120-*-*-*-*-iso8859-1,*"
++#define MONO_BOLD_FONT "-*-lucidatypewriter-bold-r-normal-*-*-120-*-*-*-*-iso8859-1,*"
+ #endif
+ #define RC_FILE PF_DIR "/gtkrc"
+ #define DEF_WIDTH 750
diff --git a/net/wireshark/pkg-plist b/net/wireshark/pkg-plist
index e2ae4336b465..adaa4bc48c0f 100644
--- a/net/wireshark/pkg-plist
+++ b/net/wireshark/pkg-plist
@@ -2,9 +2,9 @@ bin/editcap
bin/ethereal
bin/tethereal
etc/manuf
-lib/ethereal/plugins/0.8.5/gryphon.la
-lib/ethereal/plugins/0.8.5/gryphon.a
-lib/ethereal/plugins/0.8.5/gryphon.so
-@dirrm lib/ethereal/plugins/0.8.5
+lib/ethereal/plugins/0.8.7/gryphon.la
+lib/ethereal/plugins/0.8.7/gryphon.a
+lib/ethereal/plugins/0.8.7/gryphon.so
+@dirrm lib/ethereal/plugins/0.8.7
@dirrm lib/ethereal/plugins
@dirrm lib/ethereal