aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-05-29 10:36:54 +0800
committerSteve Price <steve@FreeBSD.org>2000-05-29 10:36:54 +0800
commit6c8810f07de30e1895fbd0b82401f3dec19746da (patch)
treef5eb04c163171a6edef3d0fba3fbed4652ff9fbf /net
parent3d1ed02c74ef137242369f52f0031d066cb8a46d (diff)
downloadfreebsd-ports-6c8810f07de30e1895fbd0b82401f3dec19746da.tar.gz
freebsd-ports-6c8810f07de30e1895fbd0b82401f3dec19746da.tar.zst
freebsd-ports-6c8810f07de30e1895fbd0b82401f3dec19746da.zip
Update to version 1.2.10.
PR: 18841 Submitted by: R\xe9mi Guyomarch <rguyom@321.net>
Notes
Notes: svn path=/head/; revision=28857
Diffstat (limited to 'net')
-rw-r--r--net/openldap/Makefile5
-rw-r--r--net/openldap/distinfo2
-rw-r--r--net/openldap/files/patch-aa12
-rw-r--r--net/openldap/files/patch-ab8
-rw-r--r--net/openldap/files/patch-ac12
-rw-r--r--net/openldap/files/patch-db14
-rw-r--r--net/openldap12/Makefile5
-rw-r--r--net/openldap12/distinfo2
-rw-r--r--net/openldap12/files/patch-aa12
-rw-r--r--net/openldap12/files/patch-ab8
-rw-r--r--net/openldap12/files/patch-ac12
-rw-r--r--net/openldap12/files/patch-db14
-rw-r--r--net/openldap2/Makefile5
-rw-r--r--net/openldap2/distinfo2
-rw-r--r--net/openldap20-server/Makefile5
-rw-r--r--net/openldap20-server/distinfo2
-rw-r--r--net/openldap20/Makefile5
-rw-r--r--net/openldap20/distinfo2
-rw-r--r--net/openldap21-server/Makefile5
-rw-r--r--net/openldap21-server/distinfo2
-rw-r--r--net/openldap21/Makefile5
-rw-r--r--net/openldap21/distinfo2
-rw-r--r--net/openldap22-server/Makefile5
-rw-r--r--net/openldap22-server/distinfo2
-rw-r--r--net/openldap22/Makefile5
-rw-r--r--net/openldap22/distinfo2
-rw-r--r--net/openldap23-server/Makefile5
-rw-r--r--net/openldap23-server/distinfo2
-rw-r--r--net/openldap24-server/Makefile5
-rw-r--r--net/openldap24-server/distinfo2
30 files changed, 122 insertions, 47 deletions
diff --git a/net/openldap/Makefile b/net/openldap/Makefile
index 9a7cf89041ec..cfdaaf693a2e 100644
--- a/net/openldap/Makefile
+++ b/net/openldap/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 1.2.9
+PORTVERSION= 1.2.10
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/ \
ftp://ftp.net.lut.ac.uk/openldap/openldap-release/ \
@@ -25,10 +25,11 @@ MAINTAINER= ulmo@earthling.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --enable-ldbm --with-ldbm-api=db2
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+CONFIGURE_ARGS+= --localstatedir=/var/run --enable-shared --enable-dns
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
diff --git a/net/openldap/distinfo b/net/openldap/distinfo
index 680f37b76df8..9bc43a3d2656 100644
--- a/net/openldap/distinfo
+++ b/net/openldap/distinfo
@@ -1 +1 @@
-MD5 (openldap-1.2.9.tgz) = d6ef63849c5a5367cfac84f99a0263e2
+MD5 (openldap-1.2.10.tgz) = d4b904a4da62bbfb2110dfc0cddb6b90
diff --git a/net/openldap/files/patch-aa b/net/openldap/files/patch-aa
new file mode 100644
index 000000000000..22b7d8d94a70
--- /dev/null
+++ b/net/openldap/files/patch-aa
@@ -0,0 +1,12 @@
+--- build/lib-shared.mk~ Thu May 25 22:46:57 2000
++++ build/lib-shared.mk Thu May 25 22:50:24 2000
+@@ -20,5 +20,9 @@
+ (d=`$(PWD)` ; $(LN_S) `$(BASENAME) $$d`/$@ ../$@)
+ $(RM) ../`$(BASENAME) $@ .la`.a; \
+ (d=`$(PWD)`; t=`$(BASENAME) $@ .la`.a; $(LN_S) `$(BASENAME) $$d`/.libs/$$t ../$$t)
++ # If we want our binaries to link dynamically with libldap{,_r} liblber...
++ # We also symlink the .so.# so we can run the tests without installing
++ (d=`$(PWD)`; t=`$(BASENAME) $@ .la`.so; $(LN_S) `$(BASENAME) $$d`/.libs/$$t ../$$t)
++ (d=`$(PWD)`; b=`$(BASENAME) $@ .la`; t=`ls $$d/.libs/$$b.so.?`; $(LN_S) `$(BASENAME) $$d`/.libs/`$(BASENAME) $$t` ../`$(BASENAME) $$t`)
+
+ Makefile: $(top_srcdir)/build/lib-shared.mk
diff --git a/net/openldap/files/patch-ab b/net/openldap/files/patch-ab
new file mode 100644
index 000000000000..0e6d89b746e0
--- /dev/null
+++ b/net/openldap/files/patch-ab
@@ -0,0 +1,8 @@
+--- tests/scripts/defines.sh~ Wed May 26 02:06:42 1999
++++ tests/scripts/defines.sh Thu May 25 22:53:23 2000
+@@ -53,3 +53,5 @@
+ ACLOUTMASTER=$DATADIR/acl.out.master
+ REPLOUTMASTER=$DATADIR/repl.out.master
+ MODSRCHFILTERS=$DATADIR/modify.search.filters
++# Just in case we linked the binaries dynamically
++export LD_LIBRARY_PATH=`pwd`/../libraries
diff --git a/net/openldap/files/patch-ac b/net/openldap/files/patch-ac
new file mode 100644
index 000000000000..e491cbc8c38d
--- /dev/null
+++ b/net/openldap/files/patch-ac
@@ -0,0 +1,12 @@
+--- build/lib.mk~ Thu Jan 7 18:36:30 1999
++++ build/lib.mk Thu May 25 22:58:26 2000
+@@ -27,7 +27,8 @@
+ clean-common: FORCE
+ $(RM) $(LIBRARY) ../$(LIBRARY) $(XLIBRARY) \
+ $(PROGRAMS) $(XPROGRAMS) $(XSRCS) $(XXSRCS) \
+- *.o *.lo a.out core version.c .libs/*
++ *.o *.lo a.out core version.c .libs/* \
++ ../`$(BASENAME) $(LIBRARY) .la`.so*
+
+ depend-common: FORCE
+ $(MKDEP) $(DEFS) $(DEFINES) $(SRCS) $(XXSRCS)
diff --git a/net/openldap/files/patch-db b/net/openldap/files/patch-db
index 489f067ffa89..c04351bcc06c 100644
--- a/net/openldap/files/patch-db
+++ b/net/openldap/files/patch-db
@@ -1,13 +1,13 @@
---- configure.orig Mon Jan 17 11:53:36 2000
-+++ configure Thu Mar 2 18:40:40 2000
-@@ -6011,14 +6011,14 @@
+--- configure~ Fri Mar 10 22:18:23 2000
++++ configure Thu May 25 23:48:13 2000
+@@ -6113,14 +6113,14 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ol_LIBS="$LIBS"
- echo $ac_n "checking for db_open in -ldb""... $ac_c" 1>&6
--echo "configure:6016: checking for db_open in -ldb" >&5
+-echo "configure:6118: checking for db_open in -ldb" >&5
+ echo $ac_n "checking for db_open in -ldb2""... $ac_c" 1>&6
-+echo "configure:6016: checking for db_open in -ldb2" >&5
++echo "configure:6118: checking for db_open in -ldb2" >&5
ac_lib_var=`echo db'_'db_open | sed 'y%./+-:%__p__%'`
if eval "test \"\${ac_cv_lib_$ac_lib_var+set}\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -16,9 +16,9 @@
-LIBS="-ldb $LIBS"
+LIBS="-ldb2 $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 6024 "configure"
+ #line 6126 "configure"
#include "confdefs.h"
-@@ -6046,7 +6046,7 @@
+@@ -6148,7 +6148,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
diff --git a/net/openldap12/Makefile b/net/openldap12/Makefile
index 9a7cf89041ec..cfdaaf693a2e 100644
--- a/net/openldap12/Makefile
+++ b/net/openldap12/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 1.2.9
+PORTVERSION= 1.2.10
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/ \
ftp://ftp.net.lut.ac.uk/openldap/openldap-release/ \
@@ -25,10 +25,11 @@ MAINTAINER= ulmo@earthling.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --enable-ldbm --with-ldbm-api=db2
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+CONFIGURE_ARGS+= --localstatedir=/var/run --enable-shared --enable-dns
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
diff --git a/net/openldap12/distinfo b/net/openldap12/distinfo
index 680f37b76df8..9bc43a3d2656 100644
--- a/net/openldap12/distinfo
+++ b/net/openldap12/distinfo
@@ -1 +1 @@
-MD5 (openldap-1.2.9.tgz) = d6ef63849c5a5367cfac84f99a0263e2
+MD5 (openldap-1.2.10.tgz) = d4b904a4da62bbfb2110dfc0cddb6b90
diff --git a/net/openldap12/files/patch-aa b/net/openldap12/files/patch-aa
new file mode 100644
index 000000000000..22b7d8d94a70
--- /dev/null
+++ b/net/openldap12/files/patch-aa
@@ -0,0 +1,12 @@
+--- build/lib-shared.mk~ Thu May 25 22:46:57 2000
++++ build/lib-shared.mk Thu May 25 22:50:24 2000
+@@ -20,5 +20,9 @@
+ (d=`$(PWD)` ; $(LN_S) `$(BASENAME) $$d`/$@ ../$@)
+ $(RM) ../`$(BASENAME) $@ .la`.a; \
+ (d=`$(PWD)`; t=`$(BASENAME) $@ .la`.a; $(LN_S) `$(BASENAME) $$d`/.libs/$$t ../$$t)
++ # If we want our binaries to link dynamically with libldap{,_r} liblber...
++ # We also symlink the .so.# so we can run the tests without installing
++ (d=`$(PWD)`; t=`$(BASENAME) $@ .la`.so; $(LN_S) `$(BASENAME) $$d`/.libs/$$t ../$$t)
++ (d=`$(PWD)`; b=`$(BASENAME) $@ .la`; t=`ls $$d/.libs/$$b.so.?`; $(LN_S) `$(BASENAME) $$d`/.libs/`$(BASENAME) $$t` ../`$(BASENAME) $$t`)
+
+ Makefile: $(top_srcdir)/build/lib-shared.mk
diff --git a/net/openldap12/files/patch-ab b/net/openldap12/files/patch-ab
new file mode 100644
index 000000000000..0e6d89b746e0
--- /dev/null
+++ b/net/openldap12/files/patch-ab
@@ -0,0 +1,8 @@
+--- tests/scripts/defines.sh~ Wed May 26 02:06:42 1999
++++ tests/scripts/defines.sh Thu May 25 22:53:23 2000
+@@ -53,3 +53,5 @@
+ ACLOUTMASTER=$DATADIR/acl.out.master
+ REPLOUTMASTER=$DATADIR/repl.out.master
+ MODSRCHFILTERS=$DATADIR/modify.search.filters
++# Just in case we linked the binaries dynamically
++export LD_LIBRARY_PATH=`pwd`/../libraries
diff --git a/net/openldap12/files/patch-ac b/net/openldap12/files/patch-ac
new file mode 100644
index 000000000000..e491cbc8c38d
--- /dev/null
+++ b/net/openldap12/files/patch-ac
@@ -0,0 +1,12 @@
+--- build/lib.mk~ Thu Jan 7 18:36:30 1999
++++ build/lib.mk Thu May 25 22:58:26 2000
+@@ -27,7 +27,8 @@
+ clean-common: FORCE
+ $(RM) $(LIBRARY) ../$(LIBRARY) $(XLIBRARY) \
+ $(PROGRAMS) $(XPROGRAMS) $(XSRCS) $(XXSRCS) \
+- *.o *.lo a.out core version.c .libs/*
++ *.o *.lo a.out core version.c .libs/* \
++ ../`$(BASENAME) $(LIBRARY) .la`.so*
+
+ depend-common: FORCE
+ $(MKDEP) $(DEFS) $(DEFINES) $(SRCS) $(XXSRCS)
diff --git a/net/openldap12/files/patch-db b/net/openldap12/files/patch-db
index 489f067ffa89..c04351bcc06c 100644
--- a/net/openldap12/files/patch-db
+++ b/net/openldap12/files/patch-db
@@ -1,13 +1,13 @@
---- configure.orig Mon Jan 17 11:53:36 2000
-+++ configure Thu Mar 2 18:40:40 2000
-@@ -6011,14 +6011,14 @@
+--- configure~ Fri Mar 10 22:18:23 2000
++++ configure Thu May 25 23:48:13 2000
+@@ -6113,14 +6113,14 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ol_LIBS="$LIBS"
- echo $ac_n "checking for db_open in -ldb""... $ac_c" 1>&6
--echo "configure:6016: checking for db_open in -ldb" >&5
+-echo "configure:6118: checking for db_open in -ldb" >&5
+ echo $ac_n "checking for db_open in -ldb2""... $ac_c" 1>&6
-+echo "configure:6016: checking for db_open in -ldb2" >&5
++echo "configure:6118: checking for db_open in -ldb2" >&5
ac_lib_var=`echo db'_'db_open | sed 'y%./+-:%__p__%'`
if eval "test \"\${ac_cv_lib_$ac_lib_var+set}\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -16,9 +16,9 @@
-LIBS="-ldb $LIBS"
+LIBS="-ldb2 $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 6024 "configure"
+ #line 6126 "configure"
#include "confdefs.h"
-@@ -6046,7 +6046,7 @@
+@@ -6148,7 +6148,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
diff --git a/net/openldap2/Makefile b/net/openldap2/Makefile
index 9a7cf89041ec..cfdaaf693a2e 100644
--- a/net/openldap2/Makefile
+++ b/net/openldap2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 1.2.9
+PORTVERSION= 1.2.10
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/ \
ftp://ftp.net.lut.ac.uk/openldap/openldap-release/ \
@@ -25,10 +25,11 @@ MAINTAINER= ulmo@earthling.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --enable-ldbm --with-ldbm-api=db2
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+CONFIGURE_ARGS+= --localstatedir=/var/run --enable-shared --enable-dns
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
diff --git a/net/openldap2/distinfo b/net/openldap2/distinfo
index 680f37b76df8..9bc43a3d2656 100644
--- a/net/openldap2/distinfo
+++ b/net/openldap2/distinfo
@@ -1 +1 @@
-MD5 (openldap-1.2.9.tgz) = d6ef63849c5a5367cfac84f99a0263e2
+MD5 (openldap-1.2.10.tgz) = d4b904a4da62bbfb2110dfc0cddb6b90
diff --git a/net/openldap20-server/Makefile b/net/openldap20-server/Makefile
index 9a7cf89041ec..cfdaaf693a2e 100644
--- a/net/openldap20-server/Makefile
+++ b/net/openldap20-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 1.2.9
+PORTVERSION= 1.2.10
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/ \
ftp://ftp.net.lut.ac.uk/openldap/openldap-release/ \
@@ -25,10 +25,11 @@ MAINTAINER= ulmo@earthling.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --enable-ldbm --with-ldbm-api=db2
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+CONFIGURE_ARGS+= --localstatedir=/var/run --enable-shared --enable-dns
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
diff --git a/net/openldap20-server/distinfo b/net/openldap20-server/distinfo
index 680f37b76df8..9bc43a3d2656 100644
--- a/net/openldap20-server/distinfo
+++ b/net/openldap20-server/distinfo
@@ -1 +1 @@
-MD5 (openldap-1.2.9.tgz) = d6ef63849c5a5367cfac84f99a0263e2
+MD5 (openldap-1.2.10.tgz) = d4b904a4da62bbfb2110dfc0cddb6b90
diff --git a/net/openldap20/Makefile b/net/openldap20/Makefile
index 9a7cf89041ec..cfdaaf693a2e 100644
--- a/net/openldap20/Makefile
+++ b/net/openldap20/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 1.2.9
+PORTVERSION= 1.2.10
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/ \
ftp://ftp.net.lut.ac.uk/openldap/openldap-release/ \
@@ -25,10 +25,11 @@ MAINTAINER= ulmo@earthling.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --enable-ldbm --with-ldbm-api=db2
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+CONFIGURE_ARGS+= --localstatedir=/var/run --enable-shared --enable-dns
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
diff --git a/net/openldap20/distinfo b/net/openldap20/distinfo
index 680f37b76df8..9bc43a3d2656 100644
--- a/net/openldap20/distinfo
+++ b/net/openldap20/distinfo
@@ -1 +1 @@
-MD5 (openldap-1.2.9.tgz) = d6ef63849c5a5367cfac84f99a0263e2
+MD5 (openldap-1.2.10.tgz) = d4b904a4da62bbfb2110dfc0cddb6b90
diff --git a/net/openldap21-server/Makefile b/net/openldap21-server/Makefile
index 9a7cf89041ec..cfdaaf693a2e 100644
--- a/net/openldap21-server/Makefile
+++ b/net/openldap21-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 1.2.9
+PORTVERSION= 1.2.10
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/ \
ftp://ftp.net.lut.ac.uk/openldap/openldap-release/ \
@@ -25,10 +25,11 @@ MAINTAINER= ulmo@earthling.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --enable-ldbm --with-ldbm-api=db2
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+CONFIGURE_ARGS+= --localstatedir=/var/run --enable-shared --enable-dns
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
diff --git a/net/openldap21-server/distinfo b/net/openldap21-server/distinfo
index 680f37b76df8..9bc43a3d2656 100644
--- a/net/openldap21-server/distinfo
+++ b/net/openldap21-server/distinfo
@@ -1 +1 @@
-MD5 (openldap-1.2.9.tgz) = d6ef63849c5a5367cfac84f99a0263e2
+MD5 (openldap-1.2.10.tgz) = d4b904a4da62bbfb2110dfc0cddb6b90
diff --git a/net/openldap21/Makefile b/net/openldap21/Makefile
index 9a7cf89041ec..cfdaaf693a2e 100644
--- a/net/openldap21/Makefile
+++ b/net/openldap21/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 1.2.9
+PORTVERSION= 1.2.10
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/ \
ftp://ftp.net.lut.ac.uk/openldap/openldap-release/ \
@@ -25,10 +25,11 @@ MAINTAINER= ulmo@earthling.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --enable-ldbm --with-ldbm-api=db2
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+CONFIGURE_ARGS+= --localstatedir=/var/run --enable-shared --enable-dns
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
diff --git a/net/openldap21/distinfo b/net/openldap21/distinfo
index 680f37b76df8..9bc43a3d2656 100644
--- a/net/openldap21/distinfo
+++ b/net/openldap21/distinfo
@@ -1 +1 @@
-MD5 (openldap-1.2.9.tgz) = d6ef63849c5a5367cfac84f99a0263e2
+MD5 (openldap-1.2.10.tgz) = d4b904a4da62bbfb2110dfc0cddb6b90
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index 9a7cf89041ec..cfdaaf693a2e 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 1.2.9
+PORTVERSION= 1.2.10
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/ \
ftp://ftp.net.lut.ac.uk/openldap/openldap-release/ \
@@ -25,10 +25,11 @@ MAINTAINER= ulmo@earthling.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --enable-ldbm --with-ldbm-api=db2
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+CONFIGURE_ARGS+= --localstatedir=/var/run --enable-shared --enable-dns
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
diff --git a/net/openldap22-server/distinfo b/net/openldap22-server/distinfo
index 680f37b76df8..9bc43a3d2656 100644
--- a/net/openldap22-server/distinfo
+++ b/net/openldap22-server/distinfo
@@ -1 +1 @@
-MD5 (openldap-1.2.9.tgz) = d6ef63849c5a5367cfac84f99a0263e2
+MD5 (openldap-1.2.10.tgz) = d4b904a4da62bbfb2110dfc0cddb6b90
diff --git a/net/openldap22/Makefile b/net/openldap22/Makefile
index 9a7cf89041ec..cfdaaf693a2e 100644
--- a/net/openldap22/Makefile
+++ b/net/openldap22/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 1.2.9
+PORTVERSION= 1.2.10
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/ \
ftp://ftp.net.lut.ac.uk/openldap/openldap-release/ \
@@ -25,10 +25,11 @@ MAINTAINER= ulmo@earthling.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --enable-ldbm --with-ldbm-api=db2
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+CONFIGURE_ARGS+= --localstatedir=/var/run --enable-shared --enable-dns
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
diff --git a/net/openldap22/distinfo b/net/openldap22/distinfo
index 680f37b76df8..9bc43a3d2656 100644
--- a/net/openldap22/distinfo
+++ b/net/openldap22/distinfo
@@ -1 +1 @@
-MD5 (openldap-1.2.9.tgz) = d6ef63849c5a5367cfac84f99a0263e2
+MD5 (openldap-1.2.10.tgz) = d4b904a4da62bbfb2110dfc0cddb6b90
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 9a7cf89041ec..cfdaaf693a2e 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 1.2.9
+PORTVERSION= 1.2.10
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/ \
ftp://ftp.net.lut.ac.uk/openldap/openldap-release/ \
@@ -25,10 +25,11 @@ MAINTAINER= ulmo@earthling.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --enable-ldbm --with-ldbm-api=db2
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+CONFIGURE_ARGS+= --localstatedir=/var/run --enable-shared --enable-dns
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
diff --git a/net/openldap23-server/distinfo b/net/openldap23-server/distinfo
index 680f37b76df8..9bc43a3d2656 100644
--- a/net/openldap23-server/distinfo
+++ b/net/openldap23-server/distinfo
@@ -1 +1 @@
-MD5 (openldap-1.2.9.tgz) = d6ef63849c5a5367cfac84f99a0263e2
+MD5 (openldap-1.2.10.tgz) = d4b904a4da62bbfb2110dfc0cddb6b90
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 9a7cf89041ec..cfdaaf693a2e 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 1.2.9
+PORTVERSION= 1.2.10
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/ \
ftp://ftp.net.lut.ac.uk/openldap/openldap-release/ \
@@ -25,10 +25,11 @@ MAINTAINER= ulmo@earthling.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --enable-ldbm --with-ldbm-api=db2
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+CONFIGURE_ARGS+= --localstatedir=/var/run --enable-shared --enable-dns
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
diff --git a/net/openldap24-server/distinfo b/net/openldap24-server/distinfo
index 680f37b76df8..9bc43a3d2656 100644
--- a/net/openldap24-server/distinfo
+++ b/net/openldap24-server/distinfo
@@ -1 +1 @@
-MD5 (openldap-1.2.9.tgz) = d6ef63849c5a5367cfac84f99a0263e2
+MD5 (openldap-1.2.10.tgz) = d4b904a4da62bbfb2110dfc0cddb6b90