aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2000-04-23 06:25:32 +0800
committerVanilla I. Shu <vanilla@FreeBSD.org>2000-04-23 06:25:32 +0800
commitb7fe3ddec43768f852d83ba491ac14d71dd679f9 (patch)
tree501a450ce7c0392485700768b55f20b52e645935 /net
parentdd5c40113f83fb4a2d35575673dd8ade845766d8 (diff)
downloadfreebsd-ports-b7fe3ddec43768f852d83ba491ac14d71dd679f9.tar.gz
freebsd-ports-b7fe3ddec43768f852d83ba491ac14d71dd679f9.tar.zst
freebsd-ports-b7fe3ddec43768f852d83ba491ac14d71dd679f9.zip
Upgrade
p5-Errno => 1.09 p5-File-BasicFlock => 98.1202 p5-File-Sync => 0.09 p5-Filter => 1.18 p5-HTML-Parser => 3.07 p5-IO-Tty => 0.03 p5-IO-stringy => 1.210 p5-Mysql => 1.2213 p5-Net => 1.703 p5-Storable => 0.6.11 p5-URI => 1.06 p5-libwww => 5.48
Notes
Notes: svn path=/head/; revision=27907
Diffstat (limited to 'net')
-rw-r--r--net/p5-Net/Makefile5
-rw-r--r--net/p5-Net/distinfo2
-rw-r--r--net/p5-Net/files/patch-aa175
-rw-r--r--net/p5-Net/pkg-plist3
-rw-r--r--net/p5-URI/Makefile6
-rw-r--r--net/p5-URI/distinfo2
-rw-r--r--net/p5-URI/pkg-plist44
7 files changed, 180 insertions, 57 deletions
diff --git a/net/p5-Net/Makefile b/net/p5-Net/Makefile
index 182d50bcbbd6..0c8c08243555 100644
--- a/net/p5-Net/Makefile
+++ b/net/p5-Net/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= p5-Net
-PORTVERSION= 1.0607
+PORTVERSION= 1.0703
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
@@ -28,7 +28,8 @@ MAN3= \
Net::POP3.3 \
Net::SMTP.3 \
Net::SNPP.3 \
- Net::Time.3
+ Net::Time.3 \
+ Net::libnetFAQ.3
do-configure:
@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
diff --git a/net/p5-Net/distinfo b/net/p5-Net/distinfo
index f61926e73441..0d1ef6009b7a 100644
--- a/net/p5-Net/distinfo
+++ b/net/p5-Net/distinfo
@@ -1 +1 @@
-MD5 (libnet-1.0607.tar.gz) = bce57ec6d44f711f6b6fd229efba457f
+MD5 (libnet-1.0703.tar.gz) = 78dc0672a735756ec3c2bba15498cfa0
diff --git a/net/p5-Net/files/patch-aa b/net/p5-Net/files/patch-aa
index f46d98cd546a..09254573ba30 100644
--- a/net/p5-Net/files/patch-aa
+++ b/net/p5-Net/files/patch-aa
@@ -1,12 +1,12 @@
---- Configure.orig Sat Sep 18 19:28:55 1999
-+++ Configure Sat Jan 8 02:43:46 2000
+--- Configure.orig Tue Jan 18 00:44:18 2000
++++ Configure Sun Apr 23 05:00:59 2000
@@ -1,4 +1,4 @@
-#!/usr/local/bin/perl
+#!/usr/bin/perl
#
# $Id: Configure,v 1.8 1997/03/04 09:22:32 gbarr Exp $
-@@ -241,18 +241,19 @@
+@@ -258,18 +258,19 @@
#---------------------------------------------------------------------------
@@ -32,13 +32,13 @@
+#EDQ
+#
+# $opt_d = 1
-+# unless get_bool($msg,0);
++# unless get_bool($msg,0);
+# }
+$opt_d = 0;
#---------------------------------------------------------------------------
-@@ -269,7 +270,8 @@
+@@ -286,7 +287,8 @@
Do you want me to perform hostname lookups (y|n) ?
EDQ
@@ -48,7 +48,7 @@
print <<EDQ unless $cfg{'test_exist'};
-@@ -284,71 +286,78 @@
+@@ -301,139 +303,144 @@
#---------------------------------------------------------------------------
@@ -78,7 +78,7 @@
-$cfg{'nntp_hosts'} = get_host_list($msg,$def);
+#$cfg{'nntp_hosts'} = get_host_list($msg,$def);
-+$cfg{'nntp_hosts'} = [ default_hostname($ENV{NNTPSERVER}, $ENV{NEWSHOST}, 'news') ];
++$cfg{'nntp_hosts'} = [default_hostname($ENV{NNTPSERVER}, $ENV{NEWSHOST}, 'news') ];
#---------------------------------------------------------------------------
@@ -152,20 +152,137 @@
#---------------------------------------------------------------------------
-@@ -364,9 +373,10 @@
- FTP proxy hostname :
- EDQ
-
--$def = $oldcfg{'ftp_firewall'} || $ENV{FTP_FIREWALL};
-+#$def = $oldcfg{'ftp_firewall'} || $ENV{FTP_FIREWALL};
-
--$cfg{'ftp_firewall'} = get_hostname($msg,$def);
-+#$cfg{'ftp_firewall'} = get_hostname($msg,$def);
+-$msg = <<EDQ;
+-
+-Do you have a firewall/ftp proxy between your machine and the internet
+-
+-If you use a SOCKS firewall answer no
+-
+-(y|n) ?
+-EDQ
+-
+-if(get_bool($msg,0)) {
+-
+- $msg = <<'EDQ';
+-What series of FTP commands do you need to send to your
+-firewall to connect to an external host.
+-
+-user/pass => external user & password
+-fwuser/fwpass => firewall user & password
+-
+-0) None
+-1) -----------------------
+- USER user@remote.host
+- PASS pass
+-2) -----------------------
+- USER fwuser
+- PASS fwpass
+- USER user@remote.host
+- PASS pass
+-3) -----------------------
+- USER fwuser
+- PASS fwpass
+- SITE remote.site
+- USER user
+- PASS pass
+-4) -----------------------
+- USER fwuser
+- PASS fwpass
+- OPEN remote.site
+- USER user
+- PASS pass
+-5) -----------------------
+- USER user@fwuser@remote.site
+- PASS pass@fwpass
+-6) -----------------------
+- USER fwuser@remote.site
+- PASS fwpass
+- USER user
+- PASS pass
+-7) -----------------------
+- USER user@remote.host
+- PASS pass
+- AUTH fwuser
+- RESP fwpass
+-
+-Choice:
+-EDQ
+- $def = exists $oldcfg{'ftp_firewall_type'} ? $oldcfg{'ftp_firewall_type'} : 1;
+- $ans = Prompt($msg,$def);
+- $cfg{'ftp_firewall_type'} = 0+$ans;
+- $def = $oldcfg{'ftp_firewall'} || $ENV{FTP_FIREWALL};
++#$msg = <<EDQ;
++#
++#Do you have a firewall/ftp proxy between your machine and the internet
++#
++#If you use a SOCKS firewall answer no
++#
++#(y|n) ?
++#EDQ
++#
++#if(get_bool($msg,0)) {
++#
++# $msg = <<'EDQ';
++#What series of FTP commands do you need to send to your
++#firewall to connect to an external host.
++#
++#user/pass => external user & password
++#fwuser/fwpass => firewall user & password
++#
++#0) None
++#1) -----------------------
++# USER user@remote.host
++# PASS pass
++#2) -----------------------
++# USER fwuser
++# PASS fwpass
++# USER user@remote.host
++# PASS pass
++#3) -----------------------
++# USER fwuser
++# PASS fwpass
++# SITE remote.site
++# USER user
++# PASS pass
++#4) -----------------------
++# USER fwuser
++# PASS fwpass
++# OPEN remote.site
++# USER user
++# PASS pass
++#5) -----------------------
++# USER user@fwuser@remote.site
++# PASS pass@fwpass
++#6) -----------------------
++# USER fwuser@remote.site
++# PASS fwpass
++# USER user
++# PASS pass
++#7) -----------------------
++# USER user@remote.host
++# PASS pass
++# AUTH fwuser
++# RESP fwpass
++
++#Choice:
++#EDQ
++# $def = exists $oldcfg{'ftp_firewall_type'} ? $oldcfg{'ftp_firewall_type'} : 1;
++# $ans = Prompt($msg,$def);
++# $cfg{'ftp_firewall_type'} = 0+$ans;
++ $cfg{'ftp_firewall_type'} = 0;
++# $def = $oldcfg{'ftp_firewall'} || $ENV{FTP_FIREWALL};
+
+- $cfg{'ftp_firewall'} = get_hostname("FTP proxy hostname :", $def);
+-}
+-else {
+- delete $cfg{'ftp_firewall'};
+-}
++# $cfg{'ftp_firewall'} = get_hostname("FTP proxy hostname :", $def);
+$cfg{'ftp_firewall'} = $ENV{FTP_FIREWALL};
- #---------------------------------------------------------------------------
-@@ -414,37 +424,40 @@
+ #---------------------------------------------------------------------------
+@@ -489,22 +496,23 @@
#---------------------------------------------------------------------------
@@ -188,21 +305,25 @@
+#server, this is called a passive transfer.
+#EDQ
- $msg = "\nShould all FTP connections via a firewall/proxy be passive (y|n) ?";
+ if (defined $cfg{'ftp_firewall'}) {
+ $msg = "\nShould all FTP connections via a firewall/proxy be passive (y|n) ?";
+
+- $def = $oldcfg{'ftp_ext_passive'} || 0;
++# $def = $oldcfg{'ftp_ext_passive'} || 0;
--$def = $oldcfg{'ftp_ext_passive'} || 0;
-+#$def = $oldcfg{'ftp_ext_passive'} || 0;
+- $cfg{'ftp_ext_passive'} = get_bool($msg,$def);
++# $cfg{'ftp_ext_passive'} = get_bool($msg,$def);
++ $cfg{'ftp_ext_passive'} = 0;
--$cfg{'ftp_ext_passive'} = get_bool($msg,$def);
-+#$cfg{'ftp_ext_passive'} = get_bool($msg,$def);
-+$cfg{'ftp_ext_passive'} = 0;
+ $msg = "\nShould all other FTP connections be passive (y|n) ?";
+@@ -513,18 +521,20 @@
+ $msg = "\nShould all FTP connections be passive (y|n) ?";
+ }
-$def = $oldcfg{'ftp_int_passive'} || 0;
+#$def = $oldcfg{'ftp_int_passive'} || 0;
- $msg = "\nShould all other FTP connections be passive (y|n) ?";
-
-$cfg{'ftp_int_passive'} = get_bool($msg,$def);
+#$cfg{'ftp_int_passive'} = get_bool($msg,$def);
+$cfg{'ftp_int_passive'} = 0;
@@ -222,7 +343,7 @@
#---------------------------------------------------------------------------
-@@ -460,7 +473,8 @@
+@@ -540,7 +550,8 @@
Do you want me to run these tests (y|n) ?
EDQ
diff --git a/net/p5-Net/pkg-plist b/net/p5-Net/pkg-plist
index 8228a29fd012..8c46c8d6ff30 100644
--- a/net/p5-Net/pkg-plist
+++ b/net/p5-Net/pkg-plist
@@ -16,7 +16,6 @@ lib/perl5/site_perl/%%PERL_VER%%/Net/SMTP.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/SNPP.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/Time.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/libnet.cfg
+lib/perl5/site_perl/%%PERL_VER%%/Net/libnetFAQ.pod
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/.packlist
@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/FTP
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net
diff --git a/net/p5-URI/Makefile b/net/p5-URI/Makefile
index 2940a961049f..8f9c289ed7ff 100644
--- a/net/p5-URI/Makefile
+++ b/net/p5-URI/Makefile
@@ -5,12 +5,12 @@
# $FreeBSD$
#
-PORTNAME= p5-URI
-PORTVERSION= 1.04
+PORTNAME= URI
+PORTVERSION= 1.06
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= URI
-DISTNAME= URI-1.04
+PKGNAMEPREFIX= p5-
MAINTAINER= ache@FreeBSD.org
diff --git a/net/p5-URI/distinfo b/net/p5-URI/distinfo
index a1ecf81f95f8..7e387c8f3f47 100644
--- a/net/p5-URI/distinfo
+++ b/net/p5-URI/distinfo
@@ -1 +1 @@
-MD5 (URI-1.04.tar.gz) = e830d0b7ece66c2fd537cccf048ec0c2
+MD5 (URI-1.06.tar.gz) = aa6cb7a0d2cbac2f2afbfc39eb80821c
diff --git a/net/p5-URI/pkg-plist b/net/p5-URI/pkg-plist
index a9482a082d17..1f6b66d4a274 100644
--- a/net/p5-URI/pkg-plist
+++ b/net/p5-URI/pkg-plist
@@ -1,36 +1,38 @@
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/URI/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/URI.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/_foreign.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/_generic.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/_login.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/_query.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/_segment.pm
lib/perl5/site_perl/%%PERL_VER%%/URI/_server.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/_userpass.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/Escape.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/Heuristic.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/URL.pm
lib/perl5/site_perl/%%PERL_VER%%/URI/WithBase.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/_login.pm
lib/perl5/site_perl/%%PERL_VER%%/URI/data.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/_generic.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/news.pm
lib/perl5/site_perl/%%PERL_VER%%/URI/file.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/file/Base.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/file/FAT.pm
lib/perl5/site_perl/%%PERL_VER%%/URI/file/Mac.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/file/Win32.pm
lib/perl5/site_perl/%%PERL_VER%%/URI/file/OS2.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/file/FAT.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/file/Base.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/file/QNX.pm
lib/perl5/site_perl/%%PERL_VER%%/URI/file/Unix.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/nntp.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/file/Win32.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/ftp.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/gopher.pm
lib/perl5/site_perl/%%PERL_VER%%/URI/http.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/https.pm
lib/perl5/site_perl/%%PERL_VER%%/URI/ldap.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/gopher.pm
lib/perl5/site_perl/%%PERL_VER%%/URI/mailto.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/_foreign.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/ftp.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/rlogin.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/telnet.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/news.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/nntp.pm
lib/perl5/site_perl/%%PERL_VER%%/URI/pop.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/rlogin.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/rsync.pm
lib/perl5/site_perl/%%PERL_VER%%/URI/snews.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/Heuristic.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/Escape.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/_segment.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/URL.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/https.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/_userpass.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI/_query.pm
-lib/perl5/site_perl/%%PERL_VER%%/URI.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/telnet.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/URI/.packlist
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/URI
@dirrm lib/perl5/site_perl/%%PERL_VER%%/URI/file
@dirrm lib/perl5/site_perl/%%PERL_VER%%/URI