aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2018-01-15 01:47:12 +0800
committerTijl Coosemans <tijl@FreeBSD.org>2018-01-15 01:47:12 +0800
commitf226855a77b6fa645add2bd3584a818032c4529b (patch)
treefdb1ac84a7728a80d42a2b756e7dcae21bfaa60f /science
parent96c93430c459b6dacf22a004a03092f6fa952b67 (diff)
downloadfreebsd-ports-f226855a77b6fa645add2bd3584a818032c4529b.tar.gz
freebsd-ports-f226855a77b6fa645add2bd3584a818032c4529b.tar.zst
freebsd-ports-f226855a77b6fa645add2bd3584a818032c4529b.zip
- Don't run autoreconf, but run some of the autotools from pre-configure
instead. Autoreconf runs autoheader which replaces a handmade config header. - Remove options. DEBUG only adds -g which is already handled by WITH_DEBUG. DERIV and R12 don't have any impact. They are enabled by default upstream and the port Makefile never passed --disable-* when the options are disabled. Reasons to remove these options: the only port (science/mpqc) that depends on this port requires the options to be enabled, no additional dependencies and no significant additional build time or disk space.
Notes
Notes: svn path=/head/; revision=458985
Diffstat (limited to 'science')
-rw-r--r--science/libint/Makefile18
-rw-r--r--science/libint/files/patch-configure.in29
2 files changed, 7 insertions, 40 deletions
diff --git a/science/libint/Makefile b/science/libint/Makefile
index 2b1913c32c2b..a919de95a9cf 100644
--- a/science/libint/Makefile
+++ b/science/libint/Makefile
@@ -4,7 +4,7 @@
PORTNAME= libint
DISTVERSIONPREFIX= release-
DISTVERSION= 1-1-6
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= science
MAINTAINER= ports@FreeBSD.org
@@ -21,7 +21,7 @@ GH_ACCOUNT= evaleev
# in libgcc_s.so which fails if it's different versions. Forcing this port
# to build with the default version of GCC as well resolves the conflict
# that manifests in the science/libghemical port.
-USES= autoreconf gmake libtool perl5
+USES= autoreconf:build gmake libtool perl5
USE_GCC= yes
USE_LDCONFIG= yes
ALL_TARGET= default
@@ -30,19 +30,15 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --with-cc-optflags="${CFLAGS}" \
--with-cxx-optflags="${CXXFLAGS}"
-OPTIONS_DEFINE= DEBUG DERIV R12
-
-DERIV_DESC= 1st- and 2nd-order derivative ERI support
-R12_DESC= Linear R12 methods integrals support
-
-DEBUG_CONFIGURE_ON= --enable-debug
-DERIV_CONFIGURE_ON= --enable-deriv
-R12_CONFIGURE_ON= --enable-r12
-
post-patch:
@${REINPLACE_CMD} -e 's| -rpath|${LDFLAGS} -rpath|g' \
${WRKSRC}/src/lib/MakeVars.in
+pre-configure:
+# Cannot run autoheader so cannot use autoreconf.
+ @(cd ${WRKSRC} && ${LOCALBASE}/bin/libtoolize -c -f \
+ && ${LOCALBASE}/bin/aclocal && ${LOCALBASE}/bin/autoconf)
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so
diff --git a/science/libint/files/patch-configure.in b/science/libint/files/patch-configure.in
deleted file mode 100644
index 7d813ca558ba..000000000000
--- a/science/libint/files/patch-configure.in
+++ /dev/null
@@ -1,29 +0,0 @@
---- configure.in.orig 2014-03-05 18:27:30 UTC
-+++ configure.in
-@@ -17,6 +17,26 @@ AC_SET_MAKE
- AC_DEFINE_UNQUOTED(HOST_ARCH, "$host")
- AC_DEFINE_UNQUOTED(TARGET_ARCH, "$target")
-
-+AC_DEFINE([HOST_ARCH], [], [Description])
-+AC_DEFINE([INCLUDE_DERIV], [], [Description])
-+AC_DEFINE([INCLUDE_R12], [], [Description])
-+AC_DEFINE([LIBDERIV_MAX_AM1], [], [Description])
-+AC_DEFINE([LIBDERIV_MAX_AM12], [], [Description])
-+AC_DEFINE([LIBDERIV_MAX_AM2], [], [Description])
-+AC_DEFINE([LIBINT_BUILDID], [], [Description])
-+AC_DEFINE([LIBINT_MAJOR_VERSION], [], [Description])
-+AC_DEFINE([LIBINT_MAX_AM], [], [Description])
-+AC_DEFINE([LIBINT_MAX_CLASS_SIZE], [], [Description])
-+AC_DEFINE([LIBINT_MICRO_VERSION], [], [Description])
-+AC_DEFINE([LIBINT_MINOR_VERSION], [], [Description])
-+AC_DEFINE([LIBINT_OPT_AM], [], [Description])
-+AC_DEFINE([LIBINT_VERSION], [], [Description])
-+AC_DEFINE([LIBR12_MAX_AM], [], [Description])
-+AC_DEFINE([LIBR12_MAX_CLASS_SIZE], [], [Description])
-+AC_DEFINE([LIBR12_OPT_AM], [], [Description])
-+AC_DEFINE([LONG_DOUBLE], [], [Description])
-+AC_DEFINE([TARGET_ARCH], [], [Description])
-+
- define([default_prefix_dash],ifelse(libint_buildid, ,[],[-]))
- define([default_prefix],"/usr/local")
-