aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-02-15 20:34:49 +0800
committerMathieu Arnold <mat@FreeBSD.org>2018-02-15 20:34:49 +0800
commitf6e7f26602a0e7b744f2023d058596324ca164e8 (patch)
treebf19f32ea6808c09829f1a5d7bde66757b0d8790 /science
parent87573cd4ed13f0339deb204f9319f03445049b61 (diff)
downloadfreebsd-ports-f6e7f26602a0e7b744f2023d058596324ca164e8.tar.gz
freebsd-ports-f6e7f26602a0e7b744f2023d058596324ca164e8.tar.zst
freebsd-ports-f6e7f26602a0e7b744f2023d058596324ca164e8.zip
devel/boost-python-libs got forgotten in the python flavorization, fix
this oversight. Reviewed by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14368
Notes
Notes: svn path=/head/; revision=461885
Diffstat (limited to 'science')
-rw-r--r--science/avogadro/Makefile2
-rw-r--r--science/tfel/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/science/avogadro/Makefile b/science/avogadro/Makefile
index 6bf6fe78a910..9934c6533334 100644
--- a/science/avogadro/Makefile
+++ b/science/avogadro/Makefile
@@ -37,7 +37,7 @@ OPTIONS_SUB= yes
PYTHON_USES= python:2
PYTHON_BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sip>0:devel/py-sip@${PY_FLAVOR}
-PYTHON_LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+PYTHON_LIB_DEPENDS= ${PY_BOOST}
PYTHON_RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sip>0:devel/py-sip@${PY_FLAVOR}
PYTHON_CMAKE_ON= -DENABLE_PYTHON=ON \
diff --git a/science/tfel/Makefile b/science/tfel/Makefile
index c9e42c92e094..b8c82e40b722 100644
--- a/science/tfel/Makefile
+++ b/science/tfel/Makefile
@@ -22,7 +22,7 @@ OPTIONS_SUB= yes
GNUPLOT_BUILD_DEPENDS= gnuplot:math/gnuplot
GNUPLOT_RUN_DEPENDS= gnuplot:math/gnuplot
-PYTHON_LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+PYTHON_LIB_DEPENDS= ${PY_BOOST}
PYTHON_USES= localbase python:2.7
PYTHON_CONFIGURE_ARGS= --enable-python-bindings
PYTHON_CONFIGURE_WITH= boost=${LOCALBASE}