aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2018-02-27 07:06:02 +0800
committerMark Felder <feld@FreeBSD.org>2018-02-27 07:06:02 +0800
commit8bbc085f0a780de41889a538ce556e1e7e5f43ab (patch)
tree9e27b687e431917a7afe8ce6f333ada832df2c32 /textproc
parentadf4114742aad15c807a5656931451ed76d6c10e (diff)
downloadfreebsd-ports-8bbc085f0a780de41889a538ce556e1e7e5f43ab.tar.gz
freebsd-ports-8bbc085f0a780de41889a538ce556e1e7e5f43ab.tar.zst
freebsd-ports-8bbc085f0a780de41889a538ce556e1e7e5f43ab.zip
textproc/elasticsearch5: Fix JNA support
JNA (Java Native Access) provides access to OS-native facilities in pure Java code. The JNA shipped with Elastic is meant for Linux so it does not function correctly. We will ship one built for FreeBSD instead. PR: 222261 Approved by: portmgr (with hat)
Notes
Notes: svn path=/head/; revision=463096
Diffstat (limited to 'textproc')
-rw-r--r--textproc/elasticsearch5/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/textproc/elasticsearch5/Makefile b/textproc/elasticsearch5/Makefile
index 68f732617d01..3d116104acfe 100644
--- a/textproc/elasticsearch5/Makefile
+++ b/textproc/elasticsearch5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elasticsearch
PORTVERSION= 5.6.8
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= textproc java devel
MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -15,6 +15,7 @@ COMMENT= Full-text search engine for Java
LICENSE= APACHE20
RUN_DEPENDS= bash>0:shells/bash
+BUILD_DEPENDS= jna>0:devel/jna
CONFLICTS= elasticsearch-[0-9]* elasticsearch2-[0-9]* elasticsearch6-[0-9]*
@@ -53,6 +54,7 @@ post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/elasticsearch.yml
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/bin/elasticsearch.in.sh
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/bin/elasticsearch
+ ${RM} ${WRKSRC}/lib/jna-*.jar
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/elasticsearch
@@ -71,6 +73,7 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
${INSTALL} -lrs ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin/elasticsearch-plugin ${STAGEDIR}${PREFIX}/bin/elasticsearch-plugin
+ ${INSTALL} -lrs ${JAVASHAREDIR}/classes/jna.jar ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/jna.jar
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}