aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-17 18:44:18 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-17 18:44:18 +0800
commit12f62f844112d2b74fa11e600dd11f40b70cf4bb (patch)
tree6bfc373d49b5b6341865f742e9796a81a8facc91 /www
parent06cb642db4135835b1e7feb645de05f450708a6b (diff)
downloadfreebsd-ports-12f62f844112d2b74fa11e600dd11f40b70cf4bb.tar.gz
freebsd-ports-12f62f844112d2b74fa11e600dd11f40b70cf4bb.tar.zst
freebsd-ports-12f62f844112d2b74fa11e600dd11f40b70cf4bb.zip
Convert to options dependency helper
- Fix indent - Add GitHub repository to WWW - Take maintainership
Notes
Notes: svn path=/head/; revision=464783
Diffstat (limited to 'www')
-rw-r--r--www/radicale/Makefile43
-rw-r--r--www/radicale/pkg-descr1
2 files changed, 20 insertions, 24 deletions
diff --git a/www/radicale/Makefile b/www/radicale/Makefile
index ece666cd1760..79cc44e3dbc9 100644
--- a/www/radicale/Makefile
+++ b/www/radicale/Makefile
@@ -1,29 +1,32 @@
# Created by: Mark Felder <feld@FreeBSD.org>
# $FreeBSD$
-PORTNAME= radicale
-PORTVERSION= 1.1.6
-CATEGORIES= www python
-MASTER_SITES= CHEESESHOP
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= Radicale-${PORTVERSION}
+PORTNAME= radicale
+PORTVERSION= 1.1.6
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Radicale-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Python based CalDAV/CardDAV server
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python based CalDAV/CardDAV server
-LICENSE= GPLv3
+LICENSE= GPLv3
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist distutils
NO_ARCH= yes
-USERS= radicale
-GROUPS= radicale
-USE_RC_SUBR= radicale
-SUB_LIST+= USERS="${USERS}" PYTHON_CMD="${PYTHON_CMD}"
+USERS= radicale
+GROUPS= radicale
+USE_RC_SUBR= radicale
+SUB_LIST= USERS="${USERS}" PYTHON_CMD="${PYTHON_CMD}"
-OPTIONS_DEFINE= HTTP LDAP
-HTTP_DESC= HTTP authentication support
+OPTIONS_DEFINE= HTTP LDAP
+HTTP_DESC= HTTP authentication support
+
+HTTP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests1>=0:www/py-requests1@${FLAVOR}
+LDAP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ldap>=0:net/py-ldap@${FLAVOR}
.include <bsd.port.options.mk>
@@ -33,14 +36,6 @@ USES+= python:2.7
USES+= python
.endif
-.if ${PORT_OPTIONS:MHTTP}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}requests1>=0:www/py-requests1@${FLAVOR}
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}ldap>=0:net/py-ldap@${FLAVOR}
-.endif
-
post-patch:
${REINPLACE_CMD} 's,= /etc,= ${PREFIX}/etc,g' ${WRKSRC}/config
${REINPLACE_CMD} 's,~/.config/radicale,${DATADIR},g' ${WRKSRC}/config
diff --git a/www/radicale/pkg-descr b/www/radicale/pkg-descr
index b084ce48acdf..160888c95753 100644
--- a/www/radicale/pkg-descr
+++ b/www/radicale/pkg-descr
@@ -2,3 +2,4 @@ The Radicale Project is a complete CalDAV (calendar) and CardDAV (contact)
server solution.
WWW: http://radicale.org/
+WWW: https://github.com/Kozea/Radicale