aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-07-11 16:58:51 +0800
committerGuido Falsi <madpilot@FreeBSD.org>2016-07-11 16:58:51 +0800
commit178b2506b41ad33dbe7f7311864facf0b4a751a1 (patch)
treeba482914448a4cee1bba93508b51b496cce63045 /x11-toolkits
parent64d7f0b0c45994325abd9124e46e518ac0228a64 (diff)
downloadfreebsd-ports-178b2506b41ad33dbe7f7311864facf0b4a751a1.tar.gz
freebsd-ports-178b2506b41ad33dbe7f7311864facf0b4a751a1.tar.zst
freebsd-ports-178b2506b41ad33dbe7f7311864facf0b4a751a1.zip
- Update to 3.6.6
- Add missing dependencies for editors/scite PR: 210940 Submitted by: lightside at gmx.com Approved by: Naram Qashat <cyberbotx at cyberbotx.com> (maintainer)
Notes
Notes: svn path=/head/; revision=418359
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/scintilla/Makefile4
-rw-r--r--x11-toolkits/scintilla/distinfo6
-rw-r--r--x11-toolkits/scintilla/files/patch-makefile20
3 files changed, 16 insertions, 14 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index dab6cb9b8c1e..7f5b7fb7c9be 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= scintilla
-PORTVERSION= 3.6.5
+PORTVERSION= 3.6.6
CATEGORIES= x11-toolkits
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= scite${PORTVERSION:S/.//g}
@@ -17,7 +17,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
-USES= gmake iconv pkgconfig tar:tgz
+USES= compiler:c++11-lib gmake iconv pkgconfig tar:tgz
MAKEFILE= makefile
USE_LDCONFIG= yes
USE_GNOME= gtk20
diff --git a/x11-toolkits/scintilla/distinfo b/x11-toolkits/scintilla/distinfo
index d08485816a86..5f80697c0717 100644
--- a/x11-toolkits/scintilla/distinfo
+++ b/x11-toolkits/scintilla/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1463151644
-SHA256 (scite365.tgz) = dde62ebebbd4c36afd81ab0e745ff04839f4cfc911496f2d0463aade1374b9d1
-SIZE (scite365.tgz) = 2391190
+TIMESTAMP = 1464048149
+SHA256 (scite366.tgz) = 22218673f53bc587c1cb8d9ddc5c3058a9906c2a530d9270f31f943625e0dffa
+SIZE (scite366.tgz) = 2371062
diff --git a/x11-toolkits/scintilla/files/patch-makefile b/x11-toolkits/scintilla/files/patch-makefile
index 45c625340a85..fe0d1ca27461 100644
--- a/x11-toolkits/scintilla/files/patch-makefile
+++ b/x11-toolkits/scintilla/files/patch-makefile
@@ -1,9 +1,9 @@
---- makefile.orig 2014-11-27 20:47:24 UTC
+--- makefile.orig 2016-05-17 23:50:39 UTC
+++ makefile
@@ -7,14 +7,6 @@
# Also works with ming32-make on Windows.
- .SUFFIXES: .cxx .c .o .h .a
+ .SUFFIXES: .cxx .c .o .h .a .list
-ifdef CLANG
-CXX = clang++ -Wno-deprecated-register
-CC = clang
@@ -15,7 +15,7 @@
RANLIB = touch
ifdef GTK3
-@@ -36,7 +28,8 @@
+@@ -42,7 +34,8 @@ DEL = del /q
COMPLIB=..\bin\scintilla.a
else
DEL = rm -f
@@ -25,23 +25,25 @@
endif
vpath %.h ../src ../include ../lexlib
-@@ -77,8 +70,7 @@
+@@ -74,7 +67,6 @@ else
CTFLAGS=-DNDEBUG -Os $(CXXBASEFLAGS) $(THREADFLAGS)
endif
-CFLAGS:=$(CTFLAGS)
--CXXTFLAGS:=--std=gnu++0x $(CTFLAGS) $(REFLAGS)
-+CXXTFLAGS:=$(CTFLAGS) $(REFLAGS)
+ CXXTFLAGS:=--std=gnu++0x $(CTFLAGS) $(REFLAGS)
CONFIGFLAGS:=$(shell pkg-config --cflags $(GTKVERSION))
- MARSHALLER=scintilla-marshal.o
-@@ -77,11 +69,11 @@
+@@ -83,7 +75,7 @@ MARSHALLER=scintilla-marshal.o
.cxx.o:
$(CXX) $(CONFIGFLAGS) $(CXXTFLAGS) $(CXXFLAGS) -c $<
.c.o:
- $(CC) $(CONFIGFLAGS) $(CFLAGS) -w -c $<
+ $(CC) $(CONFIGFLAGS) $(CTFLAGS) $(CFLAGS) -w -c $<
+ GLIB_GENMARSHAL = glib-genmarshal
+ GLIB_GENMARSHAL_FLAGS = --prefix=scintilla_marshal
+@@ -95,7 +87,7 @@ GLIB_GENMARSHAL_FLAGS = --prefix=scintil
+
LEXOBJS:=$(addsuffix .o,$(basename $(notdir $(wildcard ../lexers/Lex*.cxx))))
-all: $(COMPLIB)
@@ -49,7 +51,7 @@
clean:
$(DEL) *.o $(COMPLIB) *.plist
-@@ -98,9 +90,11 @@
+@@ -112,9 +104,11 @@ $(COMPLIB): Accessor.o CharacterSet.o Le
PropSetSimple.o PlatGTK.o \
KeyMap.o LineMarker.o PositionCache.o ScintillaGTK.o CellBuffer.o CharacterCategory.o ViewStyle.o \
RESearch.o RunStyles.o Selection.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o \