aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2016-11-28 01:00:08 +0800
committerDavid Naylor <dbn@FreeBSD.org>2016-11-28 01:00:08 +0800
commit4a9609d5d36869f042a616c2306eede6976e9f19 (patch)
treed47ccdb7a554ac0b8b8399fa8a240b8f4abf36ad /x11-toolkits
parent930c6dac52021bd7e799b5f6eb341575f2f2f087 (diff)
downloadfreebsd-ports-4a9609d5d36869f042a616c2306eede6976e9f19.tar.gz
freebsd-ports-4a9609d5d36869f042a616c2306eede6976e9f19.tar.zst
freebsd-ports-4a9609d5d36869f042a616c2306eede6976e9f19.zip
USES=mono: simplify EXTRACT_ONLY, fix nuget-extract [1]
- Instead of excluding the specific packages added to DISTFILES (but only for FreeBSD 9+), exclude all files with a '.nupkg' extension. - Move the nuget-extract command to be before post-extract, to allow the port's post-extract command to move packages around audio/libgpod-sharp: add port for mono bindings for libgpod - audio/libgpod: [2] - USE_GNOME: add missing dependency - Remove mono files from pkg-plist (now in audio/libgpod-sharp) - Allow relevant variables to be overridden - Fix MONO options - Patch source to allow building with modern mono - Avoid post-install target for slave ports. devel/monodevelop: update to 4.6.2.7 - Update nuget package Fantomas to 2.4.0 (latest at time of monodevelop's release). - Downgrade nuget package FSharp.Compiler.CodeDom (per paket's specification) - LICENSE: Add license of LGPL21 - LICENSE_FILE: Add license file from source - PORTSCOUT: Avoid checking alpha releases (aka x.y.0.z releases) games/openra: simplify post-extract [3] - USES=mono:nuget allow overridding of NUGET_PACKAGEDIR - Set NUGET_PACKAGEDIR to correct location, fix patching accordingly lang/fsharp: update to 4.6.2.7 ChangeLog: - Fix #639: Problems with F# scripts on Mono - Fix FSharp.Compiler.Tools targets for .NET Core usage - Fix FSharp.Compiler.Tools package dependencies lang/mono: update to 4.6.2.7 Mono 4.6.2 is the 1st service release to the 4.6 series. Changes: - LICENSE: Add license of MIT - LICENSE_FILE: Add license file from source - PORTSCOUT: Avoid checking alpha releases (aka x.y.0.z releases) Bug fixes: - #44708 - "TrustFailure (The authentication or decryption has failed.) ... Invalid certificate received from server." with "Error code: 0x5" or "Error code: 0xffffffff800b010f" when attempting to access HTTPS servers on ports other than 443 - #39832 - SIGSEGV when running roslyn multimedia/banshee: bump port revision. - Update missing port dependencies - Convert to use option helpers - OPTIONS: Add APPLEDEV (missing dependency added) - LICENSE: Add MIT license - LICENSE_FILE: Add license file from source - PORTSCOUT: Skip alpha release (2.9.1) x11-toolkits/gnome-sharp20: fix port dependencies - Add missing dependencies - Convert post-patch to shebangfix - LICENSE: add LGPL21 license - LICENSE_FILE: use license file from source - MKAE_JOBS_UNSAFE: remove, does appear to work x11-toolkits/gtk-sharp20: update to 2.12.42. PR: 214680 [2] PR: 214681 Suggested by: jbeich [1] Submitted by: jbeich [3] Approved by: avilla (maintainer; timeout) [2]
Notes
Notes: svn path=/head/; revision=427247
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gnome-sharp20/Makefile20
-rw-r--r--x11-toolkits/gnome-sharp20/files/patch-gnome_CanvasPathDef.custom13
-rw-r--r--x11-toolkits/gtk-sharp20/Makefile2
-rw-r--r--x11-toolkits/gtk-sharp20/distinfo6
4 files changed, 29 insertions, 12 deletions
diff --git a/x11-toolkits/gnome-sharp20/Makefile b/x11-toolkits/gnome-sharp20/Makefile
index 237d2a2881da..e6bfc1a02257 100644
--- a/x11-toolkits/gnome-sharp20/Makefile
+++ b/x11-toolkits/gnome-sharp20/Makefile
@@ -3,23 +3,27 @@
PORTNAME= gnome-sharp
PORTVERSION= 2.24.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
MAINTAINER= mono@FreeBSD.org
COMMENT= GNOME interfaces for the .NET runtime
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libpopt.so:devel/popt \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= gmake libtool mono pathfix perl5 pkgconfig tar:bzip2
+USES= gettext-runtime gmake libtool mono pathfix perl5 pkgconfig shebangfix tar:bzip2
+USE_GNOME= cairo gnomevfs2 gtksharp20 librsvg2 vte libgnomeprintui libgnomeui
USE_PERL5= run
-USE_GNOME= gnomevfs2 gtksharp20 librsvg2 vte libgnomeprintui libgnomeui
-MAKE_JOBS_UNSAFE= yes
+USE_XORG= ice sm
INSTALL_TARGET= install-strip
-
-post-patch:
- @${FIND} ${WRKSRC} -name '*.pl' | ${XARGS} ${REINPLACE_CMD} -e \
- 's|^#!/usr/bin/perl|#!${PERL}|'
+SHEBANG_GLOB= *.pl
.include <bsd.port.mk>
diff --git a/x11-toolkits/gnome-sharp20/files/patch-gnome_CanvasPathDef.custom b/x11-toolkits/gnome-sharp20/files/patch-gnome_CanvasPathDef.custom
new file mode 100644
index 000000000000..7b6e28aa6ff0
--- /dev/null
+++ b/x11-toolkits/gnome-sharp20/files/patch-gnome_CanvasPathDef.custom
@@ -0,0 +1,13 @@
+--- gnome/CanvasPathDef.custom.orig 2016-11-22 06:40:36 UTC
++++ gnome/CanvasPathDef.custom
+@@ -21,9 +21,7 @@
+
+ public static CanvasPathDef NewFromBpath (Art.Bpath bpath)
+ {
+- IntPtr native_bpath = GLib.Marshaller.StructureToPtrAlloc (bpath);
+- CanvasPathDef result = new CanvasPathDef (gnome_canvas_path_def_new_from_bpath (native_bpath));
+- GLib.Marshaller.Free (native_bpath);
++ CanvasPathDef result = new CanvasPathDef (gnome_canvas_path_def_new_from_bpath (ref bpath));
+ return result;
+ }
+
diff --git a/x11-toolkits/gtk-sharp20/Makefile b/x11-toolkits/gtk-sharp20/Makefile
index 5339060a388e..f6a6162b55dd 100644
--- a/x11-toolkits/gtk-sharp20/Makefile
+++ b/x11-toolkits/gtk-sharp20/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gtk-sharp
-PORTVERSION= 2.12.40
+PORTVERSION= 2.12.42
CATEGORIES= x11-toolkits
MASTER_SITES= http://download.mono-project.com/sources/gtk-sharp212/
PKGNAMESUFFIX= 20
diff --git a/x11-toolkits/gtk-sharp20/distinfo b/x11-toolkits/gtk-sharp20/distinfo
index aa3809eddf87..fecc71fac541 100644
--- a/x11-toolkits/gtk-sharp20/distinfo
+++ b/x11-toolkits/gtk-sharp20/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1476770152
-SHA256 (gtk-sharp-2.12.40.tar.gz) = 1897dfa2a252473cfefe711f23ecfd99d2239f88e0d9365b61fb31ba5f0d3e57
-SIZE (gtk-sharp-2.12.40.tar.gz) = 2640898
+TIMESTAMP = 1479572648
+SHA256 (gtk-sharp-2.12.42.tar.gz) = f3b009bb73e3251378063b6f09786609cd4c061f3f8bf552f0ea663245c045c9
+SIZE (gtk-sharp-2.12.42.tar.gz) = 2645821