aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-11-22 19:06:43 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-11-22 19:06:43 +0800
commit97dcc0f3cc53511a9f3a8b7a4c67fca971f4dfea (patch)
tree9de2cf33931c8f6069464f7e936cdf8a6d8ea2bd /x11-toolkits
parent0621462f379ff86783b47ceafe8458c0d749b738 (diff)
downloadfreebsd-ports-97dcc0f3cc53511a9f3a8b7a4c67fca971f4dfea.tar.gz
freebsd-ports-97dcc0f3cc53511a9f3a8b7a4c67fca971f4dfea.tar.zst
freebsd-ports-97dcc0f3cc53511a9f3a8b7a4c67fca971f4dfea.zip
Remove `groff' from USES.
It was recently killed in the base system and consumers have to use `textproc/groff' port now, which is a real PITA: it pulls in some obscure dependencies like `print/psutils', `graphics/netpbm', but most importantly, `ghostscript' (unconditionally), which is a huge abomination of its own, pulling another round of dependencies, some of which are as crazy as `graphics/svgalib' (sic). Trying to reset all offered knobs to `off' results in unbuildable package. Pass NROFF as mere `echo' and be done with it. Generated manpages remain identical.
Notes
Notes: svn path=/head/; revision=454682
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fltk/Makefile3
-rw-r--r--x11-toolkits/fltk/files/patch-configure9
2 files changed, 11 insertions, 1 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index d35649d0780e..de614db34411 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -15,12 +15,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png
-USES= groff jpeg localbase pkgconfig
+USES= jpeg localbase pkgconfig
USE_XORG= x11 xcursor xext xfixes xft xinerama
USE_GL= glu
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
+CONFIGURE_ENV= NROFF=echo
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/x11-toolkits/fltk/files/patch-configure b/x11-toolkits/fltk/files/patch-configure
index 7b60c0c4e1a9..c3a19182aff1 100644
--- a/x11-toolkits/fltk/files/patch-configure
+++ b/x11-toolkits/fltk/files/patch-configure
@@ -1,5 +1,14 @@
--- configure.orig 2016-11-11 16:04:30 UTC
+++ configure
+@@ -4193,7 +4193,7 @@ if ${ac_cv_path_NROFF+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ case $NROFF in
+- [\\/]* | ?:[\\/]*)
++ [\\/]* | ?:[\\/]* | echo)
+ ac_cv_path_NROFF="$NROFF" # Let the user override the test with a path.
+ ;;
+ *)
@@ -7408,7 +7408,7 @@ $as_echo "$as_me: WARNING: Ignoring libraries \"$X_PRE
LIBS="$LIBS -lX11 $X_EXTRA_LIBS"
CFLAGS="$CFLAGS $X_CFLAGS"