aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pymc3/Makefile30
-rw-r--r--math/py-pymc3/distinfo3
-rw-r--r--math/py-pymc3/pkg-descr6
4 files changed, 40 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 08924f021df0..c56bfe971c6f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -665,6 +665,7 @@
SUBDIR += py-pygsl
SUBDIR += py-pyhull
SUBDIR += py-pymc
+ SUBDIR += py-pymc3
SUBDIR += py-pysparse
SUBDIR += py-pyvtk
SUBDIR += py-roman
diff --git a/math/py-pymc3/Makefile b/math/py-pymc3/Makefile
new file mode 100644
index 000000000000..b4cbcd093857
--- /dev/null
+++ b/math/py-pymc3/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= pymc3
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.3
+CATEGORIES= math python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Probabilistic programming in Python
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}h5py>=2.7.0:science/py-h5py@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}joblib>=0.9:devel/py-joblib@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.18.0:math/py-pandas@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}patsy>=0.4.0:math/py-patsy@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}theano>=1.0.0:math/py-theano@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>=4.8.4:misc/py-tqdm@${FLAVOR}
+py27_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}enum34>=1.1.6:devel/py-enum34@${FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= pymc-devs
+USE_PYTHON= distutils concurrent autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-pymc3/distinfo b/math/py-pymc3/distinfo
new file mode 100644
index 000000000000..29e2c5d7ec4a
--- /dev/null
+++ b/math/py-pymc3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521789206
+SHA256 (pymc-devs-pymc3-v3.3_GH0.tar.gz) = 1af9ecf29b5c2a916e55f75ec96c3dede575de6052efd618af44d306c5928402
+SIZE (pymc-devs-pymc3-v3.3_GH0.tar.gz) = 24015107
diff --git a/math/py-pymc3/pkg-descr b/math/py-pymc3/pkg-descr
new file mode 100644
index 000000000000..f545a6b53d03
--- /dev/null
+++ b/math/py-pymc3/pkg-descr
@@ -0,0 +1,6 @@
+PyMC3 is a Python package for Bayesian statistical modeling and Probabilistic
+Machine Learning which focuses on advanced Markov chain Monte Carlo and
+variational fitting algorithms. Its flexibility and extensibility make it
+applicable to a large suite of problems.
+
+WWW: https://docs.pymc.io/