aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/diorite/Makefile10
-rw-r--r--x11-toolkits/diorite/files/patch-src_glib_system.vala11
2 files changed, 17 insertions, 4 deletions
diff --git a/x11-toolkits/diorite/Makefile b/x11-toolkits/diorite/Makefile
index 4052058f06f1..4cc8e6866388 100644
--- a/x11-toolkits/diorite/Makefile
+++ b/x11-toolkits/diorite/Makefile
@@ -2,6 +2,7 @@
PORTNAME= diorite
PORTVERSION= 0.2.1
+PORTREVSION= 1
CATEGORIES= x11-toolkits devel
MAINTAINER= avilla@FreeBSD.org
@@ -11,13 +12,14 @@ LICENSE= BSD2CLAUSE
BUILD_DEPENDS= valac:lang/vala
-USE_GITHUB= yes
GH_ACCOUNT= tiliado
-USES= gnome pkgconfig shebangfix waf
-USE_GNOME= glib20 gtk30
+# USES=waf implicity does USES=python:2,build but that is not sufficient
+# for shebangfix to know the python version
+USES= gnome pkgconfig python:2.7,build shebangfix waf
+USE_GITHUB= yes
+USE_GNOME= gdkpixbuf2 glib20 gtk30
USE_XORG= x11
-SHEBANG_LANG= python3
SHEBANG_FILES= testgen.py
# --noopt is required to prevent a crash in ipcserver.c, as
# the argument of diorite_ipc_server_process_connection_co() gets
diff --git a/x11-toolkits/diorite/files/patch-src_glib_system.vala b/x11-toolkits/diorite/files/patch-src_glib_system.vala
new file mode 100644
index 000000000000..e27a2d141e16
--- /dev/null
+++ b/x11-toolkits/diorite/files/patch-src_glib_system.vala
@@ -0,0 +1,11 @@
+--- src/glib/system.vala.orig 2016-01-23 21:11:53 UTC
++++ src/glib/system.vala
+@@ -61,7 +61,7 @@ namespace Diorite.System
+ }
+
+ public async void make_directory_with_parents_async(
+- File directory, int io_priority=Priority.DEFAULT, Cancellable? cancellable = null) throws GLib.Error
++ File directory, int io_priority=GLib.Priority.DEFAULT, Cancellable? cancellable = null) throws GLib.Error
+ {
+
+ SingleList<File> dirs = new SingleList<File>();