aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/monkeybubble/Makefile15
-rw-r--r--games/monkeybubble/files/patch-src_ui_main.c15
2 files changed, 21 insertions, 9 deletions
diff --git a/games/monkeybubble/Makefile b/games/monkeybubble/Makefile
index 25356acdfde1..cf75fb56839f 100644
--- a/games/monkeybubble/Makefile
+++ b/games/monkeybubble/Makefile
@@ -3,7 +3,7 @@
PORTNAME= monkeybubble
PORTVERSION= 0.4.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games gnome
MASTER_SITES= http://home.gna.org/monkeybubble/downloads/
DISTNAME= monkey-bubble-${PORTVERSION}
@@ -14,13 +14,11 @@ COMMENT= GTK2 Puzzle Bobble clone with monkeys
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake libtool pathfix pkgconfig
-USE_GNOME= gnomedocutils gnomeprefix intlhack \
- librsvg2 libgnomeui esound
-USE_GSTREAMER= yes
+USES= gmake libtool localbase pathfix pkgconfig
+USE_GNOME= gnomedocutils gnomeprefix intlhack librsvg2 libgnomeui
+USE_GSTREAMER= good vorbis
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lm
+LIBS+= -lm
INSTALLS_OMF= yes
GCONF_SCHEMAS= monkey-bubble.schemas
@@ -31,7 +29,6 @@ post-patch:
s|-Werror||g'
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
${WRKSRC}/src/net/message-handler.c \
- ${WRKSRC}/src/net/simple-server.c \
- ${WRKSRC}/src/ui/main.c
+ ${WRKSRC}/src/net/simple-server.c
.include <bsd.port.mk>
diff --git a/games/monkeybubble/files/patch-src_ui_main.c b/games/monkeybubble/files/patch-src_ui_main.c
new file mode 100644
index 000000000000..0581d036cf11
--- /dev/null
+++ b/games/monkeybubble/files/patch-src_ui_main.c
@@ -0,0 +1,15 @@
+--- src/ui/main.c.orig 2004-12-03 07:05:59 UTC
++++ src/ui/main.c
+@@ -11,11 +11,10 @@
+ #include "ui-main.h"
+ #include "input-manager.h"
+
+-#include <esd.h>
+ #include <gtk/gtk.h>
+ #include <gst/gst.h>
+ #include <bonobo/bonobo-i18n.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <libgnomeui/gnome-ui-init.h>
+
+ #include <math.h>