aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/glfw/Makefile15
-rw-r--r--graphics/glfw/files/patch-src_wl__init.c11
2 files changed, 23 insertions, 3 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index 834d760a59c0..f94d0f53e2af 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -7,13 +7,12 @@ PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF
-MAINTAINER= koalative@gmail.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Portable framework for OpenGL development
LICENSE= ZLIB
USES= cmake localbase zip
-USE_XORG= x11 xcursor xinerama xrandr xxf86vm
USE_GL= glu
USE_LDCONFIG= yes
CMAKE_ARGS= -DBUILD_SHARED_LIBS:BOOL=ON
@@ -42,7 +41,17 @@ EXAMPLES_FILES2= clipboard cursor empty events gamma glfwinfo iconify \
joysticks monitors msaa reopen sharing tearing threads \
title windows
-OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFINE= DOCS EXAMPLES WAYLAND
+OPTIONS_EXCLUDE_FreeBSD_10= WAYLAND # needs dev/evdev/input.h
+
+WAYLAND_BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
+WAYLAND_CMAKE_BOOL= GLFW_USE_WAYLAND
+WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libwayland-egl.so:graphics/mesa-libs \
+ libxkbcommon.so:x11/libxkbcommon
+WAYLAND_USES= kde:5 pkgconfig
+WAYLAND_USE= KDE=ecm
+WAYLAND_USE_OFF= XORG=x11,xcursor,xinerama,xrandr,xxf86vm
post-patch:
@${REINPLACE_CMD} -e 's|lib$${LIB_SUFFIX}/pkgconfig|libdata/pkgconfig|' \
diff --git a/graphics/glfw/files/patch-src_wl__init.c b/graphics/glfw/files/patch-src_wl__init.c
new file mode 100644
index 000000000000..2bf6d3b7416a
--- /dev/null
+++ b/graphics/glfw/files/patch-src_wl__init.c
@@ -0,0 +1,11 @@
+--- src/wl_init.c.orig 2018-03-28 18:36:50 UTC
++++ src/wl_init.c
+@@ -26,7 +26,7 @@
+
+ #include "internal.h"
+
+-#include <linux/input.h>
++#include <dev/evdev/input.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>