aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MOVED2
-rw-r--r--cad/py-pycam/Makefile3
-rw-r--r--games/bouncy/Makefile4
-rw-r--r--games/fretsonfire/Makefile4
-rw-r--r--games/nelly/Makefile4
-rw-r--r--graphics/Makefile4
-rw-r--r--graphics/gsculpt/Makefile4
-rw-r--r--graphics/impressive/Makefile4
-rw-r--r--graphics/py-PyOpenGL-accelerate/Makefile (renamed from graphics/py-opengl-accelerate/Makefile)6
-rw-r--r--graphics/py-PyOpenGL-accelerate/distinfo2
-rw-r--r--graphics/py-PyOpenGL-accelerate/pkg-descr (renamed from graphics/py-opengl-accelerate/pkg-descr)0
-rw-r--r--graphics/py-PyOpenGL/Makefile (renamed from graphics/py-opengl/Makefile)9
-rw-r--r--graphics/py-PyOpenGL/distinfo2
-rw-r--r--graphics/py-PyOpenGL/pkg-descr (renamed from graphics/py-opengl/pkg-descr)0
-rw-r--r--graphics/py-opengl-accelerate/distinfo2
-rw-r--r--graphics/py-opengl/distinfo2
-rw-r--r--graphics/py-pyggel/Makefile4
-rw-r--r--x11-toolkits/py-gtkglext/Makefile6
-rw-r--r--x11-toolkits/py-wxPython28/Makefile4
-rw-r--r--x11/xpra/Makefile6
20 files changed, 37 insertions, 35 deletions
diff --git a/MOVED b/MOVED
index 97bd27d4325a..6dcc832cd423 100644
--- a/MOVED
+++ b/MOVED
@@ -8310,3 +8310,5 @@ www/sogo-activesync|www/sogo2-activesync|2016-05-02|Renamed to www/sogo2-actives
textproc/rubygem-gherkin3|textproc/rubygem-gherkin|2016-05-03|Has expired: Use textproc/rubygem-gherkin instead
dns/odsclient||2016-05-03|Has expired: ODS shuts service down, so client is probably useless
games/Cockatrice|games/cockatrice|2016-05-05|Renamed to games/cockatrice
+graphics/py-opengl|graphics/py-PyOpenGL|2016-05-09|Use correct upstream PyPI name
+graphics/py-opengl-accelerate|graphics/py-PyOpenGL-accelerate|2016-05-09|Use correct upstream PyPI name
diff --git a/cad/py-pycam/Makefile b/cad/py-pycam/Makefile
index c19a6cc5b8e8..ab91f41475d5 100644
--- a/cad/py-pycam/Makefile
+++ b/cad/py-pycam/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pycam
PORTVERSION= 0.5.1
+PORTREVISION= 1
CATEGORIES= cad python
MASTER_SITES= SOURCEFORGE/pycam/${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +14,7 @@ COMMENT= Toolpath generator for 3-axis CNC machining
LICENSE= GPLv3
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:x11-toolkits/py-gtk2 \
- ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:graphics/py-opengl \
+ ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:graphics/py-PyOpenGL \
${PYTHON_SITELIBDIR}/gtk-2.0/gtk/gdkgl/__init__.py:x11-toolkits/py-gtkglext
USES= python:-2.7
diff --git a/games/bouncy/Makefile b/games/bouncy/Makefile
index d98440b57904..3185c8995479 100644
--- a/games/bouncy/Makefile
+++ b/games/bouncy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bouncy
PORTVERSION= r6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games python
MASTER_SITES= http://media.pyweek.org/dl/3/bouncy/ \
SF/nemysisfreebsdp/games/${PORTNAME}/:icons
@@ -19,7 +19,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GPL.txt
RUN_DEPENDS= ${PYGAME} \
- ${PYTHON_PKGNAMEPREFIX}opengl>=0:graphics/py-opengl
+ ${PYTHON_PKGNAMEPREFIX}opengl>=0:graphics/py-PyOpenGL
WRKSRC= ${WRKDIR}/${PORTNAME}-post-${DISTVERSION}
diff --git a/games/fretsonfire/Makefile b/games/fretsonfire/Makefile
index 3ffd7e0010d2..c4c7891c0dd9 100644
--- a/games/fretsonfire/Makefile
+++ b/games/fretsonfire/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fretsonfire
PORTVERSION= 1.3.110
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games python
MASTER_SITES= SF
DISTNAME= ${PORTNAME:S/f/F/g:S/o/O/}-${PORTVERSION}
@@ -14,7 +14,7 @@ COMMENT= Game of musical skill and fast fingers
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}game>=0:devel/py-game \
- ${PYTHON_PKGNAMEPREFIX}opengl>=0:graphics/py-opengl \
+ ${PYTHON_PKGNAMEPREFIX}opengl>=0:graphics/py-PyOpenGL \
${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow \
${LOCALBASE}/share/${PORTNAME}/default.ttf:games/fretsonfire-data
diff --git a/games/nelly/Makefile b/games/nelly/Makefile
index 4c859a2b3818..991204eddbc8 100644
--- a/games/nelly/Makefile
+++ b/games/nelly/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nelly
PORTVERSION= 1.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games python
MASTER_SITES= http://www.partiallydisassembled.net/nelly/ \
http://media.pyweek.org/dl/2/rushed/ \
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Nelly's Rooftop Garden, physics-based puzzle game
RUN_DEPENDS= ${PYGAME} \
- ${PYTHON_PKGNAMEPREFIX}opengl>=0:graphics/py-opengl
+ ${PYTHON_PKGNAMEPREFIX}opengl>=0:graphics/py-PyOpenGL
USES= python:2
diff --git a/graphics/Makefile b/graphics/Makefile
index ac147be75186..2ef02affec84 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -815,6 +815,8 @@
SUBDIR += projectm-libvisual
SUBDIR += pstoedit
SUBDIR += pstoepsi
+ SUBDIR += py-PyOpenGL
+ SUBDIR += py-PyOpenGL-accelerate
SUBDIR += py-PyX
SUBDIR += py-PyX12
SUBDIR += py-aafigure
@@ -848,8 +850,6 @@
SUBDIR += py-opencolorio
SUBDIR += py-opencv
SUBDIR += py-openexr
- SUBDIR += py-opengl
- SUBDIR += py-opengl-accelerate
SUBDIR += py-openimageio
SUBDIR += py-paint
SUBDIR += py-pillow
diff --git a/graphics/gsculpt/Makefile b/graphics/gsculpt/Makefile
index 8c97f9937b26..51927e3f85e7 100644
--- a/graphics/gsculpt/Makefile
+++ b/graphics/gsculpt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gsculpt
PORTVERSION= 0.99.47
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME:S,-src,,}
DISTNAME= gSculpt-${PORTVERSION}-alpha-src
@@ -14,7 +14,7 @@ COMMENT= Opensource 3D modelling application
LICENSE= GPLv2
LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>0:graphics/py-opengl \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>0:graphics/py-PyOpenGL \
${PYTHON_PKGNAMEPREFIX}gtkglext>0:x11-toolkits/py-gtkglext
WRKSRC= ${WRKDIR}/${DISTNAME:S,-src,,}
diff --git a/graphics/impressive/Makefile b/graphics/impressive/Makefile
index 985babf17645..ab1e647ec9df 100644
--- a/graphics/impressive/Makefile
+++ b/graphics/impressive/Makefile
@@ -3,7 +3,7 @@
PORTNAME= impressive
PORTVERSION= 0.10.3
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Impressive/${PORTVERSION}/
DISTNAME= Impressive-${PORTVERSION}
@@ -14,7 +14,7 @@ COMMENT= The stylish way of giving presentations
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/license.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>=0:graphics/py-opengl \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>=0:graphics/py-PyOpenGL \
${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
xpdf:graphics/xpdf \
pdftk:print/pdftk \
diff --git a/graphics/py-opengl-accelerate/Makefile b/graphics/py-PyOpenGL-accelerate/Makefile
index 6e07a817b630..4765814ed620 100644
--- a/graphics/py-opengl-accelerate/Makefile
+++ b/graphics/py-PyOpenGL-accelerate/Makefile
@@ -1,12 +1,12 @@
# $FreeBSD$
-PORTNAME= opengl
-PORTVERSION= 3.0.1
+PORTNAME= PyOpenGL
+PORTVERSION= 3.1.0
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
PKGNAMESUFFIX= -accelerate
-DISTNAME= PyOpenGL${PKGNAMESUFFIX}-${PORTVERSION}
+#DISTNAME= PyOpenGL${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= python@FreeBSD.org
COMMENT= OpenGL acceleration code for PyOpenGL
diff --git a/graphics/py-PyOpenGL-accelerate/distinfo b/graphics/py-PyOpenGL-accelerate/distinfo
new file mode 100644
index 000000000000..6103f1e8e17f
--- /dev/null
+++ b/graphics/py-PyOpenGL-accelerate/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PyOpenGL-3.1.0.tar.gz) = 9b47c5c3a094fa518ca88aeed35ae75834d53e4285512c61879f67a48c94ddaf
+SIZE (PyOpenGL-3.1.0.tar.gz) = 1172688
diff --git a/graphics/py-opengl-accelerate/pkg-descr b/graphics/py-PyOpenGL-accelerate/pkg-descr
index 7ace6c7af0e6..7ace6c7af0e6 100644
--- a/graphics/py-opengl-accelerate/pkg-descr
+++ b/graphics/py-PyOpenGL-accelerate/pkg-descr
diff --git a/graphics/py-opengl/Makefile b/graphics/py-PyOpenGL/Makefile
index 33eb4b3a2c83..41bd8503cf76 100644
--- a/graphics/py-opengl/Makefile
+++ b/graphics/py-PyOpenGL/Makefile
@@ -1,13 +1,12 @@
# Created by: Randall Hopper <aa8vb@ipass.net>
# $FreeBSD$
-PORTNAME= opengl
-PORTVERSION= 3.0.1
-PORTREVISION= 7
+PORTNAME= PyOpenGL
+PORTVERSION= 3.1.0
CATEGORIES= graphics python
-MASTER_SITES= SF/py${PORTNAME}/PyOpenGL/${PORTVERSION}
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= PyOpenGL-${PORTVERSION}
+#DISTNAME= PyOpenGL-${PORTVERSION}
MAINTAINER= python@FreeBSD.org
COMMENT= OpenGL (and related library) interface for Python
diff --git a/graphics/py-PyOpenGL/distinfo b/graphics/py-PyOpenGL/distinfo
new file mode 100644
index 000000000000..6103f1e8e17f
--- /dev/null
+++ b/graphics/py-PyOpenGL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PyOpenGL-3.1.0.tar.gz) = 9b47c5c3a094fa518ca88aeed35ae75834d53e4285512c61879f67a48c94ddaf
+SIZE (PyOpenGL-3.1.0.tar.gz) = 1172688
diff --git a/graphics/py-opengl/pkg-descr b/graphics/py-PyOpenGL/pkg-descr
index 368694cfce50..368694cfce50 100644
--- a/graphics/py-opengl/pkg-descr
+++ b/graphics/py-PyOpenGL/pkg-descr
diff --git a/graphics/py-opengl-accelerate/distinfo b/graphics/py-opengl-accelerate/distinfo
deleted file mode 100644
index 4314abb50959..000000000000
--- a/graphics/py-opengl-accelerate/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (PyOpenGL-accelerate-3.0.1.tar.gz) = 51bc771fd2fc9fc0acec5caf4dc3bd0739127eec4addc04baca545f8c3fe17cd
-SIZE (PyOpenGL-accelerate-3.0.1.tar.gz) = 194056
diff --git a/graphics/py-opengl/distinfo b/graphics/py-opengl/distinfo
deleted file mode 100644
index e7652b4dad51..000000000000
--- a/graphics/py-opengl/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (PyOpenGL-3.0.1.tar.gz) = 1ec8e314422bde6951cc45516bd7fed960f75009c30701f33a2a5b522e3482dd
-SIZE (PyOpenGL-3.0.1.tar.gz) = 698420
diff --git a/graphics/py-pyggel/Makefile b/graphics/py-pyggel/Makefile
index bd1f7f26a36a..6ac04da8efcb 100644
--- a/graphics/py-pyggel/Makefile
+++ b/graphics/py-pyggel/Makefile
@@ -4,7 +4,7 @@
PORTNAME= pyggel
PORTVERSION= 0.08
DISTVERSIONSUFFIX= -alpha4c
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics python
MASTER_SITES= GOOGLE_CODE
DISTNAME= ${PORTNAME:tu}-V${DISTVERSION}${DISTVERSIONSUFFIX}
@@ -19,7 +19,7 @@ LICENSE_COMB= dual
RUN_DEPENDS= ${PYNUMPY} \
${PYGAME} \
- ${PYTHON_PKGNAMEPREFIX}opengl>=0:graphics/py-opengl \
+ ${PYTHON_PKGNAMEPREFIX}opengl>=0:graphics/py-PyOpenGL \
${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow
USES= dos2unix python:2 zip
diff --git a/x11-toolkits/py-gtkglext/Makefile b/x11-toolkits/py-gtkglext/Makefile
index f53797476f63..63caf4621160 100644
--- a/x11-toolkits/py-gtkglext/Makefile
+++ b/x11-toolkits/py-gtkglext/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gtkglext
PORTVERSION= 1.1.0
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= x11-toolkits python
MASTER_SITES= SF/${PORTNAME}/py${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,9 +12,9 @@ DISTNAME= pygtkglext-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Python binding for GtkGLExt
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:graphics/py-opengl
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:graphics/py-PyOpenGL
LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:graphics/py-opengl
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:graphics/py-PyOpenGL
USES= gmake libtool pathfix pkgconfig python tar:bzip2
USE_GNOME= pygtk2
diff --git a/x11-toolkits/py-wxPython28/Makefile b/x11-toolkits/py-wxPython28/Makefile
index 3e8d086b26cc..b0bd0bfa94d0 100644
--- a/x11-toolkits/py-wxPython28/Makefile
+++ b/x11-toolkits/py-wxPython28/Makefile
@@ -4,7 +4,7 @@
PORTNAME= wxPython
PORTVERSION= 2.8.12.1
DISTVERSIONPREFIX= src-
-PORTREVISION?= 7
+PORTREVISION?= 8
CATEGORIES= x11-toolkits python
MASTER_SITES= SF/wxpython/wxPython/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,7 @@ PKGNAMESUFFIX= 28
MAINTAINER= python@FreeBSD.org
COMMENT= Python bindings for the wxWidgets/GTK GUI toolkit
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>=0:graphics/py-opengl
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL
WRKSRC_SUBDIR= wxPython
diff --git a/x11/xpra/Makefile b/x11/xpra/Makefile
index 680be1e06804..f3793ecf105d 100644
--- a/x11/xpra/Makefile
+++ b/x11/xpra/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xpra
PORTVERSION= 0.15.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= http://xpra.org/src/
@@ -17,8 +17,8 @@ BUILD_DEPENDS= cython:lang/cython \
RUN_DEPENDS= py${PYTHON_SUFFIX}-lz4>=0.7.0_1:archivers/py-lz4 \
${PYTHON_SITELIBDIR}/rencode/__init__.py:converters/py-rencode \
${PYTHON_SITELIBDIR}/dbus/__init__.py:devel/py-dbus \
- ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:graphics/py-opengl \
- ${PYTHON_SITELIBDIR}/OpenGL_accelerate/__init__.py:graphics/py-opengl-accelerate \
+ ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:graphics/py-PyOpenGL \
+ ${PYTHON_SITELIBDIR}/OpenGL_accelerate/__init__.py:graphics/py-PyOpenGL-accelerate \
${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
${PYTHON_SITELIBDIR}/netifaces.so:net/py-netifaces \
ssh-askpass:security/openssh-askpass \