aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/setaudit/Makefile29
-rw-r--r--security/setaudit/distinfo3
-rw-r--r--security/setaudit/pkg-descr12
4 files changed, 45 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 2dc0accf370a..2ba62d210960 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1183,6 +1183,7 @@
SUBDIR += secpanel
SUBDIR += sectok
SUBDIR += secure_delete
+ SUBDIR += setaudit
SUBDIR += sguil
SUBDIR += sha
SUBDIR += sha1collisiondetection
diff --git a/security/setaudit/Makefile b/security/setaudit/Makefile
new file mode 100644
index 000000000000..745730af35b6
--- /dev/null
+++ b/security/setaudit/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= setaudit
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.3
+CATEGORIES= security
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Tool to specify audit configurations on a process
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= csjayp
+
+PLIST_FILES= bin/setaudit \
+ man/man8/setaudit.8.gz
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/setaudit
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/setaudit/distinfo b/security/setaudit/distinfo
new file mode 100644
index 000000000000..ee915c5f065c
--- /dev/null
+++ b/security/setaudit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521772004
+SHA256 (csjayp-setaudit-v1.0.3_GH0.tar.gz) = e94787dca51b8b3986a391e3ea402f84946f151bf419611aac5bf6568ae32c0a
+SIZE (csjayp-setaudit-v1.0.3_GH0.tar.gz) = 2901
diff --git a/security/setaudit/pkg-descr b/security/setaudit/pkg-descr
new file mode 100644
index 000000000000..c5c44fadceb2
--- /dev/null
+++ b/security/setaudit/pkg-descr
@@ -0,0 +1,12 @@
+With setaudit it is possible to specify audit configurations on a process
+directly at the runtime.
+
+All audit events are redirected to the auditd(8), an audit log management
+daemon.
+
+Example of enabling all exe related audit events performed by a command and its
+child processes:
+
+ # setaudit -m ex command
+
+WWW: https://github.com/csjayp/setaudit