aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/tarantool-c/Makefile3
-rw-r--r--devel/rapidjson/Makefile5
2 files changed, 5 insertions, 3 deletions
diff --git a/databases/tarantool-c/Makefile b/databases/tarantool-c/Makefile
index bba601ae713e..c68fbaf76ec5 100644
--- a/databases/tarantool-c/Makefile
+++ b/databases/tarantool-c/Makefile
@@ -23,4 +23,7 @@ BROKEN_mips64= Fails to compile: clang compiler does not support -march=native
BROKEN_powerpc64= Fails to compile: clang compiler does not support -march=native
BROKEN_sparc64= Fails to compile: clang compiler does not support -march=native
+post-patch:
+ @${REINPLACE_CMD} -e '/-O3 -march=native/d' ${WRKSRC}/CMakeLists.txt
+
.include <bsd.port.mk>
diff --git a/devel/rapidjson/Makefile b/devel/rapidjson/Makefile
index f85c81f6a8b8..21e443f93cda 100644
--- a/devel/rapidjson/Makefile
+++ b/devel/rapidjson/Makefile
@@ -20,8 +20,6 @@ BROKEN_armv6= does not build: c++: error: the clang compiler does not support -
BROKEN_sparc64= does not build: c++: error: the clang compiler does not support -march=native
BROKEN_powerpc64= does not build: c++: error: the clang compiler does not support -march=native
-DOXYGEN_BUILD_DEPENDS+= doxygen:devel/doxygen
-
USE_GITHUB= yes
GH_ACCOUNT= miloyip
@@ -31,6 +29,7 @@ OPTIONS_DEFINE= DOXYGEN EXAMPLES
OPTIONS_DEFAULT=${OPTIONS_DEFINE}
OPTIONS_SUB= yes
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_CMAKE_ON= -DRAPIDJSON_BUILD_DOC:BOOL=ON
DOXYGEN_CMAKE_OFF= -DRAPIDJSON_BUILD_DOC:BOOL=OFF
EXAMPLES_CMAKE_ON= -DRAPIDJSON_BUILD_EXAMPLES:BOOL=ON
@@ -44,7 +43,7 @@ DATADIR= ${PREFIX}/share/doc/RapidJSON
PORTDATA= *
post-patch:
- @${REINPLACE_CMD} -e 's|DOC_INSTALL_DIR}/examples"|CMAKE_INSTALL_PREFIX}/share/examples/${PORTNAME}"|' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|DOC_INSTALL_DIR}/examples"|CMAKE_INSTALL_PREFIX}/share/examples/${PORTNAME}"| ; s| -march=native||' ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e 's|-Werror||' ${WRKSRC}/example/CMakeLists.txt ${WRKSRC}/test/unittest/CMakeLists.txt
@${REINPLACE_CMD} -e 's|.*travis.*||' ${WRKSRC}/CMakeLists.txt # travis_doc breaks cmake, see https://github.com/miloyip/rapidjson/issues/715
@${REINPLACE_CMD} -e 's|add_subdirectory.*googletest.*|link_directories(${LOCALBASE}/lib)|' ${WRKSRC}/test/CMakeLists.txt