aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/motor/Makefile29
-rw-r--r--devel/motor/distinfo2
-rw-r--r--devel/motor/files/patch-src::Makefile.in23
-rw-r--r--devel/motor/files/patch-src::configuration::Makefile.in4
-rw-r--r--devel/motor/files/patch-src::debugger::Makefile.in14
-rw-r--r--devel/motor/files/patch-src::manager::Makefile.in4
-rw-r--r--devel/motor/pkg-plist3
7 files changed, 50 insertions, 29 deletions
diff --git a/devel/motor/Makefile b/devel/motor/Makefile
index c7a578824e72..38c03a7b813a 100644
--- a/devel/motor/Makefile
+++ b/devel/motor/Makefile
@@ -6,23 +6,32 @@
#
PORTNAME= motor
-PORTVERSION= 3.2.0
-PORTREVISION= 1
+PORTVERSION= 3.2.2
CATEGORIES= devel
-MASTER_SITES= http://konst.org.ua/download/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= sobomax
+MASTER_SITES= http://konst.org.ua/download/
-MAINTAINER= sobomax@FreeBSD.org
+MAINTAINER= sysadmin@alexdupre.com
-LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl -lgnugetopt"
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
MAN1= motor.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400010
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+.endif
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC} ; ${INSTALL_DATA} FAQ README ${DOCSDIR})
+.endif
+
+.include <bsd.port.post.mk>
+
diff --git a/devel/motor/distinfo b/devel/motor/distinfo
index e076aded871f..9e4a1335a90d 100644
--- a/devel/motor/distinfo
+++ b/devel/motor/distinfo
@@ -1 +1 @@
-MD5 (motor-3.2.0.tar.gz) = 893d55c9fe7748aa6e2614b8c801ff1f
+MD5 (motor-3.2.2.tar.gz) = 2f3a95b4fe0955cb88568d48df1d2342
diff --git a/devel/motor/files/patch-src::Makefile.in b/devel/motor/files/patch-src::Makefile.in
index e7bfd1b8a659..a1ae4583ddbe 100644
--- a/devel/motor/files/patch-src::Makefile.in
+++ b/devel/motor/files/patch-src::Makefile.in
@@ -1,19 +1,14 @@
---- src/Makefile.in.orig Thu Jun 7 10:50:20 2001
-+++ src/Makefile.in Fri Aug 3 11:55:15 2001
-@@ -61,6 +61,7 @@
- CATOBJEXT = @CATOBJEXT@
- CC = @CC@
- CXX = @CXX@
-+CPPFLAGS = @CPPFLAGS@
- DATADIRNAME = @DATADIRNAME@
- GENCAT = @GENCAT@
- GMOFILES = @GMOFILES@
-@@ -87,7 +88,7 @@
- INCLUDES = -I../include -I../kkstrtext -I../kkconsui/include -I../kksystr/include -I../parser/include -I$(top_srcdir)/intl
+
+$FreeBSD$
+
+--- src/Makefile.in 2002/05/16 11:05:11 1.1
++++ src/Makefile.in 2002/05/16 11:05:22
+@@ -90,7 +90,7 @@
+ INCLUDES = -I$(top_srcdir)/kkstrtext -I$(top_srcdir)/kksystr/include -I$(top_srcdir)/kkconsui/include -I$(top_srcdir)/intl -I$(top_srcdir)/src/ui -I$(top_srcdir)/src/ui/ncurses -I$(top_srcdir)/src/debugger -I$(top_srcdir)/src/executor -I$(top_srcdir)/src/project -I$(top_srcdir)/src/configuration -I$(top_srcdir)/src/manager -I$(top_srcdir)/src/grepper -I$(top_srcdir)/src/tagbrowser -I$(top_srcdir)/src/vcs -I$(top_srcdir)/parser/include
-CPPFLAGS = -DSHARE_DIR=\"$(pkgdatadir)\" -DLOCALE_DIR=\"$(datadir)/locale\"
-+CPPFLAGS += -DSHARE_DIR=\"$(pkgdatadir)\" -DLOCALE_DIR=\"$(datadir)/locale\"
++CPPFLAGS = @CPPFLAGS@ -DSHARE_DIR=\"$(pkgdatadir)\" -DLOCALE_DIR=\"$(datadir)/locale\"
bin_PROGRAMS = motor
-
+ motor_SOURCES = main.cc motormisc.cc
diff --git a/devel/motor/files/patch-src::configuration::Makefile.in b/devel/motor/files/patch-src::configuration::Makefile.in
index a52e83995661..dff1622135fa 100644
--- a/devel/motor/files/patch-src::configuration::Makefile.in
+++ b/devel/motor/files/patch-src::configuration::Makefile.in
@@ -1,8 +1,8 @@
$FreeBSD$
---- src/configuration/Makefile.in 2001/10/08 13:16:39 1.1
-+++ src/configuration/Makefile.in 2001/10/08 13:17:10
+--- src/configuration/Makefile.in 2002/05/16 11:01:44 1.1
++++ src/configuration/Makefile.in 2002/05/16 11:02:59
@@ -89,7 +89,7 @@
INCLUDES = -I$(top_srcdir)/kkstrtext -I$(top_srcdir)/kkconsui/include -I$(top_srcdir)/kksystr/include -I$(top_srcdir)/intl -I$(top_srcdir)/src/ui/ncurses -I$(top_srcdir)/src/debugger -I$(top_srcdir)/src/executor -I$(top_srcdir)/src/project -I$(top_srcdir)/src/ui -I$(top_srcdir)/src/tagbrowser -I$(top_srcdir)/src -I$(top_srcdir)/parser/include
diff --git a/devel/motor/files/patch-src::debugger::Makefile.in b/devel/motor/files/patch-src::debugger::Makefile.in
new file mode 100644
index 000000000000..b72ce00e1c43
--- /dev/null
+++ b/devel/motor/files/patch-src::debugger::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/debugger/Makefile.in 2002/05/16 10:52:11 1.1
++++ src/debugger/Makefile.in 2002/05/16 10:52:28
+@@ -108,7 +108,7 @@
+ libdebugger_a_OBJECTS = breakpoint.o debuggercommand.o \
+ debuggermessage.o watch.o motordebugger.o stackitem.o
+ AR = ar
+-CXXFLAGS = @CXXFLAGS@
++CXXFLAGS = @CXXFLAGS@ -fpermissive
+ CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
+ CXXLD = $(CXX)
+ CXXLINK = $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@
diff --git a/devel/motor/files/patch-src::manager::Makefile.in b/devel/motor/files/patch-src::manager::Makefile.in
index 06593f842912..9873474ec12b 100644
--- a/devel/motor/files/patch-src::manager::Makefile.in
+++ b/devel/motor/files/patch-src::manager::Makefile.in
@@ -1,8 +1,8 @@
$FreeBSD$
---- src/manager/Makefile.in 2001/10/08 13:19:11 1.1
-+++ src/manager/Makefile.in 2001/10/08 13:19:28
+--- src/manager/Makefile.in 2002/05/16 11:03:39 1.1
++++ src/manager/Makefile.in 2002/05/16 11:03:53
@@ -89,7 +89,7 @@
INCLUDES = -I$(top_srcdir)/kkstrtext -I$(top_srcdir)/kkconsui/include -I$(top_srcdir)/kksystr/include -I$(top_srcdir)/intl -I$(top_srcdir)/src/ui/ncurses -I$(top_srcdir)/src/debugger -I$(top_srcdir)/src/executor -I$(top_srcdir)/src/project -I$(top_srcdir)/src/configuration -I$(top_srcdir)/src -I$(top_srcdir)/src/tagbrowser -I$(top_srcdir)/parser/include
diff --git a/devel/motor/pkg-plist b/devel/motor/pkg-plist
index 5f78faa44791..099d43d6c715 100644
--- a/devel/motor/pkg-plist
+++ b/devel/motor/pkg-plist
@@ -56,3 +56,6 @@ share/motor/themes
@dirrm share/motor/templates/library
@dirrm share/motor/templates
@dirrm share/motor
+%%PORTDOCS%%share/doc/motor/FAQ
+%%PORTDOCS%%share/doc/motor/README
+%%PORTDOCS%%@dirrm share/doc/motor