aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/p5-File-Fetch/Makefile31
-rw-r--r--ftp/p5-File-Fetch/distinfo3
-rw-r--r--ftp/p5-File-Fetch/pkg-descr7
-rw-r--r--ftp/p5-File-Fetch/pkg-plist7
5 files changed, 49 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index e9d3ca464eb9..d62e383c9f7b 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -61,6 +61,7 @@
SUBDIR += ocaml-ocurl
SUBDIR += oftpd
SUBDIR += omi
+ SUBDIR += p5-File-Fetch
SUBDIR += p5-Net-FTP-Common
SUBDIR += p5-Net-FTP-Recursive
SUBDIR += p5-Net-FTPServer
diff --git a/ftp/p5-File-Fetch/Makefile b/ftp/p5-File-Fetch/Makefile
new file mode 100644
index 000000000000..8deb64979971
--- /dev/null
+++ b/ftp/p5-File-Fetch/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-File-Fetch
+# Date created: 31 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Fetch
+PORTVERSION= 0.07
+CATEGORIES= ftp www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A generic file fetching mechanism
+
+BUILD_DEPENDS= ${SITE_PERL}/IPC/Cmd.pm:${PORTSDIR}/devel/p5-IPC-Cmd
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= File::Fetch.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/ftp/p5-File-Fetch/distinfo b/ftp/p5-File-Fetch/distinfo
new file mode 100644
index 000000000000..fb49999d8d90
--- /dev/null
+++ b/ftp/p5-File-Fetch/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Fetch-0.07.tar.gz) = 53135c09fa15e9cb0a980b153b9634e0
+SHA256 (File-Fetch-0.07.tar.gz) = 1ce376dd082bccd62af6d4899a436d53c66fc1ecb450ed80d0a54ec42792fe5e
+SIZE (File-Fetch-0.07.tar.gz) = 9463
diff --git a/ftp/p5-File-Fetch/pkg-descr b/ftp/p5-File-Fetch/pkg-descr
new file mode 100644
index 000000000000..9c0c8cc9d297
--- /dev/null
+++ b/ftp/p5-File-Fetch/pkg-descr
@@ -0,0 +1,7 @@
+File::Fetch is a generic file fetching mechanism.
+
+It allows you to fetch any file pointed to by a ftp, http, file, or rsync
+uri by a number of different means.
+
+WWW: http://search.cpan.org/dist/File-Fetch
+Author: Jos Boumans <kane@cpan.org>
diff --git a/ftp/p5-File-Fetch/pkg-plist b/ftp/p5-File-Fetch/pkg-plist
new file mode 100644
index 000000000000..745b885279ff
--- /dev/null
+++ b/ftp/p5-File-Fetch/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/File/Fetch.pm
+%%SITE_PERL%%/File/Fetch/Item.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Fetch/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Fetch
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrm %%SITE_PERL%%/File/Fetch
+@dirrmtry %%SITE_PERL%%/File