aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysql54-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mysql54-server/Makefile')
-rw-r--r--databases/mysql54-server/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/databases/mysql54-server/Makefile b/databases/mysql54-server/Makefile
index 3f507e4537b2..dab4c5e45cbc 100644
--- a/databases/mysql54-server/Makefile
+++ b/databases/mysql54-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= ${MASTERPORTNAME}
PORTVERSION= 3.23.53
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.kernelnotes.de/MySQL/Downloads/MySQL-3.23/ \
@@ -72,6 +72,9 @@ CXXFLAGS= ${CFLAGS} -felide-constructors -fno-rtti
.if ${OSVERSION} >= 400002
CXXFLAGS+= -fno-exceptions
.endif
+.if ${OSVERSION} < 500000
+CONFIGURE_ENV+= CXX="${CC}"
+.endif
# MySQL-Server part
.if !defined(CLIENT_ONLY)