aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
Diffstat (limited to 'japanese')
-rw-r--r--japanese/esecanna/Makefile60
-rw-r--r--japanese/esecanna/distinfo2
-rw-r--r--japanese/esecanna/files/esecanna.sh20
-rw-r--r--japanese/esecanna/files/patch-ac23
-rw-r--r--japanese/esecanna/files/patch-ad52
-rw-r--r--japanese/esecanna/pkg-comment2
-rw-r--r--japanese/esecanna/pkg-descr23
-rw-r--r--japanese/esecanna/pkg-message29
-rw-r--r--japanese/esecanna/pkg-plist9
9 files changed, 161 insertions, 59 deletions
diff --git a/japanese/esecanna/Makefile b/japanese/esecanna/Makefile
index 7aeb8c305c0e..388292818380 100644
--- a/japanese/esecanna/Makefile
+++ b/japanese/esecanna/Makefile
@@ -1,51 +1,57 @@
-# New ports collection Makefile for: esecanna for VJE-Delta 3.0
-# Version required: 0.2.2
-# Date created: 29 January 2000
+# New ports collection Makefile for: esecanna
+# Version required: 0.13.0
+# Date created: 24 February 2000
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
-DISTNAME= esecanna-vje30_DR-0.2.2
-PKGNAME= ja-esecanna-vje30-0.2.2
+DISTNAME= esecanna_0.13.0
+PKGNAME= ja-esecanna-0.13.0
CATEGORIES= japanese
MASTER_SITES= http://www.idaemons.org/ports/distfiles/ \
- http://plaza.harmonix.ne.jp/~redstar/
+ http://esecanna.netfort.gr.jp/
MAINTAINER= knu@idaemons.org
-#RUN_DEPENDS= ${LOCALBASE}/vje30/bin/vjed:${PORTSDIR}/japanese/vje30-trial
+.include <bsd.port.pre.mk>
-DOCDIR= ${PREFIX}/share/doc/esecanna
+.if ${PORTOBJFORMAT} == "elf"
+SHLIB_VER= 1
+.else
+SHLIB_VER= 1.0
+.endif
+
+STARTER= esecanna.sh
+
+MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
-# Make sure of naming it proper so as to be invoked *after* vje.sh on startup
-STARTER= vjeesecannaserver.sh
+PLIST_SUB= SHLIB_VER="${SHLIB_VER}" \
+ STARTER="${STARTER}"
post-extract:
- @perl -pe "s,!!PREFIX!!,${PREFIX},g" ${FILESDIR}/${STARTER} > ${WRKSRC}/${STARTER}
+ @perl -pe " \
+ s,!!PREFIX!!,${PREFIX},g; \
+ s,!!STARTER!!,${STARTER},g; \
+ " \
+ ${FILESDIR}/esecanna.sh > ${WRKSRC}/${STARTER}
do-configure:
@cd ${WRKSRC} && perl -i -pe " \
- s,/etc/esecannarc,${PREFIX}/etc/esecannarc,g; \
- s,/etc/vje30,${PREFIX}/etc/vje30,g; \
- s,/usr/lib/vje30,${PREFIX}/vje30,g; \
- s,/usr/sbin/vjed,${PREFIX}/vje30/bin/vjed,g; \
+ s,!!PREFIX!!,${PREFIX},g; \
" \
- 4DEVELOPERS.jp \
- esecannarc \
- imewrapper.c \
- vjewrapper.c
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/esecannaserver ${PREFIX}/sbin
- ${INSTALL_DATA} ${WRKSRC}/esecannarc ${PREFIX}/etc
- ${INSTALL_SCRIPT} ${WRKSRC}/${STARTER} ${PREFIX}/etc/rc.d
+ README.jp \
+ esecannarc
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${STARTER} ${PREFIX}/etc/rc.d/
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/4DEVELOPERS.jp ${WRKSRC}/README.jp ${DOCDIR}
+ ${MKDIR} ${PREFIX}/share/doc/esecanna
+ cd ${WRKSRC} && ${INSTALL_DATA} README.First.jp README.jp ${PREFIX}/share/doc/esecanna/
.endif
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/esecanna/distinfo b/japanese/esecanna/distinfo
index 0fdf19c3e4bf..3b758b0acd69 100644
--- a/japanese/esecanna/distinfo
+++ b/japanese/esecanna/distinfo
@@ -1 +1 @@
-MD5 (esecanna-vje30_DR-0.2.2.tar.gz) = 6e25521a11ac8d933c8e973b67947681
+MD5 (esecanna_0.13.0.tar.gz) = 7a7e8802c155da4e1a11203997834b34
diff --git a/japanese/esecanna/files/esecanna.sh b/japanese/esecanna/files/esecanna.sh
new file mode 100644
index 000000000000..8a9bf51da9a7
--- /dev/null
+++ b/japanese/esecanna/files/esecanna.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+if [ -f /usr/local/vje30/.version ] \
+ && grep -qw 'FREE TRIAL VERSION' /usr/local/vje30/.version \
+ && [ X"$1" != X"-f" ]; then
+ echo ""
+ echo "esecanna:"
+ echo " Using VJE-Delta 3.0 trial, it is unable to connect to vjed on startup."
+ echo " Please execute \`$0 -f' manually"
+ echo " after once you run vje."
+ exit
+fi
+
+esecannaserver="!!PREFIX!!/sbin/esecannaserver"
+
+if [ -x $esecannaserver ]; then
+ rm -f /tmp/.iroha_unix/IROHA
+ echo -n ' esecannai: '
+ $esecannaserver
+fi
diff --git a/japanese/esecanna/files/patch-ac b/japanese/esecanna/files/patch-ac
new file mode 100644
index 000000000000..ac8b7f47e1ee
--- /dev/null
+++ b/japanese/esecanna/files/patch-ac
@@ -0,0 +1,23 @@
+--- esecannarc.orig Fri Feb 25 16:02:52 2000
++++ esecannarc Sat Feb 26 00:04:26 2000
+@@ -1,10 +1,10 @@
+ ## これは えせかんな の総合設定ファイルであり、また、
+ ## ユーザー別設定ファイルのサンプルでもあります。
+-## 総合設定ファイルとして、/etc/esecannarc にないと起動しません。
++## 総合設定ファイルとして、!!PREFIX!!/etc/esecannarc にないと起動しません。
+
+ # IME.. VJE/ATOK/WNN どれをつかうか。
+ # ~/.esecannarc の場合は、そのユーザーがどの IME を使うかを指定するが、
+-# /etc/esecannarc の場合は、~/.esecannarc がない場合にどの IME を
++# !!PREFIX!!/etc/esecannarc の場合は、~/.esecannarc がない場合にどの IME を
+ # デフォルトで使うか、を指定する。
+ # VJE25:VJE30:ATOK:WNN6 のなかから指定。
+ IME=VJE25
+@@ -48,6 +48,6 @@
+
+ # 再起動時に実行するファイル名。総合設定ファイルのみ有効。
+ VJE25.RestartComm=/usr/local/vje/bin/vjed
+-VJE30.RestartComm=/usr/local/vje/bin/vjed
++VJE30.RestartComm=/usr/local/vje30/bin/vjed
+
+
diff --git a/japanese/esecanna/files/patch-ad b/japanese/esecanna/files/patch-ad
new file mode 100644
index 000000000000..cc3b33db295e
--- /dev/null
+++ b/japanese/esecanna/files/patch-ad
@@ -0,0 +1,52 @@
+--- README.jp.orig Fri Feb 25 02:22:33 2000
++++ README.jp Fri Feb 25 23:58:43 2000
+@@ -5,7 +5,7 @@
+
+ 1) えせかんなの設定
+
+-/etc/esecannarc はえせかんなのデフォルトの動作を定めます。重要なのは
++!!PREFIX!!/etc/esecannarc はえせかんなのデフォルトの動作を定めます。重要なのは
+ IME=xxxx
+ と書いてある行です。この行では、えせかんながデフォルトで接続を試みるかな漢字変
+ 換サーバーを指定します。かな漢字変換サーバーと、xxxx の対応は次の通りです。
+@@ -18,18 +18,18 @@
+ ATOK12 ATOK
+
+ 次にユーザーごとの設定です。ユーザーごとの設定は、そのユーザーのホームディレク
+-トリの .esecannarc というファイルで指定します。もしなければ、/etc/esecannarc
+-をコピーしてください。このファイルの
++トリの .esecannarc というファイルで指定します。もしなければ、
++!!PREFIX!!/etc/esecannarc をコピーしてください。このファイルの
+ IME=xxxx
+ という行は、そのユーザーが接続する変換サーバーを定めます。設定方法は
+-/etc/esecannarc の場合と同じです。
++!!PREFIX!!/etc/esecannarc の場合と同じです。
+ 他にも .esecannarc では色々と設定可能ですが、これは各モジュールの README.jp
+ を読んでください。
+
+ 2) 設定ファイルの優先順位
+
+- もし .esecannarc がある場合はそちらを優先します。ない場合 /etc/esecannarc を
+-使用します。
++ もし .esecannarc がある場合はそちらを優先します。ない場合
++!!PREFIX!!/etc/esecannarc を使用します。
+
+ 3) モジュールについて
+
+@@ -43,10 +43,7 @@
+
+ 4) 他
+
+- 起動時に自動で立ち上がるようにしたければ、/etc/rc.d/rc.local などに
+-esecannaserver
+-の一行を加えてください。cannaserver と同時に使うことは出来ないので注意してくだ
+-さい。
++cannaserver と同時に使うことは出来ないので注意してください。
+
+ えせかんなは /var/log/esecanna.log にログを吐きます。このログを見て、何が起き
+ てるのか、手がかりを得ることが出来ます。
+@@ -58,4 +55,4 @@
+ 大阪大学医学部医学科 学2 |
+ Debian JP Project | take@debian.or.jp
+ LILO, NetFort | take@netfort.gr.jp
+==========================================================
diff --git a/japanese/esecanna/pkg-comment b/japanese/esecanna/pkg-comment
index c6f46d18f664..f92dc0e8ad39 100644
--- a/japanese/esecanna/pkg-comment
+++ b/japanese/esecanna/pkg-comment
@@ -1 +1 @@
-Pseudo cannaserver which wraps VJE-delta server
+Pseudo cannaserver which wraps some other input engines
diff --git a/japanese/esecanna/pkg-descr b/japanese/esecanna/pkg-descr
index 075d446cd944..32fae848f706 100644
--- a/japanese/esecanna/pkg-descr
+++ b/japanese/esecanna/pkg-descr
@@ -1,22 +1,21 @@
-Esecanna-vje listens to canna clients as cannaserver,
-interprets to the VJE-Delta server what they say, and
-passes what it results to them.
+Esecanna pretends to be a cannaserver and listens to canna clients.
+It interprets to one of the VJE 3.0/2.5 or Wnn6 servers what they say,
+then passes through to them what it results.
-With this, you can use VJE-Delta's smart input engine
+You'll have to install one of the esecanna modules to run it.
+
+With this, you can use VJE 3.0/2.5 or Wnn6's smart input engine
also from the console applications.
- [ Canna clients ] (mule, jvim, etc.)
+ [ canna clients ] (mule, jvim, etc.)
|| /\
\/ ||
- [ esecanna-vje ] (esecannaserver)
+ [ esecanna ] (esecannaserver + {vje30,wnn6} module)
|| /\
\/ ||
- [ VJE-Delta server ] (vjed)
-
-Before running esecannaserver, don't forget to stop
-the "real" cannaserver, if running.
+ [ input engine ] (vjed or jserver)
-Further documentation is under /usr/local/share/doc/esecanna,
+Further documentation is under /usr/local/share/doc/esecanna/
and the following web site:
-WWW: http://plaza.harmonix.ne.jp/~redstar/esecanna.html
+WWW: http://esecanna.netfort.gr.jp/
diff --git a/japanese/esecanna/pkg-message b/japanese/esecanna/pkg-message
index fb2935993562..0adea1a5bf4f 100644
--- a/japanese/esecanna/pkg-message
+++ b/japanese/esecanna/pkg-message
@@ -1,20 +1,17 @@
************************************************************
-NOTE THAT THIS VERSION IS A VERY DEVELOPMENT RELEASE.
-
-First of all, never forget to read the documents located in
-/usr/local/share/doc/esecanna carefully. When and if you
-meet with any problem or strange behavior, please refer to
-the debug log stored in /var/log/esecannaserver.log or
-output to stderr if run by hand, and report it immediately
-to the author of esecanna, or the maintainer of the port.
-
-Thank you for understanding.
-
-* Using VJE-Delta 3.0 trial, esecannaserver will fail to
-* connect to vjed before once you run vje.
-
Quick Setup:
- Run /usr/local/etc/rc.d/vjeesecannaserver.sh as root.
+ Take the following step all as root.
+ 1) Install one of the esecanna-module ports
+ 2) Edit `/usr/local/etc/esecannarc'
+ 3) Run `/usr/local/etc/rc.d/zz.esecanna.sh'
+
Each user may want to configure the behavior by editing
- `~/.esecannarc', copied after `/usr/local/etc/esecannarc'.
+`~/.esecannarc', copied after `/usr/local/etc/esecannarc'.
+
+ If you find something strange with esecanna, please consult
+the log file `/var/log/esecanna.log'.
+
+Note:
+ Using VJE-Delta 3.0 trial, esecannaserver will fail to
+connect to vjed before once you run vje.
************************************************************
diff --git a/japanese/esecanna/pkg-plist b/japanese/esecanna/pkg-plist
index c9fd7fbf6c39..1a0a92806f9b 100644
--- a/japanese/esecanna/pkg-plist
+++ b/japanese/esecanna/pkg-plist
@@ -1,5 +1,10 @@
+etc/esecannarc
+etc/rc.d/%%STARTER%%
+lib/libesecanna.so
+lib/libesecanna.so.%%SHLIB_VER%%
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
sbin/esecannaserver
-share/doc/esecanna/4DEVELOPERS.jp
+share/doc/esecanna/README.First.jp
share/doc/esecanna/README.jp
-etc/rc.d/vjeesecannaserver.sh
@dirrm share/doc/esecanna