aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/milter-manager/Makefile6
-rw-r--r--mail/milter-manager/files/patch-configure11
2 files changed, 15 insertions, 2 deletions
diff --git a/mail/milter-manager/Makefile b/mail/milter-manager/Makefile
index fa4e72d8e03b..a4f5add55a93 100644
--- a/mail/milter-manager/Makefile
+++ b/mail/milter-manager/Makefile
@@ -3,6 +3,7 @@
PORTNAME= milter-manager
PORTVERSION= 2.0.7
+PORTREVERSION= 1
CATEGORIES= mail ruby
MASTER_SITES= SF/${PORTNAME}/${PORTNAME:S/-/%20/}/${PORTVERSION}
@@ -46,9 +47,10 @@ EXAMPLESDIR= ${WRKDIR}/examples
.endif
post-patch:
- ${FIND} ${WRKSRC} -type f -name Makefile.in -exec \
+ @${FIND} ${WRKSRC} -type f -name Makefile.in -exec \
${REINPLACE_CMD} -e "s#\$$(datadir)/@PACKAGE@#${DATADIR}#" \
-e "s#\$$(datarootdir)/\$$(PACKAGE)#${DATADIR}#" {} +
- ${REINPLACE_CMD} -e "s#\\\\\$$(pkgdatadir)/sample#${EXAMPLESDIR}#" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s#\\\\\$$(pkgdatadir)/sample#${EXAMPLESDIR}#" ${WRKSRC}/configure
+ @${RM} -r ${WRKSRC}/binding/ruby/glib-2.2.5
.include <bsd.port.mk>
diff --git a/mail/milter-manager/files/patch-configure b/mail/milter-manager/files/patch-configure
new file mode 100644
index 000000000000..73b3749bdcc6
--- /dev/null
+++ b/mail/milter-manager/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2016-01-20 02:07:12 UTC
++++ configure
+@@ -14169,7 +14169,7 @@ fi
+ end
+ end
+ ruby_glib2_path = ruby_glib2_gem.full_gem_path
+- print("-I ", File.join(ruby_glib2_path, "ext", "glib2"))')
++ print("-I ", File.join(ruby_glib2_path, "lib"))')
+ if test $? -eq 0; then
+ CFLAGS="$CFLAGS $RUBY_GLIB2_CFLAGS"
+ else