aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/ceres-solver/Makefile15
-rw-r--r--math/ceres-solver/distinfo8
-rw-r--r--math/ceres-solver/pkg-plist5
3 files changed, 16 insertions, 12 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index c6496db0631c..3098944e14a4 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -1,13 +1,9 @@
# $FreeBSD$
PORTNAME= ceres-solver
-DISTVERSION= 1.13.0
-PORTREVISION= 4
+DISTVERSION= 1.14.0
CATEGORIES= math
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES= f58eacf082dd.patch:-p1
-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Nonlinear least squares minimizer
@@ -23,6 +19,7 @@ USE_LDCONFIG= yes
SHEBANG_FILES= examples/slam/pose_graph_*/plot_results.py \
scripts/make_docs.py
CMAKE_ON= CXX11 BUILD_SHARED_LIBS
+CMAKE_OFF= BUILD_BENCHMARKS
LDFLAGS+= -Wl,--as-needed # -lccolamd -lcholmod -lrt from suitesparse
PLIST_SUB= VERSION=${DISTVERSION:C/rc.*//}
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME:S/-solver//}
@@ -32,8 +29,9 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= CUSTOM_BLAS EXAMPLES DOCS GFLAGS LAPACK OPENMP SCHUR TEST
OPTIONS_DEFAULT=CUSTOM_BLAS CXSPARSE OPENBLAS OPENMP SCHUR SUITESPARSE
-OPTIONS_RADIO= LAPACK
+OPTIONS_RADIO= LAPACK THREADS
OPTIONS_RADIO_LAPACK= ATLAS GOTOBLAS NETLIB OPENBLAS
+OPTIONS_RADIO_THREADS= OPENMP TBB
OPTIONS_GROUP= SPARSE
OPTIONS_GROUP_SPARSE= CXSPARSE EIGENSPARSE SUITESPARSE
@@ -59,6 +57,10 @@ OPENMP_VARS= OPENMP=gcc-
SCHUR_DESC= Fixed-size schur specializations
SCHUR_CMAKE_BOOL= SCHUR_SPECIALIZATIONS
+TBB_DESC= Intel threading building blocks
+TBB_LIB_DEPENDS= libtbb.so:devel/tbb
+TBB_CMAKE_BOOL= TBB
+
# XXX Unbundle googletest/googlemock
TEST_CMAKE_BOOL= BUILD_TESTING
TEST_TEST_TARGET= test ARGS="-V"
@@ -94,7 +96,6 @@ EIGENSPARSE_VARS= LICENSE+=LGPL21+ LICENSE_COMB=multi \
SUITESPARSE_DESC= SuiteSparse support
SUITESPARSE_LIB_DEPENDS=libspqr.so:math/suitesparse
SUITESPARSE_CMAKE_BOOL= SUITESPARSE
-SUITESPARSE_IMPLIES= LAPACK
post-patch-DOCS-on:
@${REINPLACE_CMD} -e 's,python,${PYTHON_CMD:T},' \
diff --git a/math/ceres-solver/distinfo b/math/ceres-solver/distinfo
index b94e5b4a92c4..414c93783849 100644
--- a/math/ceres-solver/distinfo
+++ b/math/ceres-solver/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1501744176
-SHA256 (ceres-solver-ceres-solver-1.13.0_GH0.tar.gz) = 51ccb201b61ac71501fb6ccef158f078a750bc796ee6a271cd535cfe338202e5
-SIZE (ceres-solver-ceres-solver-1.13.0_GH0.tar.gz) = 3586772
-SHA256 (f58eacf082dd.patch) = c372934476fae4a11e3a62f0037feeb65d01c27f05b95257b05335f4dfe999a6
-SIZE (f58eacf082dd.patch) = 2495
+TIMESTAMP = 1521691214
+SHA256 (ceres-solver-ceres-solver-1.14.0_GH0.tar.gz) = 1296330fcf1e09e6c2f926301916f64d4a4c5c0ff12d460a9bc5d4c48411518f
+SIZE (ceres-solver-ceres-solver-1.14.0_GH0.tar.gz) = 3654161
diff --git a/math/ceres-solver/pkg-plist b/math/ceres-solver/pkg-plist
index 3bb04fd0bed0..ed66052a2db3 100644
--- a/math/ceres-solver/pkg-plist
+++ b/math/ceres-solver/pkg-plist
@@ -3,6 +3,7 @@ include/ceres/autodiff_local_parameterization.h
include/ceres/c_api.h
include/ceres/ceres.h
include/ceres/conditioned_cost_function.h
+include/ceres/context.h
include/ceres/cost_function.h
include/ceres/cost_function_to_functor.h
include/ceres/covariance.h
@@ -12,6 +13,7 @@ include/ceres/dynamic_autodiff_cost_function.h
include/ceres/dynamic_cost_function.h
include/ceres/dynamic_cost_function_to_functor.h
include/ceres/dynamic_numeric_diff_cost_function.h
+include/ceres/evaluation_callback.h
include/ceres/fpclassify.h
include/ceres/gradient_checker.h
include/ceres/gradient_problem.h
@@ -40,6 +42,9 @@ include/ceres/problem.h
include/ceres/rotation.h
include/ceres/sized_cost_function.h
include/ceres/solver.h
+include/ceres/tiny_solver.h
+include/ceres/tiny_solver_autodiff_function.h
+include/ceres/tiny_solver_cost_function_adapter.h
include/ceres/types.h
include/ceres/version.h
lib/cmake/Ceres/CeresConfig.cmake
-0/+2 * Update to 5.3.4.Jung-uk Kim2017-06-221-5/+5 * Update the Calligra ports to 3.0.1.Raphael Kubo da Costa2017-06-175-90/+0 * - Update to 4.8Wen Heping2017-06-092-4/+4 * - Switch to options helpersDmitry Marakasov2017-06-031-3/+6 * Mark some ports failing on armv6, for errors classified as "clang".Mark Linimon2017-05-271-1/+2 * Update to 5.3.3.Jung-uk Kim2017-05-201-5/+5 * Update to 4.7.5Sunpoet Po-Chuan Hsieh2017-05-192-4/+4 * Update to 5.2.7.Jung-uk Kim2017-05-051-5/+5 * Chase ffmpeg 3.3 update (ABI changes)Thomas Zander2017-04-252-1/+2 * - Revert the php7 switch, we can't force users to switch to php7 yet.Martin Wilke2017-04-251-1/+0 * - Update to 4.7.4Martin Wilke2017-04-252-4/+5 * Rename the magic DISTVERSION into SPELLVERSION for the aspell ports.Mathieu Arnold2017-04-121-1/+1 * Remove obsolete PROJECTHOST.Mathieu Arnold2017-03-311-1/+0 * Update to 5.2.6.Jung-uk Kim2017-03-281-5/+5 * Remove all USE_OPENSSL occurrences.Mathieu Arnold2017-03-151-2/+1 * russian/wordpress: Update from 4.7.2 to 4.7.3Torsten Zuehlsdorff2017-03-072-4/+4 * - Bump PORTREVISION. Lazarus was update to 1.6.4Jose Alonso Cardenas Marquez2017-03-021-2/+2 * - Bump PORTREVISION. Freepascal was updatedJose Alonso Cardenas Marquez2017-02-271-2/+1 * Update to 5.2.5.Jung-uk Kim2017-02-011-5/+5 * Update to 4.7.2Sunpoet Po-Chuan Hsieh2017-01-282-4/+4 * Update WWW: SF redirects to https://sourceforge.net/projects/<PROJECT_NAME>/Sunpoet Po-Chuan Hsieh2017-01-213-3/+3 * Extract do-patch into a separate script.Mathieu Arnold2017-01-171-2/+1 * Update to 4.7.1Sunpoet Po-Chuan Hsieh2017-01-152-4/+4 * Update to 5.2.4.Jung-uk Kim2017-01-021-5/+5 * - Mark BROKEN on 11.x:Dmitry Marakasov2016-12-291-11/+6 * - Update to 4.7Sunpoet Po-Chuan Hsieh2016-12-162-4/+4 * Remove libiconv.so.3 compatibility link that was added in r374303 toTijl Coosemans2016-12-091-1/+1 * Don't quote {} in find -exec calls.Mathieu Arnold2016-12-011-1/+1 * - Update to 0.28Jose Alonso Cardenas Marquez2016-11-222-5/+6 * devel/eric6: update to 6.1.11David Naylor2016-11-191-3/+3 * Update libreoffice to 5.2.3 and liborcus to 0.11.2Baptiste Daroussin2016-11-121-4/+5 * Mark as broken on aarch64. While here, pet portlint.Mark Linimon2016-11-111-5/+6 * ${RM} already has -f.Mathieu Arnold2016-10-211-1/+1 * Reassign makc's ports back to the pool.Raphael Kubo da Costa2016-10-204-4/+4 * devel/eric6: update to 6.1.10.David Naylor2016-10-101-3/+3 * russian/fortuneru: Once again, mark this port BROKEN (unfetchable)John Marino2016-09-201-0/+2 * Revert recent strfile changes, strfile is already in baseAntoine Brodin2016-09-151-9/+11 * russian/fortuneru: Use fortune_strfile instead of strfile(8) and mark BROKENJohn Marino2016-09-141-11/+9 * - Update to 4.6.1Dmitry Marakasov2016-09-082-4/+4 * - Update to 4.6Dmitry Marakasov2016-09-072-8/+6 * devel/eric6: update to 6.1.9David Naylor2016-09-061-3/+3 * russian/xruskb: revbump required after previous changesJohn Marino2016-09-011-1/+1 * - Add LICENSEDmitry Marakasov2016-08-263-11/+11 * devel/eric6: update to 6.1.8.David Naylor2016-08-201-3/+3 * Prevent collision with getline(3)Baptiste Daroussin2016-07-301-0/+29 * Site changed to httpsAndrey A. Chernov2016-07-231-1/+1 * Cleanup $() variables in ports Makefiles.Mathieu Arnold2016-07-201-1/+1 * Remove expired ports without open PRs:Rene Ladan2016-07-058-68/+0 * eric6 ports: Update to version 6.1.7.Boris Samorodov2016-07-051-3/+3 * - Update to 4.5.3 [1]Dmitry Marakasov2016-06-232-9/+9 * eric6 ports: Update to version 6.1.6.Boris Samorodov2016-06-061-2/+3 * Deprecate ports broken for more than 6 monthsAntoine Brodin2016-06-042-0/+5 * Many KDE i10n ports: Patch updates CURDIRKurt Jaeger2016-05-261-1/+1 * editors/calligra-l10n: add plist-subKurt Jaeger2016-05-242-71/+71 * Cleanup some other NO_PACKAGE madness.Mathieu Arnold2016-05-241-1/+0 * - Fix trailing whitespace in pkg-messagesDmitry Marakasov2016-05-191-1/+1 * - Fix trailing whitespace in pkg-descrs, categories [p-x]*Dmitry Marakasov2016-05-19