aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/linux-telegram-desktop/Makefile6
-rw-r--r--net-im/linux-telegram-desktop/distinfo6
-rw-r--r--net-im/linux-telegram-desktop/files/telegram-desktop.sh.in5
3 files changed, 11 insertions, 6 deletions
diff --git a/net-im/linux-telegram-desktop/Makefile b/net-im/linux-telegram-desktop/Makefile
index ae00110850ad..2d2e9614cffc 100644
--- a/net-im/linux-telegram-desktop/Makefile
+++ b/net-im/linux-telegram-desktop/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= telegram-desktop
-PORTVERSION= 1.1.7
+PORTVERSION= 1.1.23
CATEGORIES= net-im linux
-MASTER_SITES= https://updates.tdesktop.com/tlinux32/ \
- http://freebsd.nsu.ru/distfiles/
+MASTER_SITES= https://updates.tdesktop.com/tlinux32/
PKGNAMEPREFIX= linux-
DISTNAME= tsetup32.${PORTVERSION}
@@ -17,6 +16,7 @@ LICENSE= GPLv3
USES= linux:c7 tar:xz
USE_LINUX= alsalib alsa-plugins-oss dbuslibs dri expat gtk2 xorglibs
NO_BUILD= yes
+RUN_DEPENDS= dbus-launch:devel/dbus
WRKSRC= ${WRKDIR}/Telegram
TDESKTOPDIR= lib/telegram-desktop
diff --git a/net-im/linux-telegram-desktop/distinfo b/net-im/linux-telegram-desktop/distinfo
index 2184fb0ccb68..72466d92f444 100644
--- a/net-im/linux-telegram-desktop/distinfo
+++ b/net-im/linux-telegram-desktop/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496182037
-SHA256 (tsetup32.1.1.7.tar.xz) = 49db49c089efa680e8ce68ee7153e7a3f601e485a1305857f5cf1b13a5e7e5b0
-SIZE (tsetup32.1.1.7.tar.xz) = 30618984
+TIMESTAMP = 1506705339
+SHA256 (tsetup32.1.1.23.tar.xz) = d3a93bd958e3e692e39c9744e62a967e42ee089c68a106a3ab236937252111ef
+SIZE (tsetup32.1.1.23.tar.xz) = 31249588
diff --git a/net-im/linux-telegram-desktop/files/telegram-desktop.sh.in b/net-im/linux-telegram-desktop/files/telegram-desktop.sh.in
index 1bbc4d442490..87dad4e4b9d8 100644
--- a/net-im/linux-telegram-desktop/files/telegram-desktop.sh.in
+++ b/net-im/linux-telegram-desktop/files/telegram-desktop.sh.in
@@ -1,4 +1,9 @@
#!/bin/sh
+if [ "$DBUS_SESSION_BUS_ADDRESS" = "" ]; then
+ eval `dbus-launch --sh-syntax`
+fi
+
+mkdir -p $HOME/.local/share/TelegramDesktop/tdata
export QT_XKB_CONFIG_ROOT=%%PREFIX%%/share/X11/xkb
exec %%PREFIX%%/%%TDESKTOPDIR%%/Telegram "$@"