aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/valknut/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/net-p2p/valknut/Makefile b/net-p2p/valknut/Makefile
index 4005976b7f5f..c7bb581864e6 100644
--- a/net-p2p/valknut/Makefile
+++ b/net-p2p/valknut/Makefile
@@ -33,6 +33,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libdc=${LOCALBASE} \
--x-libraries=${LOCALBASE}/lib \
--x-includes=${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}