aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/qt5-gtkplatform/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/qt5-gtkplatform/Makefile')
-rw-r--r--x11-toolkits/qt5-gtkplatform/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-toolkits/qt5-gtkplatform/Makefile b/x11-toolkits/qt5-gtkplatform/Makefile
new file mode 100644
index 000000000000..dca8d8c816c1
--- /dev/null
+++ b/x11-toolkits/qt5-gtkplatform/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= gtkplatform
+DISTVERSION= 0.2.2
+CATEGORIES= x11-toolkits
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= GTK platform backend for Qt 5
+
+LICENSE= LGPL3 GPLv2+
+LICENSE_COMB= dual
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libinput.so:x11/libinput \
+ libmtdev.so:devel/libmtdev \
+ libnotify.so:devel/libnotify \
+ libudev.so:devel/libudev-devd \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= qmake:outsource pkgconfig
+USE_GNOME= gtk30 cairo gdkpixbuf2
+USE_QT5= buildtools_build core gui widgets dbus
+USE_XORG= x11 xext xrender
+USE_GL= gl egl
+
+USE_GITHUB= yes
+GH_ACCOUNT= CrimsonAS
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/qt5/plugins/platforms/libqgtk.so
+
+.include <bsd.port.mk>