aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/wxgtk30/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/x11-toolkits/wxgtk30/Makefile b/x11-toolkits/wxgtk30/Makefile
index 75a42e6071ef..41b541d696ec 100644
--- a/x11-toolkits/wxgtk30/Makefile
+++ b/x11-toolkits/wxgtk30/Makefile
@@ -11,15 +11,19 @@ DISTNAME= wxWidgets-${PORTVERSION}
MAINTAINER= portmaster@bsdforge.com
COMMENT= The wxWidgets GUI toolkit with GTK+ bindings
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/docs/gpl.txt
+
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff \
libexpat.so:textproc/expat2
-USES= compiler:c++11-lib gmake iconv jpeg pkgconfig tar:bzip2
+USES= compiler:c++11-lib gmake iconv jpeg localbase pkgconfig tar:bzip2
USE_XORG= x11 sm xxf86vm xinerama
USE_GL= glu
USE_GNOME= gtk20
USE_LDCONFIG= yes
+USE_CXXSTD= c++11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libpng=sys \
--with-libjpeg=sys \
@@ -35,10 +39,6 @@ CONFIGURE_ARGS= --with-libpng=sys \
CONFIGURE_ENV= X11BASE="${LOCALBASE}" \
ac_cv_header_sys_inotify_h=no
-CPPFLAGS+= -I${LOCALBASE}/include
-CXXFLAGS+= -std=c++11
-LIBS+= -L${LOCALBASE}/lib
-
OPTIONS_DEFINE= GSTREAMER MSPACK NLS WEBKIT
OPTIONS_DEFAULT=GSTREAMER MSPACK WEBKIT
MSPACK_DESC= Microsoft archives support