aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-06-09 17:28:44 +0800
committerEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-06-09 17:28:44 +0800
commit8944f13286ba5293781f2d57980da284cb2aa29d (patch)
tree91aa682420a072399f03ac7fb456f62c13064add /configure.ac
parent981a1377f660a9d1e3660dc66613b993b78486fc (diff)
parent3f52e59aa058c16a9ba115398681a16b1e289cd1 (diff)
downloadgsoc2013-empathy-8944f13286ba5293781f2d57980da284cb2aa29d.tar.gz
gsoc2013-empathy-8944f13286ba5293781f2d57980da284cb2aa29d.tar.zst
gsoc2013-empathy-8944f13286ba5293781f2d57980da284cb2aa29d.zip
Merge branch 'call'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 41 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3e998de91..a8a272be1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,7 @@ FOLKS_REQUIRED=0.5.1
GLIB_REQUIRED=2.28.0
GNUTLS_REQUIRED=2.8.5
GTK_REQUIRED=3.0.2
+GSTREAMER_REQUIRED=0.10.32
KEYRING_REQUIRED=2.26.0
GCR_REQUIRED=2.91.4
LIBCANBERRA_GTK_REQUIRED=0.25
@@ -62,6 +63,15 @@ GNOME_CONTROL_CENTER_REQUIRED=2.31.4
#ifelse(empathy_released, 1, [], [enable_maintainer_mode="yes"])
#GNOME_MAINTAINER_MODE_DEFINES
+# telepathy-yell
+prev_top_build_prefix=$ac_top_build_prefix
+prev_ac_configure_args=$ac_configure_args
+ac_configure_args="$ac_configure_args --disable-shared-library"
+AX_CONFIG_DIR([telepathy-yell])
+ac_top_build_prefix=$prev_top_build_prefix
+ac_configure_args=$prev_ac_configure_args
+export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:"$ac_top_build_prefix"telepathy-yell/telepathy-yell
+
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_SRCDIR([configure.ac])
@@ -154,7 +164,7 @@ PKG_CHECK_MODULES(EMPATHY,
gmodule-export-2.0
gobject-2.0
gsettings-desktop-schemas
- gstreamer-0.10
+ gstreamer-0.10 >= $GSTREAMER_REQUIRED
gstreamer-interfaces-0.10
libxml-2.0
telepathy-glib >= $TELEPATHY_GLIB_REQUIRED
@@ -166,6 +176,8 @@ PKG_CHECK_MODULES(EMPATHY,
gcr-3 >= $GCR_REQUIRED
])
+PKG_CHECK_MODULES(YELL, [telepathy-yell])
+
PKG_CHECK_MODULES(EMPATHY_AV,
[
farsight2-0.10
@@ -173,6 +185,32 @@ PKG_CHECK_MODULES(EMPATHY_AV,
])
# -----------------------------------------------------------
+# Call interface
+# -----------------------------------------------------------
+AC_ARG_WITH(call,
+ AC_HELP_STRING([--enable-call=@<:@no/yes/auto@:>@],
+ [build with Call interface support]),,
+ [with_call=auto])
+if test "x$with_call" != "xno" ; then
+ PKG_CHECK_MODULES(EMPATHY_CALL,
+ [
+ farsight2-0.10
+ telepathy-farstream
+ ], have_farstream="yes", have_farstream="no" )
+
+ if test "x$have_farstream" = "xyes"; then
+ AC_DEFINE(HAVE_CALL, 1, [Define if you have Call channel support])
+ fi
+else
+ have_farstream=no
+fi
+
+if test "x$with_call" = "xyes" -a "x$have_farstream" != "xyes"; then
+ AC_MSG_ERROR([Could not find Call handler dependencies.])
+fi
+AM_CONDITIONAL(HAVE_CALL, test "x$have_farstream" = "xyes")
+
+# -----------------------------------------------------------
# evolution-data-server (about-me)
# -----------------------------------------------------------
AC_ARG_WITH(eds,
@@ -556,7 +594,7 @@ Configure summary:
Location awareness (Geoclue): ${have_geoclue}
Geocode support (Geoclue): ${have_geocode}
Adium themes (Webkit).......: ${have_webkit}
- Meego widgets ..............: ${have_meego}
+ Meego widgets...............: ${have_meego}
Control center embedding....: ${have_control_center_embedding}
Cheese webcam support ......: ${have_cheese}
@@ -567,4 +605,5 @@ Configure summary:
Extras:
Nautilus-sendto plugin......: ${have_nst}
Salut E-D-S support.........: ${with_eds}
+ Exp. Call channel handler...: ${have_farstream}
"
n> * Sync with new bsd.autotools.mkade2004-06-051-0/+1 * - WITHOUT_NLS-knob [1]vs2004-05-172-118/+121 * - Use USE_ICONV knobkrion2004-03-311-2/+3 * Whoa there, boy, that's a mighty big commit y'all have there...ade2004-03-141-1/+1 * Unbreak by fixing bug introduced in rev 1.45, which attempted tonectar2004-03-061-1/+2 * o Update to 1.5.6.nork2004-03-014-22/+11 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-041-3/+3 * Now gettext 0.12.1 is gettext-old.trevor2004-01-241-2/+2 * - don't clobber any given LDFLAGSdinoex2003-09-031-2/+2 * Bump the PORTREVISION for the ports directly affected by the gettext upgrade.marcus2003-08-271-0/+1 * Chase the libintl.so shared lib version.marcus2003-08-251-1/+1 * Update to 1.5.4.nork2003-04-034-9/+25 * De-pkg-comment.knu2003-02-212-1/+1 * Update to 1.5.3 and change MAINTAINER's mail address.nork2003-02-154-22/+23 * Now that AUTOCONF and friends contain slashes in them, use a separatorknu2002-11-291-6/+7 * Chase shlib rev of devel/gettextade2002-08-021-1/+1 * moving saslv1 includes files to make it easier to add saslv2ume2002-07-291-1/+1 * Update to 1.5.1.j1pat2002-06-248-100/+185 * Update to 1.3.99.j1.knu2002-05-233-24/+18 * gettext upgrade uber-patch (stage 3)ade2002-04-131-2/+3 * Update to 1.3.28.j1pat2002-04-023-15/+18 * Iconv cleanup, stage 2a: remove patches that only replacing <iconv.h> withsobomax2002-03-186-104/+0 * Bump PORTREVISION to reflect the (lib)iconv upgrade.knu2002-03-181-0/+1 * Iconv cleanup, stage 1b: correct {BUILD,LIB,RUN}_DEPENDS of all ports that needsobomax2002-03-181-1/+1 * Stage 1 of gettext update.ade2002-03-161-2/+2 * Update to 1.3.27.j2pat2002-02-134-13/+13 * o update to 1.3.25.sf2002-01-174-12/+18 * Update to 1.3.24dwcjr2001-12-097-14/+37 * o USE_AUTO* police sweeplioux2001-12-031-1/+6 * Update to 1.3.23dwcjr2001-10-192-6/+6 * Update to 1.3.22.1.j0.knu2001-09-124-26/+28 * Update 1.3.20.ja0.knu2001-08-134-37/+10 * Update to latest version (1.3.19)dwcjr2001-06-257-38/+69 * upgrade to ja-mutt-1.3.18.j0ijliao2001-05-233-20/+20 * Update to 1.3.17.knu2001-04-092-4/+12 * o update to 1.3.16.j0.sf2001-03-107-26/+49 * update to 1.3.14i-ja0.sf2001-02-1510-23/+23 * update to 1.3.13i-j0.sf2001-01-293-5/+6 * Update to 1.3.11.j0.knu2000-11-142-3/+3 * Update to version 1.3.10.j0jeh2000-10-222-6/+5 * Update to 1.3.10-ja0-beta1nakai2000-10-173-70/+29 * Add one command (flea) and its manpage.asami2000-10-10