aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorPeter Williams <peterw@src.gnome.org>2000-06-29 23:59:20 +0800
committerPeter Williams <peterw@src.gnome.org>2000-06-29 23:59:20 +0800
commit8ba0e76ccb80df199a04f8b9d60afcf7e5930666 (patch)
treee96a3fc4e2417b00fa697a479844e1517de2165e /calendar/gui/Makefile.am
parentd2875d9e05b5d20e7f8a5d5300dfc9e83de7b7bc (diff)
downloadgsoc2013-evolution-8ba0e76ccb80df199a04f8b9d60afcf7e5930666.tar.gz
gsoc2013-evolution-8ba0e76ccb80df199a04f8b9d60afcf7e5930666.tar.zst
gsoc2013-evolution-8ba0e76ccb80df199a04f8b9d60afcf7e5930666.zip
Make the pilot stuff in calendar/gui optional.
svn path=/trunk/; revision=3793
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index b7c6082f99..d3f8410595 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -2,6 +2,14 @@ SUBDIRS = dialogs
help_base = $(datadir)/gnome/help/cal
+if HAVE_GNOME_PILOT
+CPS = calendar-pilot-sync #empty-pilot-calendar
+else
+CPS =
+endif
+
+bin_PROGRAMS = evolution-calendar $(CPS)
+
CPPFLAGS = \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\"
@@ -16,6 +24,7 @@ INCLUDES = \
-I$(includedir) \
$(BONOBO_VFS_GNOME_CFLAGS) \
$(GNOME_CONDUIT_INCLUDEDIR) \
+ $(GNOME_PILOT_CFLAGS) \
$(PISOCK_INCLUDEDIR) \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\"
@@ -23,6 +32,8 @@ INCLUDES = \
LINK_FLAGS = \
$(BONOBO_VFS_GNOME_LIBS) \
$(INTLLIBS) \
+ $(GNOME_PILOT_LIBS) \
+ $(PISOCK_LIBS) \
dialogs/libcal-dialogs.a \
$(top_builddir)/calendar/cal-client/libcal-client.la \
$(top_builddir)/calendar/cal-util/libcal-util.la \
@@ -40,7 +51,6 @@ glade_DATA = \
glade_messages = event-editor-dialog.glade.h
-bin_PROGRAMS = evolution-calendar calendar-pilot-sync #empty-pilot-calendar
# calendar-conduit-control-applet
evolution_calendar_SOURCES = \
@@ -101,7 +111,7 @@ evolution_calendar_LDADD = \
evolution_calendar_LDFLAGS = `gnome-config --libs gdk_pixbuf`
-
+if HAVE_GNOME_PILOT
calendar_pilot_sync_SOURCES = \
calendar-pilot-sync.c
@@ -111,6 +121,7 @@ calendar_pilot_sync_LDADD = -lpisock \
$(BONOBO_HTML_GNOME_LIBS) \
$(LINK_FLAGS)
+endif
#empty_pilot_calendar_SOURCES = \
# empty-pilot-calendar.c
etunicode-web1 2004.04.30, 100% Viet Unicode & Vietrafan2007-01-084-0/+53 * Update to KDE 3.5.5 / KOffice 1.6.1lofi2006-12-201-3/+3 * - Respect X11BASErafan2006-12-022-15/+12 * KDE 3.5.4 / KOffice 1.5.2lofi2006-09-132-3/+6 * All dictionaries can be installed separately:thierry2006-07-154-7/+18 * Update to KDE 3.5.3lofi2006-06-063-162/+100 * SHA256ifyedwin2006-01-2414-0/+16 * Update to KDE 3.5.0lofi2006-01-091-0/+1 * Remove expired ports.lawrance2005-12-155-73/+0 * Bump PORTREVISION to chase the glib20 shared library update.marcus2005-11-051-0/+1 * Unbreak by fixing pkg-plist and aligning run-depends statement.edwin2005-11-042-8/+5 * Unbreak port by fixing pkg-plistedwin2005-11-042-5/+2 * Respect X11BASEmnag2005-10-273-11/+26 * Mark as BROKEN: unfetchable.linimon2005-10-121-1/+5 * Update to KDE 3.4.2 / KOffice 1.4.1lofi2005-08-011-1/+1 * This port is scheduled for deletion on 2005-09-22 if it is still brokenkris2005-07-232-0/+4 * The grand-daddy site of VietNet gone :~-( R.I.P. media.mit.eduobrien2005-07-171-1/+2 * Watch over this VN port.obrien2005-07-171-1/+1 * The grand-daddy site of VietNet gone :~-( R.I.P. media.mit.eduobrien2005-07-175-10/+6 * The grand-daddy site of VietNet gone :~-( R.I.P. media.mit.eduobrien2005-07-171-2/+1 * Move to using the bzip2'ed distfile.obrien2005-07-172-2/+3 * At Kris's request, back out the MACHINE_ARCH spelling correction untilobrien2005-04-121-1/+1 * Assist getting more ports working on AMD64 by obeying theobrien2005-04-111-1/+1 * BROKEN: Broken dependencykris2005-03-271-0/+2 * Upgrade to 0.2.9.thierry2005-03-164-10/+10 * Bump PORTREVISION to chase the glib20 shared lib version change.marcus2005-03-121-0/+1 * BROKEN: Incomplete pkg-plistkris2005-02-281-0/+2 * Add ports to ${SUBDIR} in alphabetical order.cperciva2005-01-301-2/+2 * Portlint.obrien2004-12-302-2/+2 * Portlint.obrien2004-12-301-1/+1 * Add xvnkb 0.2.8, a Vietnamese input method for X-Window.thierry2004-12-3010-0/+306 * Update to KDE 3.3.2lofi2004-12-141-1/+1 * Update to KDE 3.3lofi2004-08-311-1/+1 * Add slaves ports for Aspell's new dictionaries.thierry2004-08-293-0/+22 * - Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,anholt2004-07-243-20/+10 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+2 * SIZEify (maintainer timeout)trevor2004-03-3113-0/+14 * Update to KDE 3.2.1 / QT 3.3.1lofi2004-03-102-2/+1 * - rpm2cpio.pl need to be EXTRACT_DEPENDS otherwise it will not workpav2004-03-021-1/+1 * Update to KDE 3.2.0lofi2004-02-053-5/+6 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-041-2/+2 * Now gettext 0.12.1 is gettext-old.trevor2004-01-241-1/+1 * Use the CPIO macro defined in bsd.port.mk.trevor2004-01-221-1/+1 * Use the SORT macro from bsd.port.mk.trevor2004-01-221-1/+1 * s/rpm2cpio/rpm2cpio.pl/ after the recent update of archivers/rpm2cpio (thenetchild2003-12-121-2/+2 * Another last minute change. Size/date stamp changes only.will2003-09-281-1/+1 * Upgrade to Qt 3.2.1 / KDE 3.1.4. See x11/kde3/Makefile rev 1.64 for details.will2003-09-181-2/+1 * Update this port from being based on the X11 R6.5.1 sources to R6.6.obrien2003-08-182-3/+4 * Remove the _POSIX_SOURCE handling to fix the building on 5-CURRENT.obrien2003-08-182-6/+2 * Update KDE to the latest official release, KDE 3.1.3lofi2003-07-292-1/+63 * Fix PLISTlioux2003-06-131-1/+17 * Update to KDE 3.1.2lioux2003-05-201-1/+1 * Add a NO_VIET_KDE knob to avoid the KDE I18N bits -- otherwise it is hard toobrien2003-05-091-0/+2 * BROKEN: Does not compilekris2003-05-071-0/+2