aboutsummaryrefslogtreecommitdiffstats
path: root/camel/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2003-02-21 05:04:19 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2003-02-21 05:04:19 +0800
commitabada7e2cd02933caa7a2643c0771b3ee7a63cfe (patch)
treedef1c8730c5190323d408d2058a837da47bdc1fb /camel/Makefile.am
parent08c781ab889611a7b9ca1605b36361032cc80f7d (diff)
downloadgsoc2013-evolution-abada7e2cd02933caa7a2643c0771b3ee7a63cfe.tar.gz
gsoc2013-evolution-abada7e2cd02933caa7a2643c0771b3ee7a63cfe.tar.zst
gsoc2013-evolution-abada7e2cd02933caa7a2643c0771b3ee7a63cfe.zip
Call camel_iconv_init(). (camel_shutdown): Call camel_iconv_shutdown().
2003-02-20 Jeffrey Stedfast <fejj@ximian.com> * camel.c (camel_init): Call camel_iconv_init(). (camel_shutdown): Call camel_iconv_shutdown(). * camel-sasl-digest-md5.c (digest_response): Updated to use camel-iconv and the new camel-charset-map functions. * camel-mime-utils.c: Updated to use camel-iconv and the new camel-charset-map functions. * camel-mime-part-utils.c (check_html_charset): Use camel_charset_canonical_name() instead of e_iconv_charset_name() which is longer available. (convert_buffer): Use camel-iconv. (simple_data_wrapper_construct_from_parser): Since camel_charset_iso_to_windows() returns the charset in it's canonical format, no need to re-canonicalise it. * camel-mime-part.c (process_header): Use camel_charset_canonical_name() instead of e_iconv_charset_name() which is longer available. * camel-mime-message.c (process_header): Use camel_charset_canonical_name() instead of e_iconv_charset_name() which is longer available. * camel-mime-filter-charset.c: Use camel-iconv. * camel-folder-summary.c (message_info_new): Use camel_charset_canonical_name() instead of e_iconv_charset_name() which is longer available. (content_info_new): Use camel_charset_locale_name(). (camel_message_info_new_from_header): Same as message_info_new(). * camel-search-private.c: Use g_alloca() instead of alloca(). * camel-filter-search.c (check_header): Use camel_charset_canonical_name() instead of e_iconv_charset_name() which is longer available. * camel-charset-map.c (camel_charset_locale_name): New function, replaces e_iconv_locale_charset(). (camel_charset_canonical_name): New function, similar to e_iconv_charset_name() but instead of returning the iconv-friendly name, it returns the canonical name. (g_iconv will do the iconv-friendly name conversions for us). svn path=/trunk/; revision=19977
Diffstat (limited to 'camel/Makefile.am')
-rw-r--r--camel/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/camel/Makefile.am b/camel/Makefile.am
index 119798b233..7192e5e48a 100644
--- a/camel/Makefile.am
+++ b/camel/Makefile.am
@@ -47,6 +47,7 @@ libcamel_la_SOURCES = \
camel-gpg-context.c \
camel-html-parser.c \
camel-http-stream.c \
+ camel-iconv.c \
camel-index.c \
camel-internet-address.c \
camel-lock.c \
@@ -148,6 +149,7 @@ libcamelinclude_HEADERS = \
camel-folder.h \
camel-gpg-context.h \
camel-http-stream.h \
+ camel-iconv.h \
camel-index.h \
camel-internet-address.h \
camel-i18n.h \
tw44/cgit/cgit.cgi/freebsd-ports-gnome/commit/Mk/bsd.kde4.mk?h=gstreamer0.10-removal&id=9e862f39478bb9c0b234a0cc4500a6726631a1e1'>Fixed botched setup of MASTER_SITE_KDE_kde. Damn was I stupid. I didn'talane2002-10-111-1/+10 * 1. Welcome to KDE 3.0.4.alane2002-10-111-1/+2 * Fix building of kdemultimedia3 on -CURRENT. Obtained from wca.seanc2002-09-161-1/+1 * Automagically mark kde2 ports as bork bork borked. If it really only needsalane2002-09-101-2/+2 * Remove USE_NEWGCC, which is no longer supported or required.kris2002-08-311-4/+0 * Update to 3.0.3. Not much changed here: [1] i18n PKGNAMEs converted towill2002-08-251-1/+1 * Update to 3.0.2 (full log):will2002-07-051-0/+7 * Get rid of old cruft that was inserted a long time ago to workaroundwill2002-06-171-3/+3 * Minor cleanups/fixes:will2002-05-121-3/+3 * Add back the qt145 port and support for qt-1.x. This should notkris2002-05-051-1/+13 * Say goodbye to Qt 1.x and all of its dependents. The one port I foundwill2002-04-191-31/+10 * (QT3/KDE3 only:) Use alternate dependency style; fix looking for qtwill2001-11-141-2/+3 * (QT3/KDE3 only:) Remove -lqt, this was a mistake.will2001-11-131-4/+5 * Good Will. \will2001-11-061-1/+1 * Slight modification to accomodate devel environment.will2001-11-051-1/+1 * Experimental support for the QT/KDE 3.x series.will2001-11-041-9/+47 * Fix glaring logic/typo bugs:will2001-04-151-19/+19 * Overhaul QT/KDE support:will2001-04-031-35/+41 * Fix bogon. Note to self: pay more attention to what you're doing.will2001-03-261-3/+0 * Fix variable usage and comments.will2001-03-261-9/+9