aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJP Rosevear <jpr@novell.com>2004-09-17 03:09:51 +0800
committerJP Rosevear <jpr@src.gnome.org>2004-09-17 03:09:51 +0800
commit1be35325c9ffebfbf5f872b4c889b3513f072179 (patch)
treeeec8832d9a82817e7525923cfb511e050ed95e33 /configure.in
parent62053f6698a4fd1cc261b6c07a7c3d8d766ca081 (diff)
downloadgsoc2013-evolution-1be35325c9ffebfbf5f872b4c889b3513f072179.tar.gz
gsoc2013-evolution-1be35325c9ffebfbf5f872b4c889b3513f072179.tar.zst
gsoc2013-evolution-1be35325c9ffebfbf5f872b4c889b3513f072179.zip
bump EDS and gal requirements
2004-09-16 JP Rosevear <jpr@novell.com> * configure.in: bump EDS and gal requirements svn path=/trunk/; revision=27282
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 20 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 890b641688..aa7e826c72 100644
--- a/configure.in
+++ b/configure.in
@@ -1076,19 +1076,24 @@ fi
dnl --- Required version numbers
-GAL_REQUIRED=2.2.0
+GAL_REQUIRED=2.3.0
+GAL_PACKAGE=2.4
GTKHTML_REQUIRED=3.2.0
-EDS_REQUIRED=0.0.99
+EDS_REQUIRED=1.1.0
+EDS_PACKAGE=1.2
BONOBOUI_REQUIRED=2.4.2
AC_SUBST(GAL_REQUIRED)
+AC_SUBST(GAL_PACKAGE)
AC_SUBST(GTKHTML_REQUIRED)
+AC_SUBST(GTKHTML_PACKAGE)
AC_SUBST(EDS_REQUIRED)
+AC_SUBST(EDS_PACKAGE)
AC_SUBST(BONOBOUI_REQUIRED)
dnl --- Flags to get all the GNOME stuff
-FULL_GNOME_DEPS="glib-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED gnome-vfs-2.0 libgnomeui-2.0 libglade-2.0 libgnomecanvas-2.0 libxml-2.0 gconf-2.0 gal-2.2 >= $GAL_REQUIRED"
+FULL_GNOME_DEPS="glib-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED gnome-vfs-2.0 libgnomeui-2.0 libglade-2.0 libgnomecanvas-2.0 libxml-2.0 gconf-2.0 gal-$GAL_PACKAGE >= $GAL_REQUIRED"
EVO_SET_COMPILE_FLAGS(GNOME_FULL, $FULL_GNOME_DEPS)
AC_SUBST(GNOME_FULL_CFLAGS)
@@ -1102,13 +1107,13 @@ CPPFLAGS="$CPPFLAGS_save"
dnl --- Flags for the various libraries we build
-EVO_SET_COMPILE_FLAGS(CAMEL, glib-2.0 gthread-2.0 gal-2.2 >= $GAL_REQUIRED $mozilla_nss,
+EVO_SET_COMPILE_FLAGS(CAMEL, glib-2.0 gthread-2.0 gal-2.4 >= $GAL_REQUIRED $mozilla_nss,
$THREADS_CFLAGS $KRB4_CFLAGS $KRB5_CFLAGS $MANUAL_NSS_CFLAGS $OPENSSL_CFLAGS,
$THREADS_LIBS $KRB4_LDFLAGS $KRB5_LDFLAGS $MANUAL_NSS_LIBS $OPENSSL_LDFLAGS)
AC_SUBST(CAMEL_CFLAGS)
AC_SUBST(CAMEL_LIBS)
-EVO_SET_COMPILE_FLAGS(CAMEL_GROUPWISE, libegroupwise-1.0 >= $EDS_REQUIRED,
+EVO_SET_COMPILE_FLAGS(CAMEL_GROUPWISE, libegroupwise-$EDS_PACKAGE >= $EDS_REQUIRED,
$CAMEL_CFLAGS,
$CAMEL_LIBS)
AC_SUBST(CAMEL_GROUPWISE_CFLAGS)
@@ -1129,19 +1134,19 @@ EVO_SET_COMPILE_FLAGS(CERT_UI, glib-2.0 gobject-2.0 gthread-2.0,
AC_SUBST(CERT_UI_CFLAGS)
AC_SUBST(CERT_UI_LIBS)
-EVO_SET_COMPILE_FLAGS(E_NAME, libgnomeui-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED gal-2.2 >= $GAL_REQUIRED)
+EVO_SET_COMPILE_FLAGS(E_NAME, libgnomeui-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED gal-$GAL_PACKAGE >= GAL_REQUIRED)
AC_SUBST(E_NAME_CFLAGS)
AC_SUBST(E_NAME_LIBS)
-EVO_SET_COMPILE_FLAGS(E_UTIL, gthread-2.0 gconf-2.0 libxml-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED libglade-2.0 gal-2.2 >= $GAL_REQUIRED libgnomeui-2.0 libgnome-2.0 libgnomecanvas-2.0 libedataserver-1.0 >= $EDS_REQUIRED $mozilla_nspr, $THREADS_CFLAGS $MANUAL_NSPR_CFLAGS, $THREADS_LIBS $MANUAL_NSPR_LIBS)
+EVO_SET_COMPILE_FLAGS(E_UTIL, gthread-2.0 gconf-2.0 libxml-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED libglade-2.0 gal-$GAL_PACKAGE >= GAL_REQUIRED libgnomeui-2.0 libgnome-2.0 libgnomecanvas-2.0 libedataserver-$EDS_PACKAGE >= $EDS_REQUIRED $mozilla_nspr, $THREADS_CFLAGS $MANUAL_NSPR_CFLAGS, $THREADS_LIBS $MANUAL_NSPR_LIBS)
AC_SUBST(E_UTIL_CFLAGS)
AC_SUBST(E_UTIL_LIBS)
-EVO_SET_COMPILE_FLAGS(TZDIALOG, libecal-1.0 >= $EDS_REQUIRED, $GNOME_FULL_CFLAGS, $GNOME_FULL_LIBS)
+EVO_SET_COMPILE_FLAGS(TZDIALOG, libecal-$EDS_PACKAGE >= $EDS_REQUIRED, $GNOME_FULL_CFLAGS, $GNOME_FULL_LIBS)
AC_SUBST(TZDIALOG_CFLAGS)
AC_SUBST(TZDIALOG_LIBS)
-EVO_SET_COMPILE_FLAGS(SOURCE_SEL, libedataserver-1.0 >= $EDS_REQUIRED, $GNOME_FULL_CFLAGS, $GNOME_FULL_LIBS)
+EVO_SET_COMPILE_FLAGS(SOURCE_SEL, libedataserver-$EDS_PACKAGE >= $EDS_REQUIRED, $GNOME_FULL_CFLAGS, $GNOME_FULL_LIBS)
AC_SUBST(SOURCE_SEL_CFLAGS)
AC_SUBST(SOURCE_SEL_LIBS)
@@ -1151,23 +1156,23 @@ dnl EVO_SET_COMPILE_FLAGS(E_WIDGETS, bonobo_conf bonobox_print gdk_pixbuf gnomec
dnl AC_SUBST(E_WIDGETS_CFLAGS)
dnl AC_SUBST(E_WIDGETS_LIBS)
dnl
-EVO_SET_COMPILE_FLAGS(IMPORTERS, gconf-2.0 libglade-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED libgnomeui-2.0 libebook-1.0 >= $EDS_REQUIRED)
+EVO_SET_COMPILE_FLAGS(IMPORTERS, gconf-2.0 libglade-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED libgnomeui-2.0 libebook-$EDS_PACKAGE >= $EDS_REQUIRED)
AC_SUBST(IMPORTERS_CFLAGS)
AC_SUBST(IMPORTERS_LIBS)
-EVO_SET_COMPILE_FLAGS(LIBFILTER, libgnome-2.0 libgnomeui-2.0 libglade-2.0 libxml-2.0 gconf-2.0 gal-2.2 >= $GAL_REQUIRED)
+EVO_SET_COMPILE_FLAGS(LIBFILTER, libgnome-2.0 libgnomeui-2.0 libglade-2.0 libxml-2.0 gconf-2.0 gal-$GAL_PACKAGE >= GAL_REQUIRED)
AC_SUBST(LIBFILTER_CFLAGS)
AC_SUBST(LIBFILTER_LIBS)
dnl --- evolution (shell) flags
-EVO_SET_COMPILE_FLAGS(SHELL, libgnome-2.0 libgnomeui-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED gal-2.2 >= $GAL_REQUIRED libglade-2.0 gnome-vfs-2.0 libgtkhtml-3.1 >= $GTKHTML_REQUIRED)
+EVO_SET_COMPILE_FLAGS(SHELL, libgnome-2.0 libgnomeui-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED gal-$GAL_PACKAGE >= GAL_REQUIRED libglade-2.0 gnome-vfs-2.0 libgtkhtml-3.1 >= $GTKHTML_REQUIRED)
AC_SUBST(SHELL_CFLAGS)
AC_SUBST(SHELL_LIBS)
dnl --- evolution-addressbook flags
-EVOLUTION_ADDRESSBOOK_DEPS="gconf-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED libglade-2.0 gal-2.2 >= $GAL_REQUIRED libgnomeui-2.0 libgnome-2.0 libgnomecanvas-2.0 gnome-vfs-2.0 libgnomeprintui-2.2 libgtkhtml-3.1 >= $GTKHTML_REQUIRED libebook-1.0 >= $EDS_REQUIRED"
+EVOLUTION_ADDRESSBOOK_DEPS="gconf-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED libglade-2.0 gal-$GAL_PACKAGE >= GAL_REQUIRED libgnomeui-2.0 libgnome-2.0 libgnomecanvas-2.0 gnome-vfs-2.0 libgnomeprintui-2.2 libgtkhtml-3.1 >= $GTKHTML_REQUIRED libebook-$EDS_PACKAGE >= $EDS_REQUIRED"
EVO_SET_COMPILE_FLAGS(EVOLUTION_ADDRESSBOOK, $EVOLUTION_ADDRESSBOOK_DEPS)
AC_SUBST(EVOLUTION_ADDRESSBOOK_CFLAGS)
@@ -1184,7 +1189,7 @@ EVO_SET_COMPILE_FLAGS(LIBSOUP, libsoup-2.2 >= 2.2.0)
AC_SUBST(LIBSOUP_CFLAGS)
AC_SUBST(LIBSOUP_LIBS)
-EVO_SET_COMPILE_FLAGS(EVOLUTION_CALENDAR, libgnome-2.0 libgnomeui-2.0 libbonoboui-2.0 gal-2.2 >= $GAL_REQUIRED libglade-2.0 gnome-vfs-2.0 libgnomeprint-2.2 libgnomeprintui-2.2 libgtkhtml-3.1 >= $GTKHTML_REQUIRED libebook-1.0 >= $EDS_REQUIRED libecal-1.0 >= $EDS_REQUIRED)
+EVO_SET_COMPILE_FLAGS(EVOLUTION_CALENDAR, libgnome-2.0 libgnomeui-2.0 libbonoboui-2.0 gal-$GAL_PACKAGE >= GAL_REQUIRED libglade-2.0 gnome-vfs-2.0 libgnomeprint-2.2 libgnomeprintui-2.2 libgtkhtml-3.1 >= $GTKHTML_REQUIRED libebook-$EDS_PACKAGE >= $EDS_REQUIRED libecal-$EDS_PACKAGE >= $EDS_REQUIRED)
AC_SUBST(EVOLUTION_CALENDAR_CFLAGS)
AC_SUBST(EVOLUTION_CALENDAR_LIBS)
@@ -1196,7 +1201,7 @@ fi
dnl --- evolution-mail flags
-EVO_SET_COMPILE_FLAGS(EVOLUTION_MAIL, libgnome-2.0 libgnomeui-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED gal-2.2 >= $GAL_REQUIRED libglade-2.0 gnome-vfs-module-2.0 libgnomeprint-2.2 libgnomeprintui-2.2 libgtkhtml-3.1 >= $GTKHTML_REQUIRED libxml-2.0 bonobo-activation-2.0 gthread-2.0 gconf-2.0 $mozilla_nss libebook-1.0 >= $EDS_REQUIRED)
+EVO_SET_COMPILE_FLAGS(EVOLUTION_MAIL, libgnome-2.0 libgnomeui-2.0 libbonoboui-2.0 >= $BONOBOUI_REQUIRED gal-$GAL_PACKAGE >= GAL_REQUIRED libglade-2.0 gnome-vfs-module-2.0 libgnomeprint-2.2 libgnomeprintui-2.2 libgtkhtml-3.1 >= $GTKHTML_REQUIRED libxml-2.0 bonobo-activation-2.0 gthread-2.0 gconf-2.0 $mozilla_nss libebook-$EDS_PACKAGE >= $EDS_REQUIRED)
AC_SUBST(EVOLUTION_MAIL_CFLAGS)
AC_SUBST(EVOLUTION_MAIL_LIBS)
n>1-0/+1 * The KDE/FreeBSD team is pleased to announce KDE Software CompilationAlberto Villa2011-10-171-0/+1 * - Added user and group to prepare for new port devel/trac-bittenGreg Larkin2011-10-141-0/+1 * Add the radns users/groupsBaptiste Daroussin2011-09-281-0/+1 * - Add for openerp-serverBeech Rintoul2011-09-021-0/+1 * Allow operator user to be used by a port.Chris Rees2011-08-241-0/+1 * mail/mixminion now uses USERSChris Rees2011-08-151-0/+1 * net/gini now uses USERSChris Rees2011-08-121-0/+1 * net/gatekeeper now uses USERS/GROUPSChris Rees2011-07-261-0/+1 * Add users for net-mgmt/zenossChris Rees2011-07-221-0/+1 * - add entry mail, so postix and clamav can in future the portsOlli Hauer2011-07-111-0/+1 * Add missing entries for tr-ircdChris Rees2011-07-091-0/+1 * audio/ventrilo-server now uses USERS and GROUPSChris Rees2011-07-081-0/+1 * ratbox-services now uses USERS and GROUPSChris Rees2011-07-061-0/+1 * - Fix a crash when an invalid log file is specified.Hiroki Sato2011-07-021-0/+1 * Remove duplicate dbxml line.Chris Rees2011-06-291-1/+0 * - Correct GROUP when postfix OPTION is selected [1]Chris Rees2011-06-141-0/+1 * Add GROUPS entry for games/conquestChris Rees2011-06-121-0/+1 * . Add entries for dbxml forgotten in databases/dbXML update.Greg Lewis2011-06-121-0/+1 * Add entries for ports which are converted to the new USERS paradigm.Rene Ladan2011-06-071-0/+10 * - add a current version of yate (3.3.2p1). This is not a repocopy ofFlorian Smeets2011-05-221-0/+1 * - Upgrade to 3.2.2.Jun Kuriyama2011-05-211-1/+1 * Fix format of _adsuck entry.Gerald Pfeifer2011-05-081-1/+1 * adsuck is a DNS relay that returns NXdomain for hosts that match names in aBaptiste Daroussin2011-05-071-0/+1 * - Updated to 3.0.0.b30 [1]Greg Larkin2011-05-041-0/+1 * - update to 2.8.3Baptiste Daroussin2011-04-241-0/+1 * Update webcamd to 0.1.24.Koop Mast2011-04-211-0/+1 * - Add _tcpproxy for new port net/tcpproxyDennis Herrmann2011-04-031-0/+1 * - rename hobbit to xymonDirk Meyer2011-04-021-1/+1 * - Pass -Dbsd_with_getifaddrs to CFLAGS in order to get a correct networkEmanuel Haupt2011-03-291-0/+1 * Reserve IDs for multimedia/vdr and related ports.Juergen Lock2011-03-271-0/+1 * Register uid and gid for net/get_iplayerBrendan Fabeny2011-03-091-0/+1 * - Register UID and GID for devel/jenkinsLi-Wen Hsu2011-03-071-0/+1 * - Register uid and gid for net/crtmpserverSylvio Cesar Teixeira2011-02-281-0/+1 * - Register uid and gid for net-mgmt/icingaChin-San Huang2011-02-241-0/+1 * - Register uid and gid for net/erlyvideoMartin Wilke2011-02-021-0/+1 * - register UID/GID 587 for assp user (port mail/assp)Olli Hauer2011-01-061-0/+1 * - Move torrus user to next unoccupied slotPav Lucistnik2010-12-241-1/+1 * - Upgrade to USERS/GROUPSPav Lucistnik2010-12-231-0/+1 * - register UID/GID 542 for _flowd user (port net-mgmt/flowd)Olli Hauer2010-12-211-0/+1 * Add the port of minidlna -- the DLNA-speaking service.Mikhail Teterin2010-12-141-0/+1 * Dont declare ${sancp_flags} in command_args.Wesley Shields2010-12-131-0/+1 * - add radmind with uid/gid 506 for port sysutils/radmindOlli Hauer2010-11-281-0/+1 * . Add a port of the 2.x series of Dovecot:Greg Lewis2010-11-271-0/+1 * * Sets up a uhub UID and GID for the daemon to run as.Stefan Walter2010-11-111-0/+1 * Remove "freeswitch" user from "dahdi" group for a while.Max Khon2010-11-081-1/+1 * Fix "dahdi" group gid.Max Khon2010-11-071-1/+1 * Add "asterisk" user/group and "dahdi" group.Max Khon2010-11-071-0/+2 * Add _tss and _pkcs11 to reserve for security/trousers andNorikatsu Shigemura2010-11-071-0/+2 * Finally upgrade amanda-{server,client} to 3.2.0. Old 2.6.x wasJun Kuriyama2010-11-011-0/+1 * - add RC scriptSteve Wills2010-10-111-0/+1 * Archiveopteryx is an Internet mail server, optimised to supportAshish SHUKLA2010-10-031-0/+1 * Update to 2010-07-R1Brendan Fabeny2010-10-031-0/+1 * BackupPC is a high-performance, enterprise-grade system for backing up Linux,Philip M. Gollucci2010-09-231-0/+1 * - Convert to USERS/GROUPSPhilip M. Gollucci2010-09-221-0/+1 * tWMS is a tiny WMS server written in Python and using tiles as aDmitry Marakasov2010-09-081-0/+1 * Use the USERS/GROUPS mechanismLars Thegler2010-08-121-0/+1 * - Add user/group shellinabox with uid/gid 139Philippe Audeoud2010-07-051-0/+1 * Add 'saned' user/group the Right Way.Stefan Walter2010-06-281-0/+1 * - Add activemq for new port net/activemqWen Heping2010-06-121-0/+1 * Add net/freeswitch-core, part of a revamp to the freeswitch portsJosh Paetzel2010-06-121-0/+1 * - add members for meta1c meta1mDirk Meyer2010-06-051-2/+2 * - Update to 0.7.3Pav Lucistnik2010-05-141-0/+1 * Remove trailing ':' from fossy.Wesley Shields2010-04-301-1/+1 * Add trailing ':' to drizzle and fossyWesley Shields2010-04-301-2/+2 * - Added user and group for Drizzle database serverGreg Larkin2010-04-291-0/+1 * - Reserve kumofs uid/gid.Jun Kuriyama2010-04-261-0/+1 * Minbif aims to use the libpurple library from the Pidgin projectBeat Gaetzi2010-04-151-0/+1 * - Add user and group mfs for MooseFS portWen Heping2010-04-071-0/+1 * - reserver GID/UID 924 for upcomming mail/postpalsIon-Mihai Tetcu2010-03-131-0/+1 * Massive cleanup of the Munin ports:Dag-Erling Smørgrav2010-02-251-0/+1 * - Add user and group for audio/liquidsoapWen Heping2010-02-011-0/+1 * - Update Wolfpack Empire to 4.3.23Johan van Selst2009-12-281-0/+1 * - Reserve UID/GID 137 for audio/musicpdPav Lucistnik2009-12-071-0/+1 * - Prepare for add new port databases/mongodbWen Heping2009-11-191-0/+1 * - Add 444 for callweaverPav Lucistnik2009-09-181-0/+1 * - Update to 0.8.5Beat Gaetzi2009-09-181-0/+1 * - Add UID/GID:211 for devel/py-gitosisNicola Vitale2009-09-161-0/+1 * Add haldaemon with UID/GID 560.Florent Thoumie2009-09-071-0/+1 * Add UID and GID forgotten while adding net-mgmt/noc.Boris Samorodov2009-08-181-0/+1 * Remove entries for security/trans-proxy-tor and security/dns-proxy-torErwin Lansing2009-08-161-2/+0 * Add prosody entries to UIDs & GIDs.Vanilla I. Shu2009-08-051-0/+1 * Register user/group "redis" for the port "databases/redis".Sergey Skvortsov2009-07-281-0/+1 * - Add fossy user/group for devel/fossology.Alejandro Pulver2009-07-241-0/+1 * -Add transmission.Jeremy Messenger2009-06-201-0/+1 * - Add GID and UID for emulators/virtualbox.Beat Gaetzi2009-06-181-0/+1 * - Add couchdb user and group.Wesley Shields2009-06-171-0/+1 * - Register net-mgmt/nefuRong-En Fan2009-04-071-0/+1 * - Register uid and gid for mail/prayerRong-En Fan2009-03-171-0/+1 * Reflect the change of UID/GID of ejabberd.Xin LI2009-03-161-1/+1 * Rework on rc script for www/httptunnel.Rong-En Fan2009-01-301-0/+1 * Register a fixed UID/GID for the user 'dhcpd' and use that instead of aStefan Walter2009-01-121-0/+1 * PLEASE WELCOME www/rt38Philip M. Gollucci2008-12-271-0/+1 * - Take maintainershipGreg Larkin2008-11-201-0/+1 * - Add UID and GID entries for net/rabbitmq.Wesley Shields2008-10-291-0/+1